Supprimer le cache des images (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 20 réponses, 6 participants et a été mis à jour pour la dernière fois par YannC, le il y a 8 années.
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #561846
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle:
    – Version de WordPress : 4.4.2
    – Version de PHP/MySQL : 5.6
    – Thème utilisé : Template Monster 56025
    – Extensions en place : Jetpacks, Chery Frameworks, Yoast SEO, MotoPress Slider
    – Nom de l’hebergeur : 1and1
    – Adresse du site : asi-online.info

    Problème(s) rencontré(s) : Nouveau sur ce forum, je suis en train de faire mon site Internet via WordPress et lorsque je souhaite supprimer des fichiers de ma bibliothèque de médias, le site conserve les anciennes versions de ces images (images fantômes) et je n’arrive pas à supprimer ces fantômes… Je télécharge les images depuis Filezilla et sur mon ordinateur, elles sont normales !!!!
    Je suis preneur de toutes solutions. Merci par avance

    #1051136
    zizanie
    Participant
    Chevalier WordPress
    321 contributions

    Bonjour,

    J’ai dû mal à comprendre votre question, puisque lorsque l’on se rend dans la bibliothèque d’images et que vous cliquez sur l’image que vous ne voulez plus, sur la droite on vous demande si vous voulez la « supprimer définitivement »

    #1051137
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    Bonjour et merci de vous intéresser à mon problème.
    Je vais tenter d’être un peu plus clair.
    Effectivement dans la bibliothèque, après sélection d’une image, il y a l’option « Supprimer définitivement » que j’ai essayé plusieurs fois sans succès, car la version effacée apparaît toujours en lieu et place de la nouvelle version de l’image.
    Un petit tour sur mon site va vous permettre d’y voir plus clair:

    http://asi-online.info

    sur la page d’accueil, il y a un slider de 8 thèmes abordés dans mon activité et sur chaque slide, il y a une petite icône en png qui descend pendant l’animation.

    Ces icônes ont été blanches, orange et maintenant elles sont bleues pour « coller » à l’éthique graphique du site, mais certaines apparaissent toujours en blanc ou en orange, malgré leur suppression via la bibliothèque !!!

    C’est pour cela que je parle de fantômes et je ne sais pas quoi faire, même 1and1 n’a trouvé aucune solution !!!!

    Je pense qu’il doit y avoir un dossier qui stocke ces images (peut-être une sorte de cache) et qui me serait bien agréable de connaître pour que je puisse supprimer vraiment « définitivement » ces fantômes…

    Cordialement, Laurent

    #1051138
    Flobogo
    Modérateur
    Maître WordPress
    20071 contributions

    Bonjour,

    Êtes-vous sûr qu’il n’y a pas … un plugin de cache, justement, que vous auriez « oublié » (caché ?) dans la liste de vos plugins ?

    #1051139
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Je pense au cache aussi. C’est tout bête mais avez-vous vidé votre historique récent puis rafraichi la page ? Pour être fixé, allez carrément sur votre site avec un autre navigateur « de secours » (genre Opéra) ou avec un proxie, les cookies seront différents et vous verrez le site comme un nouveau venu.

    #1051140
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    Merci à tous pour votre implication…

    J’ai bien sûr vérifié sur d’autres navigateurs et même sur d’autres ordinateurs !!! En vain… ces foutues images sont toujours présentes… :fire::fire:

    J’ai aussi supprimer tous les fichiers temporaires, réinitialiser les navigateurs, passer CCleaner, mais toujours pareil…

    Par contre, j’ai lu un article précisant que ce genre de problèmes ne pouvait être résolu, car les moteurs de recherche possèdent le cache de ces liens et donc, qu’il fallait attendre jusqu’à plusieurs jours avant que les serveurs distants soient purgés… Explications tout à fait plausible, pour ma part, mais quelqu’un aurait-il un avis ?

    #1051141
    CAMEO172
    Participant
    Maître WordPress
    1395 contributions
    lmichelot wrote:
    Merci à tous pour votre implication…

    J’ai bien sûr vérifié sur d’autres navigateurs et même sur d’autres ordinateurs !!! En vain… ces foutues images sont toujours présentes… :fire::fire:

    J’ai aussi supprimer tous les fichiers temporaires, réinitialiser les navigateurs, passer CCleaner, mais toujours pareil…

    Par contre, j’ai lu un article précisant que ce genre de problèmes ne pouvait être résolu, car les moteurs de recherche possèdent le cache de ces liens et donc, qu’il fallait attendre jusqu’à plusieurs jours avant que les serveurs distants soient purgés… Explications tout à fait plausible, pour ma part, mais quelqu’un aurait-il un avis ?

    arrêtez le farfulu. si vous effacez une image de la bibliothèque, il ne doit plus y être, basta !

    Même l’histoire de cache ne tient pas la route, surtout si entre temps vous changez de navigateur (les autres n’ayant rien en cache).

    Si elle y est encore c’est qu’il y a un soucis de droit, à mon avis. Avez vous un message particulier après avoir cliquer sur « supprimer définitivement » ?

    #1051142
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    Cameo172, je suis un peu surpris par le ton de votre réponse, mais bon, chacun s’exprime comme il le veut…
    Pour ce qui est des droits, ce sont des icônes en png libres de droit, donc, aucun problème… Donnez-moi votre adresse mail, je vois enverrai un exemplaire des icônes qui posent problème et vous irez sur le site depuis votre ordinateur et vous pourrez vous rendre compte de la véracité de mes propos…
    Les images ont bien été supprimées depuis la bibliothèque de WP, sans aucun message d’erreur concernant leur suppression, mais demeurent en cache quelque part; ce que j’aimerais savoir.

    #1051143
    CAMEO172
    Participant
    Maître WordPress
    1395 contributions
    lmichelot wrote:
    Cameo172, je suis un peu surpris par le ton de votre réponse, mais bon, chacun s’exprime comme il le veut…
    Pour ce qui est des droits, ce sont des icônes en png libres de droit, donc, aucun problème… Donnez-moi votre adresse mail, je vois enverrai un exemplaire des icônes qui posent problème et vous irez sur le site depuis votre ordinateur et vous pourrez vous rendre compte de la véracité de mes propos…
    Les images ont bien été supprimées depuis la bibliothèque de WP, sans aucun message d’erreur concernant leur suppression, mais demeurent en cache quelque part; ce que j’aimerais savoir.

    désolé, grosse journée. Arrêtez de penser cache, si vous avez bien lisé vos plugin vous n’avez rien de tel.. qui plus est un cache n’est jamais côté administrateur donc aucune raison pour que quand vous cliquez sur supprimer dans la bibliothèque, ça ne disparaisse pas.

    Quand je parle de droit, je ne pas parle de droit d’utilisation, mais de droit des fichiers ou des dossiers. il faudrait voir si vous avez bien la main sur ses dossiers.

    #1051144
    PhiLyon
    Modérateur
    Maître WordPress
    28264 contributions

    Bonsoir.

    Tes images ne seraient pas stockées dans ton MotoPress Slider ?

    🙂

    #1051145
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    Non, je ne pense pas, car dans Motopress slider, les images sont en fait des liens vers la bibliothèque; si je les supprime de la bibliothèque, elles ne s’affichent plus dans le slider…

    #1051146
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    CAMEO172, les droits Admin, je les ai bien et je peux, sans problème et sans aucune restriction, gérer l’ensemble des données du site tant sur les fichiers que les dossiers et lorsque je supprime un fichier et/ou un dossier de la bibliothèque, ils sont bien supprimés mais il demeure ces fameux fantômes… Désolé de faire ce constat; il me serait plus facile de ne pas avoir à gérer ce problème…

    #1051147
    PhiLyon
    Modérateur
    Maître WordPress
    28264 contributions

    Tu as un plugin de cache : WP Super Cache d’après ce site http://whatwpthemeisthat.com/

    🙂

    #1051148
    lmichelot
    Membre
    Initié WordPress
    9 contributions

    Oui, je l’ai installé

    #1051149
    PhiLyon
    Modérateur
    Maître WordPress
    28264 contributions

    Et bien vides le cache, ou désactives-le, je ne connais pas ce plugin !

    Le lien pour le désinstaller https://fr.wordpress.org/plugins/wp-super-cache/other_notes/

    🙂

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.