statut permanent « disallow » du robots.txt malgré changement

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #509490
    argentik
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.2.1
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur : o2switch
    – Adresse du site : http://www.clowndesource.com

    Problème(s) rencontré(s) :

    bjr à tous,
    Voilà, j ai recherché ds le forum mais pas de solution.
    mon pb : j avais mis le site en « non visible pr les moteurs de recherche » avant que le site ne soit entièrement terminé.
    après le redesign et les màj, je remets l option « rendre visible pour les moteurs de recherche » ds la section « vie privée ».

    seulement voilà… en regardant le fichier http://www.clowndesource.com/robots.txt j ai un

    User-Agent: *
    Disallow: /

    permanent.

    j ai mis les plugins suivants :
    BWP GXS pr la sitemap
    WP robots txt

    et j ai meme ajouté un robots.txt manuel à la racine du /blog avec :

    User-agent: *
    Disallow:

    ce qui ne coupe rien normalement.

    rien à faire, j ai tjs le meme résultat, càd que WP ne reconnait pas la commande faite via l option de vie privée… ce fichier virtuel est il têtu, il veut que le site reste invisible des robots ??

    j ai déjà essayé d enlever ts les plugins, et malgré que l option soit bien à « rendre visible », le fichier virtuel donne l ordre de l inverse.

    que dois je faire ? où ai je fait une erreur ? est ce un bug de wordpress ??

    merci infiniment pour votre aide à tous,

    A.M.

    #832542
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Supprimez tout simplement la ligne Disallow !

    #832543
    argentik
    Participant
    Initié WordPress
    27 contributions

    merci pr ta proposition, je viens d essayer, le fichier dit toujours « disallow »

    j ai écrit ceci :

    User-agent: *

    #832544
    argentik
    Participant
    Initié WordPress
    27 contributions

    en fait j ai écrit exactement cela au dessus, mais j ai tjs le meme résultat ds mon navigateur :
    http://clowndesource.com/robots.txt

    qqch prend le dessus malgré les changements ? que puis je faire ? merci pr vos tuyaux…

    #832545
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Videz le cache de votre navigateur.

    #832546
    argentik
    Participant
    Initié WordPress
    27 contributions

    je viens de vider le cache sous FF : tjs le mm résultat :-((

    #832547
    Chris CB
    Participant
    Initié WordPress
    18 contributions

    J’ai une version anglaise de WordPress (je suis désolé), je ne connais pas les noms des menus de l’interface d’admin en français. Mais dans les paramêtres du blog (Settings), il y a une section Confidentialité (Privacy). Dedans on peut choisir si on accepte ou pas l’indexation par les moteurs de recherche. Il faut bien sûr l’accepter.

    #832548
    argentik
    Participant
    Initié WordPress
    27 contributions

    justement, j ai accepté que le site soit visible des moteurs de recherche !! et il continue de montrer qu’il est invisible..

    #832549
    Chris CB
    Participant
    Initié WordPress
    18 contributions

    J’ai eu le problème je me souviens. La seule solution que j’avais trouvé été de faire moi même le robots.txt et d’ajouter au début du .htaccess les lignes suivantes :

    ExpiresDefault A0
    Header set Cache-Control « no-store, no-cache, must-revalidate, max-age=0 »
    Header set Pragma « no-cache »

    #832550
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    A mon avis, le plugin WP robots txt soit être supprimé complètement ainsi que le fichier robots .txt

    Quite à le remettre par la suite.

    #832551
    argentik
    Participant
    Initié WordPress
    27 contributions
    Chris CB wrote:
    J’ai eu le problème je me souviens. La seule solution que j’avais trouvé été de faire moi même le robots.txt et d’ajouter au début du .htaccess les lignes suivantes :

    ExpiresDefault A0
    Header set Cache-Control « no-store, no-cache, must-revalidate, max-age=0 »
    Header set Pragma « no-cache »

    je viens d essayer :

    – j ai désactivé le plug-in wp-robots + ai effacé le robots txt manuel = le mm résultat , càd disallow

    – j ai essayé la solution de chris : j ai remis le robots txt en racine + ai fait la modification du .htaccess = le mm résultat , càd disallow

    … je sais pas quoi faire ?? :-(( et merci pour vos propositions, je ss sure que qqun va trouver !

    #832552
    luciole135
    Participant
    Maître WordPress
    13753 contributions
    argentik wrote:
    j ai désactivé le plug-in wp-robots + ai effacé le robots txt manuel = le mm résultat , càd disallow

    Perso, je ne le désactiverait pas, je le supprimerai.

    #832553
    Chris CB
    Participant
    Initié WordPress
    18 contributions

    Dans ton .htaccess, tu aurais pas de rewrite concernant le robot.txt ?

    #832554
    argentik
    Participant
    Initié WordPress
    27 contributions

    j ai une question… qd il y a :

    User-agent: *
    Disallow:

    ça signifie que ttes les pages st visibles par les robots maintenant ?

    car c ce que le robots.txt affiche maintenant !!

    #832555
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Non, là vous interdisez le site à tous les robots :
    http://www.promo-web.org/Optimisation/robots.htm

    Pour autoriser, comme je vous l’ai dit, il suffit de ne rien écrire.

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.