Spam sur mon site…

  • WordPress :4.9
  • Statut : non résolu
8 sujets de 31 à 38 (sur un total de 38)
  • Auteur
    Messages
  • #2039083
    Li-An
    Modérateur
    Maître WordPress
    20603 contributions

    Il n’y a en effet pour l’instant aucune raison à ce code. Ça pourrait bien être les symptômes du piratage – mais les supprimer ne corrigera pas la faille.

    #2039468
    saperlipopettewp
    Participant
    Initié WordPress
    31 contributions

    Bonjour,

    @li-an, merci beaucoup ! C’est quoi le listing de fichiers ? C’est ceux de la bdd ? Et est-ce que les codes supplémentaires vont changer qqchose dans mon back office ?

    @Flobogo, j’ai moi aussi observé ce genre de caractères dans le fichier wp-config du site contaminé ! Je pensais que c’était dû au passage du http au https. Je viens de faire un essai, et en tout cas, ce n’est pas Fusion Builder qui rajoute ces codes. Je guette le wp-config et le code généré par Fusion au fur et à mesure que je réinstalle mon site. Je vous tiens au courant !

    #2039507
    saperlipopettewp
    Participant
    Initié WordPress
    31 contributions

    Pardon @Li-An… Mais où faut-il mettre les codes dans les fichiers wpconfig et htaccess ? Quand je les mets à la fin, le site ne s’affiche plus…

    #2039531
    Li-An
    Modérateur
    Maître WordPress
    20603 contributions

    Les deux morceaux de code fournis sont à placer dans le htaccess.

    #2039608
    Flobogo
    Modérateur
    Maître WordPress
    15052 contributions

    Il faut vraiment réinstaller des versions saines de WP, du thème et des extensions, et du fichier wp-config.php.

    Idéalement, ne vous servez pas de la copie infectée, il vaudrait mieux générer un nouveau fichier wp-config.php, en partant du modèle wp-config-sample.php , avec vos infos de BDD.

    Idem pour le fichier .htaccess : avec votre installation remise à neuf, allez dans Réglages > Permaliens, et enregistrez le réglage qui vous convient. Cela génèrera un nouveau fichier .htaccess, vous y ajouterez les lignes de code conseillées par Li-An.

    #2126453
    saperlipopettewp
    Participant
    Initié WordPress
    31 contributions

    Hello tout le monde !

    J’ai refait le site et tout va bien ! Saut que maintenant c’est le pluggin Contact Form 7 qui pose problème…

    J’obtiens les message : « Une erreur s’est produite lors de l’envoi de votre message. Veuillez essayer à nouveau. »

    J’ai essayé de mettre différentes adresses mail mais rien n’y fait. Sur l’ancien site, ça marchait bien et là, il ne semblerait pas que cela soit un conflit avec un autre pluggin (ce sont les mêmes qu’avant).

    Merci pour votre aide !

    #2126458
    saperlipopettewp
    Participant
    Initié WordPress
    31 contributions
    Cette réponse a été marquée comme privée.
    #2126460
    Li-An
    Modérateur
    Maître WordPress
    20603 contributions

    Vous devriez ouvrir un nouveau sujet. Refaites les tests habituels de désactivation. « Rien n’a changé » est souvent une illusion et même un vieux routier comme moi se fait avoir.

8 sujets de 31 à 38 (sur un total de 38)
  • Vous devez être connecté pour répondre à ce sujet.