[Résolu] SOS Fatal error Woocommerce !!! (Créer un compte)

  • WordPress :6.1
  • Statut : résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #2436979
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Blossom travel
    • Extensions en place : woocommerce
    • Nom de l’hébergeur : ionos
    • Adresse du site :

    Problème(s) rencontré(s) :

    <!– wp:paragraph –>

    Bonsoir à tous ! J’espère que quelqu’un saura trouver la solution !

    <!– /wp:paragraph –> <!– wp:paragraph –>

    Voici ce que j’obtiens chaque fois que je tente de modifier une page de mon site…

    <!– /wp:paragraph –> <!– wp:paragraph –>

    Fatal error: Uncaught Error: Call to undefined function AutomatticWooCommerceBlocksBlockTypeswp_is_block_theme() in /homepages/38/d838271311/htdocs/app838553154/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/BlockTypes/ProductImage.php:168 Stack trace: #0 /homepages/38/d838271311/htdocs/app838553154/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/BlockTypes/AbstractBlock.php(100): AutomatticWooCommerceBlocksBlockTypesProductImage->enqueue_data() #1 /homepages/38/d838271311/htdocs/app838553154/wp-includes/class-wp-hook.php(303): AutomatticWooCommerceBlocksBlockTypesAbstractBlock->enqueue_editor_assets( ») #2 /homepages/38/d838271311/htdocs/app838553154/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array) #3 /homepages/38/d838271311/htdocs/app838553154/wp-includes/plugin.php(470): WP_Hook->do_action(Array) #4 /homepages/38/d838271311/htdocs/app838553154/wp-admin/edit-form-blocks.php(252): do_action(‘enqueue_block_e…’) #5 /homepages/38/d838271311/htdocs/app83855 in /homepages/38/d838271311/htdocs/app838553154/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/BlockTypes/ProductImage.php on line 168

    <!– /wp:paragraph –> <!– wp:paragraph –>

    J’ai essayé de supprimer Woocommerce et bien sûr ensuite tout fonctionne… Mais j’ai besoin de Woocommerce ! Alors comment faire ??

    <!– /wp:paragraph –> <!– wp:paragraph –>

    Un grand merci d’avance pour ceux qui pourront aider la grande novice que je suis !

    <!– /wp:paragraph –>

    • Ce sujet a été modifié le il y a 1 année et 5 mois par Li-An.
    • Ce sujet a été modifié il y a 1 année et 5 mois par Flobogo. Raison : déplacé en rubrique "Woocommerce"
    #2436998
    Li-An
    Participant
    Maître WordPress
    28461 contributions

    Bonjour,

    Il y avait un questionnaire affiché, c’est dommage de ne pas l’avoir complété entièrement, car il peut aider à vous aider.
    Alors, merci de le copier-coller et compléter du mieux possible dans votre prochain post. Vous pouvez utiliser cette extension https://github.com/zitezinfo/infosite et copier/coller les informations affichées.

    Pour l’installer : téléchargez le fichier .zip indiqué dans le lien puis Extensions>Ajouter, cliquer sur le bouton Téléverser une extension (utilisez le fichier zip).

    #2437075
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Bonjour Li-An et merci pour votre réponse.

    Voici les infos :

    Ma configuration WP actuelle :
    – Version de WordPress : 5.8
    – Version de PHP / MySQL : 7.4.33 / 5.7.38
    – Thème utilisé : Blossom Travel (slug : blossom-travel) pas de thème enfant
    – Thème URI : https://blossomthemes.com/wordpress-themes/blossom-travel/
    – Extensions activées : a3 Lazy Load (2.6.1), Advanced Editor Tools (previously TinyMCE Advanced) (5.6.0), Antispam Bee (2.11.1), BlossomThemes Email Newsletter (2.2.1), BlossomThemes Social Feed (2.0.4), BlossomThemes Toolkit (2.2.4), Broken Link Checker (1.11.21), Coming Soon Page, Maintenance Mode, Landing Pages & WordPress Website Builder by SeedProd (6.15.7), Contact Form 7 (5.5.6.1), Easy Social Feed (6.3.9), Enable jQuery Migrate Helper (1.3.0), Infosite (6), Limit Login Attempts Reloaded (2.25.10), ProfilePress (4.5.0), Regenerate Thumbnails (3.1.5), Regenerate Thumbnails Advanced (2.4.0), Shariff Wrapper (4.6.9), Statify (1.8.4), The Events Calendar (5.16.4), UpdraftPlus – Backup/Restore (1.22.24), WooCommerce (7.2.2), WooCommerce PayPal Payments (2.0.1), WP Menu Cart (2.13.0), Yoast SEO (19.4)
    – Extensions désactivées : Cookie Notice & Compliance for GDPR / CCPA (2.4.4)
    – Adresse du site : https://camillecase.com/
    – Hébergeur :ionos

    #2437109
    Li-An
    Participant
    Maître WordPress
    28461 contributions

    Bonjour, si vous êtes vraiment en WP 5.8, ça peut expliquer bien des choses…

    Et remplacez Limit Login par une vraie extension de sécurité (Ninja Firewall, SecuPress, Wordfence…)

    #2437128
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Merci pour votre réponse. Je vais essayer de remplacer Limit Login et vérifier la version de WP.

    #2437130
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Ah! J’ai essayé d’activer Ninja Firewall, après avoir désactivé Limit Login et j’au eu ce message d’erreur :
    <div id= »message » class= »error »>

    L’extension n’a pas pu être activée, car elle a déclenché une erreur fatale.

    </div>
    Error, the /homepages/38/d838271311/htdocs/app838553154/wp-content/mu-plugins folder is not writable. Check your server permissions and try again.

    #2437135
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    J’ai essayé de mettre à jour la version de WP mais je n’y parviens pas.

    Voici ce qui s’affiche :
    Version actuelle : 5.8
    Dernière vérification le 23 décembre 2022 à 14h13. Vérifier à nouveau.

    Mais si je clique sur vérifier, rien ne se passe…

     

    • Cette réponse a été modifiée le il y a 1 année et 5 mois par Amylubee.
    #2437145
    Li-An
    Participant
    Maître WordPress
    28461 contributions

    Vous avez des problèmes liés au serveur. Le message de Ninja Firewall indique que le répertoire auquel il a besoin d’accéder n’a pas les autorisations préconisées par WP. Il faudrait passer par le FTP pour corriger ça éventuellement mais en fait, on a un problème plus grave.

    Ce n’est pas normal que votre site ne soit pas au moins en 5.8.3. Ça signifie qu’il n’est pas à jour niveau sécurité. Cette mise à jour aurait dû être effectuée automatiquement. Vous êtes passé par un module Ionos pour l’installation de WP ? Il faut que vous les contactiez pour signaler le problème – et le fait que la mise à jour ne se fait pas lorsque vous la demandez. Si vous n’avez pas de réponse rapide, on va tâcher de faire la mise à jour par FTP.

    #2437158
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Merci pour les conseils. Je vais essayer de les contacter à nouveau.

    #2437173
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Bonsoir Li-An,

    Après 3 interlocuteurs différents, dont un qui me conseille de demander sur les forums… J’ai envoyé des captures d’écrans au support Ionos… On verra…

    Car j’ai découvert d’autres problèmes, enfin je crois… Tout ça devient un peu trop compliqué pour moi…

    Dans la partie « santé du site » voici ce que je peux voir :
    problème critique
    Les mises à jour d’arrière-plan ne fonctionnent pas comme prévu

    Les mises à jour d’arrière-plan assurent que WordPress peut se mettre à jour automatiquement si une mise à jour de sécurité est disponible pour la version que vous utilisez actuellement.

    • Aucun système de contrôle de version n’a été détecté. (vert donc une bonne chose ?)
    • Votre installation de WordPress ne nécessite pas d’identifiants FTP pour effectuer les mises à jour. (pareil ?)
    • Certains fichiers ne sont pas accessibles par WordPress : (croix rouge…)
      • xmlrpc.php
      • wp-blog-header.php
      • readme.html
      • wp-signup.php
      • index.php
      • wp-cron.php
      • wp-config-sample.php
      • wp-login.php
      • wp-settings.php
      • license.txt
      • wp-mail.php
      • wp-links-opml.php
      • wp-load.php
      • wp-includes/class-wp-user-query.php
      • wp-includes/l10n.php
      • wp-includes/date.php
      • wp-includes/class-wp-oembed.php
      • wp-includes/images/w-logo-blue-white-bg.png
      • wp-includes/images/blank.gif
      • wp-includes/images/down_arrow.gif

     

    • Cette réponse a été modifiée le il y a 1 année et 5 mois par Amylubee.
    #2437179
    Li-An
    Participant
    Maître WordPress
    28461 contributions

    C’est un problème d’autorisation sur les répertoires. Tout est bloqué à cause de ça. Il va falloir passer par le FTP pour voir quelles sont les autorisations.

    La doc Ionos est un peu chiche mais vous trouverez plein de tutos pour utiliser un logiciel FTP https://www.ionos.fr/assistance/hebergement/configurer-et-gerer-lacces-ftp/transferer-des-fichiers-via-sftp-avec-filezilla/

    Une fois celui-ci installé et la connexion au serveur faite, on checkera les autorisations.

    #2437249
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Merci encore pour votre soutien. Je vais installer Filezilla. J’attends une réponse de Ionos. Je posterai dès que j’aurai du nouveau.
    En attendant, passez un agréable Noël 🎄 !

    #2437854
    Amylubee
    Participant
    Initié WordPress
    9 contributions

    Bonjour Li-An,

    Le service Ionos a mis à jour la version de WP et tout est rentré dans l’ordre ! Merci encore pour vos excellents conseils. Passez un bon réveillon. Tous mes vœux pour cette nouvelle année !

    #2437857
    Li-An
    Participant
    Maître WordPress
    28461 contributions

    Très étrange. Mais si c’était un problème d’autorisation de fichiers sur le serveur, c’était plus facile à régler de leur côté.

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.