Sortie de WordPress 3.2 – PHP version 5.2.4 ou supérieure requise (Créer un compte)

  • Statut : non résolu
15 sujets de 31 à 45 (sur un total de 111)
  • Auteur
    Messages
  • #779952
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    Merci de ne pas utiliser ce post pour du support. . D’autant qu’il y a déjà un post épinglé pour les problèmes de mémoire lors des mises à jour automatiques : http://www.wordpress-fr.net/support/sujet-39271-cas-echec-mise-jour-automatique

    #779955
    Petit_Nuage
    Membre
    Initié WordPress
    2 contributions
    Sanjicook wrote:
    Bonjour, j’ai le même problème je suis chez free et j’ai le mesage suivant :

    « Cette mise à jour ne peut être installée car WordPress 3.2 requiert une version de PHP égale ou supérieure à la 5.2.4. Votre hébergement utilise PHP version 5.1.3RC4-dev. »

    Si quelqu’un pourrais m’aider :D

    Salut Sanjicook.
    J’ai installé la 3.2.1 sur free.fr ce matin, plus d’info sur mon blog:
    http://gaetan.janssens.free.fr/v2/index.php/maj-wordpress-3-2-3-free-fr-19-07-2011/
    ++

    #779954
    Sanjicook
    Membre
    Initié WordPress
    5 contributions

    Merci ça marche mais a la fin je ne sais pas ou mettre les lignes pour l’erreur « La fonction array_fill_keys n’existe pas dans la 5.1.3RC4 de free. »

    #779956
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #779957
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #779958
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    Est-ce que array_fill_keys est la seule fonction postérieure à PHP version 5.1.3RC4-dev utilisée dans la dernière version de WordPress ? Est-ce ces fonctions ne sont pas utilisées ailleurs que pour l’installation (ce qui pourrait d’ailleurs altérer d’autres fonctionnalités) ?

    #779959
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #779960
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    A voir à l’usage, mais il pourrait y avoir des problèmes ailleurs.
    De plus cela fait modifier le cœur de l’application donc perte des modifications à chaque mise à jour.
    Cela ne me paraît pas être une solution très pertinente.
    Perso j’ai gardé la 3.1.3 chez Free.

    #779961
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #779962
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    vous devriez être au moins sous WP 3.1.4 et non 3.1.3

    Dans absolu oui… En pratique non… Il me semble que la correction de sécurité portait sur un compte éditeur qui pouvait accéder à des droits supplémentaires. Et comme je suis le seul membre… 🙂

    Et php5.3 devrait arriver sur Free

    Franchement, cela fait de nombreux mois que tout le monde dit cela (le problème existe avec Joomla depuis le début de l’année me semble-t-il). Je n’ai à ce jour vu aucune communication officielle de Free sur le sujet. Juste des rumeurs colportées à partir de posts sur l’ADUF et reprises un peu partout.

    peut être ou peut être pas, cela n’est que supposition

    C’est un peu ce que je reproche à la démarche. Je ne suis pas sûr que des tests ou des analyses poussées ont été faites pour s’inquiéter de savoir si cela pouvait impacter d’autres fonctions dans le code.

    Et la règle « on ne modifie pas les fichiers du core WordPress » reste quand même d’actualité.

    #779963
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #779964
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions
    rvzen wrote:
    « on ne modifie pas les fichiers du core WordPress » ça je ne le savais pas!

    Ce n’est pas faute de l’avoir répété ^^
    Toute modif du core WordPress est écrasée à la mise à jour suivante…. et donc à refaire

    #779965
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    j’avais fait la mise à jour par sécurité,mais ce n’est pas important.

    Ben si, c’est grave… Je suis le premier à faire la leçon aux autres… :D Je le méritais bien… :fouet:

    l’info de proxad.free.pagesperso , ce n’est pas plus fiable ?

    Je ne fais pas trop confiance aux newsgroups, forums (sans connaître l’utilisateur en tout cas)… Mais à chaque fois que j’ai vu cette information, l’origine était soit « un gars du support m’a dit que le passage est pour… » soit un lien vers une autre discussion sans source… Pour l’instant je n’ai pas vu de communication officielle de la part de Free et toi ?

    si cela pose un souci, vous effacez mon message

    Non… Bien au contraire… Cette discussion est constructive… et de toute façon, le hack de petit nuage semble rencontrer un certain succès sur la toile. Je voulais juste apporter quelques restrictions sur la méthode.

    Ce qui me gène c’est qu’au vu du nombre d’utilisateurs de WordPress chez free.fr, si tout le monde fait la manip, cela risque de ne pas être simple à trouver l’origine du problème en cas de soucis avec un plugin ou un thème… Sans compter les problèmes liés à la perte du Hack à la prochaine mise à jour, qui coincera probablement…

    #779966
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #779967
    Franck (fge)
    Modérateur
    Maître WordPress
    9572 contributions

    Modifier le cœur de WordPress ne doit se faire que dans le cadre d’une extension. On peut toucher au cœur mais pas à ses fichiers.

15 sujets de 31 à 45 (sur un total de 111)
  • Le sujet ‘Sortie de WordPress 3.2 – PHP version 5.2.4 ou supérieure requise’ est fermé à de nouvelles réponses.