Site wordpress partiellement inaccessible (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
15 sujets de 76 à 90 (sur un total de 96)
  • Auteur
    Messages
  • #2380637
    Flobogo
    Modérateur
    Maître WordPress
    17618 contributions

    Bonjour,

    Ah bravo, on peut même dire qu’il a ouvert les 2 yeux, et montre de réels signes de retour parmi les (sites) vivants 🙂

    Le voilà habillé avec ses habits Twentysixteen un peu démodés, mais c’est mieux que la chemise toute blanche de l’hôpital. Pas d’inquiétude, on le rhabillera en Panoramic à la fin.

    Bravo au Dr Ferman, je n’avais pas compris que le fichier admin-bar.php était raccourci involontairement. Ça date sans doute de la période où vous avez eu quelques soucis de connexion avec votre box, mais je ne pensais pas que des fichiers pouvaient être tronqués pendant le transfert.
    Comme quoi, on a beau pratiquer la médecine WordPress depuis des années, on en apprend aussi de notre côté.

    Parfait pour la version PHP 7.1, c’est effectivement plus adapté à l’état actuel du patient, on ne lui demande pas de courir un marathon tout de suite.

    Par contre, si, si, il faut absolument accepter la mise à jour de la base de données, c’est normal après un changement de version WordPress, surtout aussi important que le passage de WP 4.9 à WP 5.0

    Je vous conseille donc maintenant de :

    • retourner sur votre site, et acceptez la mise à jour de BDD qui devrait vous être à nouveau proposée

     

    • si vous avez accès à l’admin du site, installez l’extension Classic Editor qui vous permettra de garder le mode d’édition auquel vous êtes habituée. Car WP 5.0 introduit l’éditeur Gutenberg, avec un fonctionnement par blocs, qui peut être déroutant.
      Pour ça, téléchargez sur votre ordi l’extension exclusivement ici : https://downloads.wordpress.org/plugin/classic-editor.1.0.zip
      Ensuite, dans votre admin’ de site, allez au menu Extension, puis ajouter, puis tout en haut de page cliquez sur le bouton “Téléverser une extension”. WordPress vous propose alors de parcourir votre ordi pour retrouver le dossier classic-editor.1.0.zip, puis vous cliquez “installer maintenant”. Mais ne l’activez pas.
      Si ça ne fonctionne pas : déconnectez-vous du site (en vérifiant au passage que toutes vos extensions sont déconnectées, il doit y avoir des messages en rouge qui disent que les dossiers n’existent pas, c’est normal, c’est à cause du -X sur le dossier plugins)
      Dans ce cas, sur votre ordi, dézippez le dossier classic-editor.1.0.zip. Dedans, il y a un dossier classic-editor que vous devrez copier par FTP (Filezilla) vers le site distant, dans le dossier wp-content/plugins-X

     

    • Allez ensuite à votre gestion de base de données (PhpMyAdmin), et sauvegardez la base de données comme vous avez appris à le faire.

     

    • Puis, téléchargez WP 5.2.11 à sélectionner ici et dézippez le dossier
      Puis par FTP, supprimez le dossier wp-content / le dossier wp-includes / les 15 ou 16 fichiers à la racine, sauf wp-config.php et sauf .htaccess qu’il faut toujours garder.
      Ensuite, envoyez par FTP la copie de ces mêmes dossiers et fichiers à partir de la version 5.2.11 dézippée vers le site distant. Et envoyez aussi la copie du dossier twentysixteen qui se trouve dans wp-content de la version 5.2.11 dézippée sur votre ordi. Filezilla va vous demander si vous voulez remplacer, vous dites “oui” et vous cochez “pour tous les fichiers de la file d’attente”
      Et enfin, envoyez aussi le dossier twentynineteen qui se trouve dans wp-content de la version 5.2.11 dézippée sur votre ordi.

    Une fois que tout ça sera fait, reconnectez-vous, acceptez à nouveau la mise à jour de la base de données, vérifiez si le site s’affiche bien … et revenez donner des nouvelles. Si tout va bien, le patient sera vraiment en phase de guérison.

    #2380653
    ferman
    Participant
    Maître WordPress
    4413 contributions

    Il me semble que Flobogo voulait dire: “puis par FTP, supprimez le dossier wp-admin / le dossier wp-includes et non le dossier  wp-content / le dossier wp-includes

    #2380654
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Bonjour Ferman

    J’en étais justement là, et je me disais bizarre bizarre, du coup, je viens à l’instant de faire une copie de tout le site distant via FileZilla, en me disant : “pas grave j’aurai le dossier “content”   sous la main s’il ne fallait pas y toucher !!!

    Allez je continue sur ma lancée !

    Merci pour votre aide

    #2380655
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Hello Les Dr en Chef !!!

    Je trépigne d’impatience de vous annoncer que toutes les étapes listées et exécutées se sont parfaitement déroulées, et que le patient a toujours ses zoeils d’ouverts !!!!

    Sur l’admin de mon site, j’ai juste un message qui me dit que cela serait bien que j’update mon PHP…. !!! cf capture

    Trop bien !!!!

    Vous assurez trop !

    Merci
    Sandrine

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2380659
    ferman
    Participant
    Maître WordPress
    4413 contributions

    Allez je continue sur ma lancée !

    Faites donc!  passez aux étapes suivantes indiquées par Flobogo #2380631 . Quand vous en serez à 5.6.4, vous pourrez repasser en PHP 7.4 chez OVH.  Vérifiez à chaque étape que le site est OK et n’oubliez pas de sauvegarder votre base de données.

     

    #2380690
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Hello hello !

    Devinez qui a demandé un plateau repas depuis sa chambre médicalisée ? eh oui, le Moribond, enfin l’ex moribond !! J’ai tout fini vos instructions, tout s’est super bien passé, je suis en version 5.7.2 (alléluia !!!), pas en PHP 7.4 car il ne s’affichait pas dans ma liste sur OVH mais je suis en 7.3

    J’ai accès à mon admin du site… Ca fleure bon, non ?!!!

    Sandrine en mode contente !!! et reconnaissante !

     

    #2380694
    ferman
    Participant
    Maître WordPress
    4413 contributions

    pas en PHP 7.4 car il ne s’affichait pas dans ma liste sur OVH

    Chez OVH, voyez vous le moyen de choisir entre “environnement d’exécution : stable ou stable 64”? Si oui passez en stable64 et choisissez ensuite 7.4. Sinon, pour passer en 7.4, il faut le faire manuellement. Vous l’avez déjà fait avec un technicien OVH; vous pouvez les recontacter. D’un autre côté, avec le niveau d’expertise que vous avez atteint vous pouvez voler de vos propres ailes. Par FTP copiez le  fichier ovhconfig sur votre PC , ouvrez avec notepad++ et modifiez comme indiqué dans le lien que je vous avez donné (juste au dessous de Soit via le fichier /.ovhconfig). Après “stable” (container.image=stable), ajoutez 64 (container.image=stable64).

    Vous pouvez aussi regarder ce lien (en ajoutant 64 là où il faut). C’est très bien expliqué.

     

    • Cette réponse a été modifiée le il y a 2 mois et 2 semaines par ferman.
    • Cette réponse a été modifiée le il y a 2 mois et 2 semaines par ferman.
    #2380703
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Youhou avec Stable 64 (coché sur l’environnement d’exécution) (oui, j’irai toujours à la simplicité !!) j’ai pu avoir la version PHP 7.4 !
    Merci tout plein

    #2380708
    ferman
    Participant
    Maître WordPress
    4413 contributions

    Devinez qui a demandé un plateau repas depuis sa chambre médicalisée ? eh oui, le Moribond, enfin l’ex moribond !!

    Alors là il pète vraiment la forme parce que demander un plateau repas à l’hôpital…il faut vraiment être affamé.  Le Dr.Flobogo passera sans aucun doute prendre des nouvelles du patient et donner les conseils à suivre pour qu’il ne rechute pas à l’avenir.

    #2380712
    Flobogo
    Modérateur
    Maître WordPress
    17618 contributions

    @ferman : merci de ta vigilance. Moi, j’ai accumulé les gardes de nuit, et voilà 😁


    @sandrinesia
    :

    Mais il est en pleine forme votre patient. Le voilà déjà sur pieds, et en fin de rééducation. Ça fait plaisir. 🙂

    Il reste quelques petites choses à fignoler :

    • en haut à gauche de l’admin’ du site, vous avez un lien “mises à jour”. Cliquez sur le lien, car il faut sans doute mettre à jour le thème Twenty Sixteen, qui doit être celui de la version 5.2.11
    • regardez ensuite si l’admin’ vous propose la mise à jour de Panoramic. Si ce n’est pas proposé, allez dans le FTP, et supprimez le -X de panoramic-X dans wp-content/themes. Puis revenez à l’admin’, faites la mise à jour de Panoramic, et … essayez de le réactiver. Il faudra probablement refaire quelques réglages, mais vous devriez le retrouver en bon état de fonctionnement.

    Allez, un peu plus compliqué, mais vous comme dit le Dr Ferman, vous avez appris à opérer seule :

    Par FTP (Filezilla), téléchargez sur votre ordi le fichier .htaccess situé à la racine du site, là où se trouvent les 3 dossiers wp-admin / wp-content / wp-includes
    Ouvrez-le avec avec NotePad++ ou équivalent, pour ajouter les lignes suivantes à la fin du fichier  :

    <IfModule mod_autoindex.c>
    Options -Indexes
    </IfModule>

    Renvoyez ensuite ce fichier par FTP à la racine du site, là où se trouvent les 3 dossiers wp-admin / wp-content / wp-includes. Si Filezilla demande si il faut remplacer l’ancien fichier, acceptez.
    L’ajout de ce code empêchera de lister le contenu des dossiers aux yeux des curieux. (inutile de faire savoir aux hackers toutes les extensions que vous utilisez, par exemple)

    Et pour terminer, on va finaliser le passage en HTTPS, qui n’est pas complet, et les 2 versions co-existent (comme si le patient avait un jumeau, mais un “mauvais jumeau”). Avant tout, sauvegardez (encore une fois) votre base de données, maintenant que tout WordPress est passé en 5.7.2

    2 solutions:

    • soit vous allez dans l’onglet “Outils” > “santé du site”, et un bouton vous propose de passer tout le site en HTTPS. Ce serait la solution la plus simple.
    • soit ce bouton n’existe pas, ou bien ça ne donne rien. Dans ce cas, suivez la procédure suivante :
      D’abord, on va réactiver le dossier des extensions (plugins), en renommant sans le -X le dossier wp-content/plugins.
      Ensuite, dans l’admin’ du site, allez à l’onglet “Extensions” > “ajouter”. Tapez le début de “Better Search Replace”. WP va vous proposer une liste d’extension, celle-ci en 1er. Cliquez pour l’installer puis l’activer. Normalement, cette extension est traduite en français.
      Vous allez l’utilisez pour remplacer http://energies-et-moi.fr par la même adresse avec https. Sélectionnez toutes les tables. Vous pouvez faire un essai avant de faire le remplacement réel.

    Si le passage en HTTPS s’est fait par le bouton dans “santé du site”, il faut maintenant réactiver le dossier plugins, comme expliqué juste ci-dessus.

    Vous pourrez ensuite mettre à jour vos différentes extensions. Attention à celles qui n’ont pas de mise à jour du tout, cela peut vouloir dire qu’elles sont anciennes, elles pourraient ne pas être compatibles avec WP 5.7.2 et/ou PHP 7.4. Si besoin, donnez-nous la liste, ou vérifiez la date de dernière mises à jour sur le site officiel, en tapant à chaque fois les premières lettres du nom. NB : un bandeau jaune veut dire qu’il n’y a pas de mise à jour depuis 3 versions, donc depuis WP 5.4, ce n’est pas grave-grave si ça fonctionne. Par contre, un bandeau rouge signifie l’arrêt de l’extension, il faudra la supprimer et chercher une remplaçante.

    Une fois les extensions mises à jour, vous pouvez les réactivez, mais prudemment, une par une (commencez par celles qui vous semblent indispensables pour la vie quotidienne de votre patient).
    En cas de bug (une petite rechute, ça peut arriver), soit vous désactiver l’extension, ou si vous n’avez plus accès à l’admin’, vous allez dans le FTP pour ajouter un -X directement au dossier de l’extension concernée, dans wp-content/plugins.

    Quand tout ça sera fait, votre patient devrait être prêt à sortir de l’hôpital et à reprendre une vie normale.

    • Cette réponse a été modifiée le il y a 2 mois et 2 semaines par Flobogo. Raison: rectification de code
    #2380764
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Wow la longueur des devoirs !!! Ca m’a séché sur place ce matin !!!!
    Merci d’avoir pris le temps de tout taper cela !!! Enorme !

    Bon alors, c’est gentil à vous deux de croire en mon pseudo potentiel dans l’informatique, mais je ne comprends toujours pas ce que je fais, j’applique simplement à la ligne tout ce que vous avez pris le temps d’écrire.

    1 – MàJ thèmes : c’est ok, je suppose que je vais pouvoir cliquer sur l’activation de Panoramic pour le réutiliser comme thème principal.

    2 – La manip sur .htaccess via FTP en rajoutant les lignes de codages à la fin du dossier, n’a pas marché. Je vous ai mis une bonne vieille capture avec la version de l’emplacement n° 1 mis avant END wordpress. Et j’ai également tenté, en mettant ces lignes après END wordpress soit en lignes 19 à 21. Mais cela affiche une erreur 500 lorsque je vais sur mon site. Du coup, je les ai enlevées pour revenir à la version initiale du fichier .htaccess pour revoir mon joli site s’afficher !

    3 – https : je crois que j’ai fait un mélange des deux techniques proposées car je recherchais le bouton “santé du site” sur OVH ! Comme je ne le trouvais pas (tu m’étonnes), j’ai téléchargé Better Search Place et je l’ai installé. Mais je ne savais pas ou et comment aller sélectionner les 12 tables. Et c’est là que j’ai vu le bouton Santé sur ma page d’accueil de l’admin de mon site, qui me proposait de passer en htpps. J’ai cliqué et hop, victoire, cela a marché !

    4 – Les extensions… J’ai 8 extensions les 8 en bandeau rouge ! Je peux cliquer, une par une, sur “mettre à jour maintenant” quitte à repasser par FZ pour la neutraliser par un X après. Oui, la flemmardise me gagne lol

    Bien cordialement

    Sandrine

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2380768
    ferman
    Participant
    Maître WordPress
    4413 contributions

    je suppose que je vais pouvoir cliquer sur l’activation de Panoramic

    Oui si:

    1. vous avez bien renommé panoramic-X en panoramic.
    2. aucune demande de mise à jour du thème n’apparaît dans votre tableau de bord wp.
    3. MIEUX: vous avez supprimé les dossiers panoramic existants, vous avez téléchargé la dernière version de panoramic, décompressée et mise dans le dossier themes.

    Je peux cliquer, une par une, sur “mettre à jour maintenant” quitte à repasser par FZ pour la neutraliser par un X après:

    C’est effectivement comme ça qu’il faut procéder. Pour .htaccess, Flobogo vous donnera les précisions nécessaires. Je ne connais pas la méthode. Tout ce que je peux dire c’est qu’il ne faut rien mettre entre #begin wordpress et #end wordpress. Il est donc normal que ça n’ait pas marché la première fois. Pourquoi pas la deuxième? Je ne sais pas .

    • Cette réponse a été modifiée le il y a 2 mois et 2 semaines par ferman.
    #2380779
    Flobogo
    Modérateur
    Maître WordPress
    17618 contributions

    Je reprends vos différents points :

    1 – Pour panoramic, je confirme les recommandations de Ferman

    2 – Pour la manip’ sur le .htaccess, une erreur s’était glissée dans le code : il manquait un slash /  sur la 3ème ligne :
    Mais je confirme qu’il faut placer les 3 lignes à la suite des lignes déjà présentes (j’avais dit “à la fin du fichier”, ça voulait dire “à la suite”)
    Le code et les explications sont sur le site d’Aurélien Denis, un des admins en chef (le patron de la clinique, quoi ^^)

    3 – Pour le passage en HTTPS : tout fonctionne (presque) parfaitement. Il reste un petit détail (mais important pour la sécurité, et pour éviter le “contenu dupliqué” que Mr Goo-gle n’aime pas) : l’URL du site en HTTP est toujours accessible, sans renvoyer automatiquement vers HTTPS.

    Vous allez donc ajouter ce code encore à la suite du précédent dans le fichier .htaccess :

    # Redirection vers HTTPS 
    RewriteCond %{SERVER_PORT} ^80$ [OR]
    RewriteCond %{HTTPS} =off
    RewriteRule ^(.*)$ https://monsite.com/$1 [R=301,L]
    
    # Redirection du www vers non-www en HTTPS
    RewriteCond %{HTTP_HOST} ^www\.monsite\.com [NC]
    RewriteRule ^(.*)$ https://monsite.com/$1 [R=301,L]

    Évidemment, vous remplacer monsite.com par energies-et-moi.fr
    (merci WPMarmite)

    4 – Pour les 8 extensions, le bandeau rouge, c’est parce qu’elles sont considérées comme inexistantes, parce que vous n’avez pas renommé sans -X à la fin le dossier wp-content/plugins par FTP.
    Ensuite, mettez à jour celles qui doivent être mises à jour.
    Et seulement ensuite, réactivez les une par une, en vérifiant ce qui se passe sur le site à chaque fois.
    Par contre, attention aux extensions qui n’ont aucune mise à jour à faire, cela veut peut-être dire qu’elles n’existant plus ou sont trop anciennes. Pour celles-là, il faut aller sur le site officiel des extensions WP, et chercher le nom de chacune d’elles pour voir de quand elles datent et si elles ne sont pas supprimées. Si vous avez un doute, demandez-nous, avec la liste de vos extensions.

    #2380887
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Évidemment, vous remplacer monsite.com par energies-et-moi.fr
    (merci WPMarmite)
    évidemment, comme je lis ligne par ligne, je n’avais pas changé le monsite.com ah ah ah

    Mes Amis, j’ai l’immense plaisir de vous annoncer que Le Moribond a quitté l’hôpital en méga forme ! Toutes les dernières opérations se sont déroulées sans problème. J’ai mis à jour une par une les extensions via la “santé du site” qui affiche un “bien”, le “très bien” viendrait si je supprime le thème twentysixteen mais c’est sentimental, je ne peux pas le supprimer de suite !!!!

    Ca va me faire tout bizarre de ne plus avoir ma petite page d’exercices à faire quotidiennement ! Que vais-je faire de tout ce temps libre ?!!!
    Plus sérieusement, je ne sais comment vous remercier, toi Flobogo pour toutes ces heures à m’indiquer si méticuleusement toutes les étapes, en prenant toujours soin de tout m’expliquer dans un langage neutre ! A chaque fois, je commençais en paniquant en voyant toutes les lignes soigneusement tapées par vos soins, mis rapidement je m’apercevais que le chemin était tellement balisé qu’il était impossible pour la grande débutante que j’étais, de me tromper. Plein de pédagogie. Grand respect, mille mercis.
    Merci aussi à vous Ferman (arobase bleu clair… oui bein ça je n’arrive pas à le faire par exemple !!!), vos interventions précises ont permis de dénouer le schmilblik et idem, toujours en prenant soin de ne pas employer de termes trop techniques. Merci merci

    Si je peux vous rendre service (regardez mes activités sur mon superbe site fonctionnel !), ce serait avec plaisir. Si vous passez dans le Jura, sublime destination vacances, venez vous faire payer un repas (invitation qui n’est pas du vent).

    Avec mon infinie gratitude, les Chirurgiens en Chef,

    Sandrine et l’ex Moribond

    #2380903
    ferman
    Participant
    Maître WordPress
    4413 contributions

    Merci pour l’invitation.

    Que vais-je faire de tout ce temps libre ?!!!

    Vous pourrez reprendre l’entrainement au “tambour chamanique” que vous avez sûrement dû interrompre ou bien vous former (ou perfectionner?)  au “talking drum“, autrement plus expressif à mon avis (qui n’est que celui d’un parfait matérialiste).

    Bonne route en tout cas à vous et votre site  quasiment “revenu d’entre les morts”.

15 sujets de 76 à 90 (sur un total de 96)
  • Vous devez être connecté pour répondre à ce sujet.