Site wordpress partiellement inaccessible (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
15 sujets de 61 à 75 (sur un total de 96)
  • Auteur
    Messages
  • #2380405
    Flobogo
    Modérateur
    Maître WordPress
    17636 contributions

    Je reprends les différents points, puis la piste expliqué par @ferman :

    1- Vous pourriez tout à fait remettre cette ligne de code, vous l’avez peut-être mal positionnée : elle doit être à la suite des 4 autres, ce qui vous fait 5 lignes juste au-dessus de la ligne avec “happy blogging”

    2 – Bizarre, bizarre. 🙄 Les lignes 3 et 4 du code que je vous ai fait mettre dans wp-config.php “disent” à WordPress d’enregistrer les infos de débogage dans le fichier debug.log

    3 – Au lieu d’un accès VIP à tous les hôpitaux (ça en ferait trop pour moi), il faudrait peut-être me donner accès à la chambre de votre patient. Je vous propre de me mettre votre adresse mail en message privé, en plaçant bien un espace avant et après le @ (que vous pouvez remplacer par [at] ) afin que de vilains robots curieux n’aillent pas piquer votre mail. Je supprimerai d’ailleurs le post avec votre mail ensuite, donc ne mettez rien d’autre dans ce post-là. Si nous n’arrivons pas à avancer plus, je vous enverrai un mail vendredi soir pour que vous me communiquiez les accès FTP et base de données de votre site, si vus acceptez que je consulte moi-même ce patient.

    4 – le changement de thème sera provisoire, au moins le temps nécessaire pour rétablir le site. C’était normalement l’objectif en renommant le dossier panoramic avec -X, mais votre patient a été réfractaire à cette méthode. (une allergie à un traitement, ça arrive)
    Et il vaut mieux un site avec un thème différent, que pas de site du tout. La suite vous appartiendra.

    5 – Pour ce changement de thème, suivez donc mes recommandations, reprises par @ferman qui connaît bien cette procédure  :
    → vous devez accéder à votre base de données, vous rendre dans la table (quelquechose)_options, faire défiler les lignes (y compris en 2ème page) jusqu’à la ligne 40 ou un peu plus, pour retrouver celle qui comporte le mot template dans une colonne et le mot panoramic dans la colonne à côté, ainsi qu’en-dessous une ligne avec le mot stylesheet dans une colonne et le mot panoramic dans la suivante. A moins que ce ne soit panoramic-X … ou même twentysixteen

    Je vous conseille de nous faire une capture écran de ces lignes et de l’afficher ici. Et laissez-vous guider par @ferman pour la suite si vous avez le temps, il est lui aussi un excellent chirurgien.

    (NB : pas besoin de la capture écran de votre fichier .htaccess, vous me l’aviez mise en privé il y a déjà plusieurs jours, et tout était normal)

    #2380510
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Bonjour Les Chirurgiens en Chef !

    J’ai séché les cours hier, j’étais trop fatiguée et vos lignes d’explications pourtant très claires s’étaient réaffichées en chinois dans ma tête !

    1 – Par rapport aux lignes de “debug” ajoutées sur le fichier wp-config.php   je vous ai fait une capture. A savoir qu’avec ou sans interligne (je ne sais pas si la mise en page harmonieuse compte dans le langage du codage !!) , mais vous aurez une idée d’où je les ai mises

    2 – Dans la base de données, table “options” c’est le Panoramic-X qui siège au niveau du Template et du Stylesheet, d’ailleurs il vous adresse un joli selfie en pj !

    Je crois que j’ai tout fait mes devoirs, aucun problème pour vous donner mes accès.

    Un grand merci à vous deux

    Bien cordialement

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2380513
    ferman
    Participant
    Maître WordPress
    4425 contributions

    Bonjour,

    Voyons si nous avons un peu de chance: remplacez panoramix-X (c’est vous qui l’avez mis là ou bien il est venu tout seul?) par twentysixteen . Pour ça faites un double clic sur “panoramic-x” et dans la fenêtre qui s’ouvre remplacez par twentysixteen (en un mot sans tiret). A la fin cliquez en dehors de la table (ça ferme la fenêtre), sortez de votre base de données et regardez si ça va mieux sur votre site. Pour les “debug” ils sont bien placés mais il n’y en aura peut-être pas besoin; il n’est pas interdit de rêver.

    • Cette réponse a été modifiée le il y a 2 mois et 4 semaines par ferman.
    #2380522
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Bonsoir Ferman

    Panoramic-x est venu tout seul, je n’ai rien fait. Je l’ai remplacé manuellement par twentysixteen, et tadam… rien ! Page blanche lorsque je me rends sur mon site.
    (à noter, je ne sais pas si cela à son importance, mais dans le fichier wp-config.php il y a toutes les lignes de codage sur les debugs, je ne les ai pas retirées)
    bien cordialement

    • Cette réponse a été modifiée le il y a 2 mois et 4 semaines par sandrinesia.
    #2380526
    Flobogo
    Modérateur
    Maître WordPress
    17636 contributions

    Le patient n’est toujours pas réveillé, mais je comprends pourquoi les analyses ne sont pas lisibles et pas bonnes !

    1 – Par rapport aux lignes de “debug” ajoutées sur le fichier wp-config.php je vous ai fait une capture.

    Heureusement, car la capture montre l’erreur : la ligne 80 commande de ne pas utiliser le mode debug (défini sur “false“). Cette ligne devrait se terminer par “true”, et vous l’avez rajouté (à ma demande) en ligne 85.  Mais apparemment, WP n’en tient pas compte et ne s’occupe pas de la demande d’affichage qui vient ensuite (lignes 88 -89)
    Donc, virez juste cette ligne 80 : define ('WP_DEBUG', false); … et on devrait (enfin ?) avoir l’affichage des erreurs grâce aux lignes suivantes.
    Attention, vous avez 2 fichiers wp-config.php ouverts, ne vous trompez pas. Quand vous avez fini, fermez-les l’un après l’autre.
    NB : les lignes d’espacement n’ont aucune importance, sauf pour nous aider à nous y retrouver.

     

    2 – Dans la base de données, table “options” c’est le Panoramic-X qui siège au niveau du Template et du Stylesheet

    Panoramic-x est venu tout seul, je n’ai rien fait.

    Et si, je sais ce qui s’est passé : la 1ère fois où je vous ai demandé de désactiver panoramic en le renommant avec -X par FTP, je n’avais pas encore constaté que vous n’aviez pas de dossier de thème par défaut Twenty-quelque-chose. Je vous ai fait rajouter après le dossier de Twenty-sixteen
    Sauf que WordPress a buggué, car on lui a dit de désactiver panoramic, et comme il n’en trouvait pas d’autre, il essaye depuis ce temps d’activer panoramic-X. Et comme ce thème “panoramic-X” n’existe pas, ben il n’affiche rien.

    Par contre, bizarre que la technique de @ferman ne donne rien. Vous avez bien indiqué twentysixteen (sans espace, sans tiret, sans majuscule, sans erreur) à la place des deux panoramic-X ??
    Et vous avez bien suivi la 2ème partie de la consigne : “A la fin cliquez en dehors de la table (ça ferme la fenêtre)” ?
    Si vous retournez maintenant dans votre base de données, vous voyez twentysixteen  en lignes 40 et 41 de la table (préfixe)_options ? (NB : pour des captures d’écran affichées publiquement, ce serait mieux de masquer le préfixe.

    Bon, modifiez votre wp-config.php en supprimant la ligne 80, puis renvoyez-le par FTP et actualisez.
    Vérifiez ensuite votre base de données et les “twentysixteen” en lignes 40 et 41 de la table (préfixe)_options

    Et on verra ce que ça donne. En désespoir de cause, je vous demanderai vos identifiants demain soir, à mettre en message privé.

    #2380534
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Bonjour bonjour !!!

    Allez on commence par une bonne nouvelle : en enlevant la ligne 80 du fichier wp-config.php, j’ai pu obtenir les lignes de bug sur mon site. Je vais ai mis la capture d’écran. J’ai ensuite enlevé toutes les lignes de codes que vous m’avez faites rajouter pour que cela ne s’affiche plus sur mon site en public

    Oui j’ai bien fait toutes les modifications comme l’avait écrit @ferman : pas de fautes (je suis même partie revérifier dans les thèmes de wp-contents.php si les orthographes étaient similaires, ce qui est le cas). twentysixteen s’affiche bien en lignes 40 et 41 de la table options. cf capture (j’ai double cliqué volontairement pour vous montrer qu’il n’y a rien d’autre à l’intérieur des cases !)

    Je vous laisse réflexionner !!!

    Merci tout plein

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2380538
    ferman
    Participant
    Maître WordPress
    4425 contributions

    Bonjour,

    Le message semble indiquer indique une incompatibilité entre le PHP utilisé par votre ancienne version de wordpress et la version PHP (7.4 trop moderne pour votre wordpress). Pouvez-vous dans votre sauvegarde aller dans le dossier includes puis ouvrir le fichier script-loader (notepad++) et faire une copie d’écran des lignes 707 et 708 (+ quelques lignes au dessus et au dessous).

    #2380553
    ferman
    Participant
    Maître WordPress
    4425 contributions

    …et faites pareil pour admin-bar.php (le deuxième message).

     

    #2380569
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Bonsoir Ferman,

    Je vous mets les deux captures demandées en pj !

    Merci pour votre aide

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2380574
    Flobogo
    Modérateur
    Maître WordPress
    17636 contributions

    Bonsoir,

    Et bien, on a avancé d’un tout petit pas, car même si on obtient un message d’erreur, il n’est pas très parlant.

    Seul votre fichier script-loader.php comporte les accolades en lignes 707-708 comme indiqué dans le message d’erreur.
    (pour admin-bar.php, c’est la ligne 107 qu’il faut consulter; mais j’ai vérifié dans une version 5.0.13 téléchargée, pas d’accolade dans ce fichier à la ligne 107 ??)

    Enfin, si c’est lié à la version de PHP (PHP 7.4 n’étant pas prévu pour votre version actuelle), vous pourriez essayer de “redescendre” en PHP 7.1 chez votre hébergeur. Je laisse @ferman le soin de vous expliquer comment procéder, car c’est spécifique à OVH.

    Concernant “twentysixteen,” j’ai un tout petit espoir : votre capture d’écran montre qu’il y a un espace entre la fin du mot twentysixteen et votre curseur.
    Bon, ça n’a peut-être rien à voir, mais le diable se cache dans les détails : retournez dans votre base de données, dans la fameuse table xxx_options aux lignes 40 et 41, et supprimez l’éventuel espace qui serait à la suite du mot twentysixteen

    Quand ce sera fait, on essaiera de retourner encore une fois en 4.9.18. Comme vous aviez accès à votre thème et au tableau de bord, on pourra peut-être activer réellement twenty sixteen, avant de replonger le patient en coma artificiel pour essayer d’avancer.

    Vous le faites toute seule, ou vous me donner les accès de votre site (et vos identifiants de connexion au FTP) par message privé, si vous voulez.

    #2380575
    ferman
    Participant
    Maître WordPress
    4425 contributions

    Merci, je pense voir l’erreur pour script-loader (on va voir ce qu’on fait avec ça). Pour l’autre, désolé, je me suis mal exprimé :

    …et faites pareil pour admin-bar.php (le deuxième message).

    Je voulais dire faites une copie d’écran de la ligne indiquée dans le deuxième message  (la ligne 1017) et les lignes au dessus et au dessous.

    #2380581
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Salutations les Chirurgien(ne)s !

    Alors entre la première et la deuxième tartine du matin, voici la capture d’écran d’admin-bar ligne 1017 .

    Maintenant je vais me plonger dans le post plus long de Flobogo !

    Cordialement

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2380584
    ferman
    Participant
    Maître WordPress
    4425 contributions

    Bonjour,

    Ce n’est vraiment pas de chance. Apparemment, la version 5.0.13 de wordpress n’aime pas php7.4.  la première erreur est la présence de {} dans le fichier script-loader ($value{0}) aux lignes 707 et 708 alors que php7.4 n’accepte plus cette syntaxe (il faudrait $value[0]). On ne voyait pas ça dans votre version précédente de wp (4.9.18) car le fichier script-loader de cette version ne contient pas de {}.

    Donc c’est assez paradoxal mais la version wordpress la plus ancienne semble plus compatible avec PHP7.4  (en tout cas pour ce fichier) que la plus récente.

    Est-ce-que cette erreur (et la deuxième) suffit à expliquer l’écran blanc, ce n’est pas sûr mais en tout cas ce n’est pas bon.

    Important: Pour la deuxième erreur je viens de voir votre réponse avec la copie d’écran. Il manque une bonne partie du fichier (les lignes 1017 à 1056). Cela ne peut donc pas marcher. Avant de passer à la suite, par FTP, ouvrez de dossier “includes”  et retransférez ce fichier depuis votre téléchargement de wordpress version 5.0.13. Vérifiez ensuite à tout hasard si le site n’est pas réapparu.

    Le Dr Flobogo et moi avons longuement discuté hier soir le cas du patient autour de la machine à café (fictive) et sommes arrivés aux conclusions suivantes.

    Bidouiller le fichier script-loading pour essayer de le rendre compatible avec php7.4 serait une perte de temps. Il y a une autre erreur (admin-bar) et peut-être que d’autres incompatibilités non encore révélées existent. Il faut donc en priorité revenir à une version PHP plus tolérante, tant que le processus de mise à jour de wordpress n’est pas plus avancé. Au moins jusqu’à 5.5.

    Les recommandations :

    1. Revenir en PHP 7.1 :

    Vous avez déjà fait l’opération en sens inverse (vers 7.4) donc ça ne devrait pas vous poser de problème. Pour mémoire : vous allez dans votre hébergement OVH -> informations générales -> version PHP globale -> presser les … -> modifier configuration courante. Vous choisirez 7.1 (s’il n’y a pas 7.1 prenez 7.2). Il faudra peut- être modifier ovhconfig (par ftp) pour refléter ce changement. En cas de problème, vous pouvez regarder le forum OVH ICI. Si tout se passe bien on devrait de nouveau avoir accès au site et il faudra alors continuer la mise à jour de wordpress par étapes comme expliqué par le Dr. Flobogo précédemment.

    1. Si le patient ne réagit pas :

    Il faudra alors revenir à la version wordpress 4.9.18. Le site devrait être alors visible et recommencer le processus de mise à jour à partir de là. (voir l’avis du Dr. Flobogo ci dessus).

    1. S’il n’y a toujours pas de réaction du patient :

    Il faudra encore (il commence à avoir l’habitude) le ressusciter au moyen d’une restauration vigoureuse (peut-être à j – 15, en tout cas une période où le site était encore visible). Vous avez déjà fait ça il me semble donc ça ne devrait pas vous poser de problème mais vous n’aurez sans doute pas à en venir là.

    Voila qui devrait vous occuper après le petit déjeuner. Bon courage.

     

    • Cette réponse a été modifiée le il y a 2 mois et 3 semaines par ferman.
    #2380600
    ferman
    Participant
    Maître WordPress
    4425 contributions

    Bonsoir,

    Après vérification, je complète ce que je disais:

    Pour mémoire : vous allez dans votre hébergement OVH -> informations générales -> version PHP globale -> presser les … -> modifier configuration courante. Vous choisirez 7.1 (s’il n’y a pas 7.1 prenez 7.2).

    ET  modifier environnement d’exécution  de stable64 à stable (voir cette page du forum ovh).  Cela devrait suffire et il ne devrait pas y avoir besoin d’aller modifier manuellement OVHconfig, contrairement à la dernière fois (il y a un certain temps) où je suis passé de 7.3 à7.4. Maintenant c’est plus simple. Mais vous aviez sans doute trouvé toute seule.

    • Cette réponse a été modifiée le il y a 2 mois et 3 semaines par ferman.
    #2380631
    sandrinesia
    Participant
    Initié WordPress
    46 contributions

    Bonjour Vous Deux !

    Bein mince, voilà que je viens parasiter vos pauses cafés virtuelles avec mon patient moribond !!! Moche ! Quel soutien et dévotion de votre part ! ça a tellement touché Moribond qu’il a réouvert un oeil ! Ouiiii !

    1 – Effectivement en lui mettant un admin-bar.php complet, mon site est réapparu sous la version twentysixteen  Parfait !

    2 – J’ai également pu passer en version antérieure du PHP sur OVH, désormais je suis en 7.1 stable   Lorsque j’essaie d’aller sur l’admin de mon site, j’ai un message de mise à jour de bases de données, je n’ai rien validé, j’ai juste tout refermé. voici le message en question :

    WordPress a été mis à jour ! Avant de vous laisser continuer, nous devons mettre à jour la base de données. Le processus de mise à jour peut prendre un certain temps, merci donc pour votre patience.

    3 – Je suppose que la suite des mises à jour à mettre en pratique de Dr Flobogo est celle-ci  :   vous pouvez passer en WP 5.2.11 puis 5.4.6, puis 5.6.4 et enfin 5.7.2, toujours de la même façon, en sauvegardant la base de données entre chaque étape. Seulement arrivée en 5.7.2, vous pourrez (si tout va bien) accéder à l’admin, et vous rendre dans l’onglet Outils > santé du site, pour passer en HTTPS.

    Belle journée

    Sandrine

    PS : merci encore

15 sujets de 61 à 75 (sur un total de 96)
  • Vous devez être connecté pour répondre à ce sujet.