Site WordPress cassé affichage différents & sans CSS (Créer un compte)

  • WordPress :6.1
  • Statut : non résolu
  • Ce sujet contient 7 réponses, 3 participants et a été mis à jour pour la dernière fois par Dave_COM, le il y a 2 semaines.
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2436921
    Dave_COM
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4
    • Thème utilisé : Astra
    • Extensions en place : Duplicate Page, Elementor, Elementor Pro, UpdraftPlus – Sauvegarde/Restauration, WooCommerce
    • Nom de l’hébergeur : Namecheap
    • Adresse du site : connectoutremer.site (adresse non sécurisé HTTP)

    Problème(s) rencontré(s) : 
    Le site que nous développons actuellement tombait régulièrement, il affichait une mise en page très différente de ce que l’on mettait en place, des menus totalement cassés et surdimensionnés, des formes qui n’étaient pas choisi apparaissait sur certaines sections… Nous avons développé le site à l’aide d’un premier template acheté sur themeforest (https://preview.themeforest.net/item/aguvic-creative-digital-agency-elementor-template-kit/full_screen_preview/35177642?_ga=2.24795514.1737510158.1644591036-1768851004.1644591036) ensuite, nous avons acheté un second template (qui est l’actuel : https://preview.themeforest.net/item/minerva-public-relation-creative-agency-elementor-template-kit/full_screen_preview/34013771?_ga=2.45227364.1737510158.1644591036-1768851004.1644591036) en pensant que le problème venait du précédent template. Finalement, le problème persiste davantage et est permanent.

    Les manipulations que nous avons déjà essayées :

    Vider les données de nos navigateurs
    Remplacer les blocs et sections qui changent de mise en page
    Désactiver et réactiver tous les plugins progressivement
    Changer de template, réinstaller le module WP et recréer le site from scratch
    Utiliser des plugins de mise en cache
    Désactiver les plugins hors de la liste classique
    L’hébergement et la base de données sont en bon état et loin d’être saturée.

    J’ai cherché des solutions à ce problème via les différents blogs, mais je n’ai rien trouvé qui se rapproche de ma situation, que devrais-je faire pour résoudre cette erreur ?
    Merci par avance à tous les membres de la communauté WPFR

    • Ce sujet a été modifié il y a 1 mois et 1 semaine par Dave_COM. Raison : Forme message
    • Ce sujet a été modifié le il y a 1 mois et 1 semaine par Dave_COM.
    • Ce sujet a été modifié le il y a 1 mois et 1 semaine par Dave_COM.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2436970
    momofr@free.fr
    Modérateur
    Maître WordPress
    5495 contributions

    Salut, il te faut régénérer les ressources dans les outils d’Elementor.

    A faire de temps en temps lors du développement et selon les réglages faits dans Elementor (réglages du site).

    #2437080
    Dave_COM
    Participant
    Initié WordPress
    5 contributions

    Bonjour, j’ai régénéré les ressources CSS à partir des outils de Elementor. L’affichage sur les différents navigateurs n’a pas été rétablis sauf sur safari. (J’ai également supprimé de nouveau les données de navigation de chaque navigateur)

    J’ai oublié de préciser que deux plugins apparaissent dans la catégorie « Indispensable » –  EasyWP Plugin  & « Avancée » – Redis Object Cache

    Il m’avait été conseillé de désactiver les plugins de mise en cache sur le site, donc je les ai désactivés à partir du serveur FTP. Ce matin, j’ai remarqué que les fichiers se sont régénérés et sont de nouveaux actifs sur le site.

    #2437082
    momofr@free.fr
    Modérateur
    Maître WordPress
    5495 contributions

    Salut, lorsque tu parle de « Indispensable » tu veux dire des mu-plugins je suppose.

    Ton hébergeur étant aux USA ils utilisent peut être un CDN en Europe ce qui peut expliquer cela, une inspection de tout ton hébergement te dira ce qu’il en est.

    Pour un site à ciblage FR ou Europe il est conseillé d’être hébergé en France.

    #2437129
    Dave_COM
    Participant
    Initié WordPress
    5 contributions

    Oui c’est bien ça le fichier mu-plugins. En effet nous avons choisit l’hébergeur NameCheap localisé au USA. Hé bien nous avons l’habitude d’hébergé nos sites chez eux pour certains de nos clients, généralement ça se passe bien. (Nous sommes basé dans les Caraïbes en Guadeloupe)
    Je te remercie pour tes éclaircissements, nous allons nous rapprocher de l’hébergeur en attendant.

    #2437189
    Flobogo
    Modérateur
    Maître WordPress
    19084 contributions

    Bonjour,

    Je ne comprends pas bien : vous utilisez le thème Astra et des templates  ? Ils sont adaptés pour Astra au moins ??

    #2437676
    Dave_COM
    Participant
    Initié WordPress
    5 contributions

    Bonjour, Oui le template est compatible avec le thème Astra
    J’ai contacter l’hébergeur, le conseiller m’a expliqué que le problème provient de la sécurité du site donc il a fait une manipulation pour redirigés les liens. Le site se comporte mieux pour le moment

    #2440528
    Dave_COM
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Nous pensions avoir réglé le souci en contactant l’hébergeur et en mettant en appliquant leurs instructions. Cependant, le site à toujours tendances à être endommagé par moment. Nous avons régénéré les CSS et les données, ce qui a eu pour effet de rétablir l’affichage.

    Le technicien de l’hébergeur NameCheap à également vérifier et remplacer tous les liens pour que ça ne se reproduise pas, mais pour le moment, nous rencontrons toujours ce problème et notre hébergeur ne semble pas pouvoir ne venir en aide à ce niveau.

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.