[Résolu] Site signalé non sécurisé uniquement avec Firefox (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
  • Ce sujet contient 25 réponses, 5 participants et a été mis à jour pour la dernière fois par ungars, le il y a 2 années.
15 sujets de 1 à 15 (sur un total de 26)
  • Auteur
    Messages
  • #2403567
    ungars
    Participant
    Chevalier WordPress
    390 contributions

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 7.3 / Mysql : 5.0.12
    • Thème utilisé : Spice Press
    • Extensions en place : Complianz, Contact Form 7, Yoast, Cookie Notice, Really Simple Css, Site Origin Css, Spicebox, WordPress Importer
    • Nom de l’hébergeur : Online.net
    • Adresse du site : http://www.ahpc-energie.fr

    Bonjour,

    Je constate que la page d’ accueil semble contenir des éléments non sécurisé quand je l ‘ouvre avec Firefox. Avec les autres navigateurs, je n’ ai pas ce problème (Chrome, Chromium, Edge) .

     

    Il y aurait des éléments non sécurisés comme des images.

     

    Je ne comprends pas pourquoi je n’ ai ce message qu’ avec Firefox.

     

    Quand j’ ai passé ce site en construction en HTTPS, j’ ai bien suivi le tuto mis à disposition par l’ hébergeur : installer un certificat de sécurité via Cpannel, et forcer le https toujours avec Cpannel.

    Je vous remercie pour votre aide, bonne soirée

    • Ce sujet a été modifié le il y a 2 années par ungars.
    #2403571
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bonsoir, peut-être en suivant ce tutoriel :https://wpmarmite.com/contenu-mixte-wordpress/

     

    #2403579
    Flobogo
    Modérateur
    Maître WordPress
    20159 contributions

    Bonjour,

    Votre site (en tous cas, la page d’accueil) contient des images qui proviennent d’un site extérieur (casperland . net/adil/), qui est en HTTP.
    (j’ai mis le nom du site avec espace, pour désactiver le lien)

    Hébergez ces images sur votre propre site, cela vous évitera des ennuis possibles sur le droit à l’image de l’autre site, et ainsi, vos images seront en HTTPS.

    Et pour info, votre version HTTP redirige mal vers la version HTTPS, selon Sucuri. Consultez ces consignes à mettre dans votre fichier .htaccess au  point 3.1 de leur tuto.

    #2403581
    ungars
    Participant
    Chevalier WordPress
    390 contributions

    Bonsoir, merci à tout le monde pour vos réponses.

    Votre site (en tous cas, la page d’accueil) contient des images qui proviennent d’un site extérieur (casperland . net/adil/), qui est en HTTP.

     

    J’ avais commencé le site sur une url provisoire, casperland.net

    J’ ai transféré ensuite le site sur l’ url actuelle. J’ ai constaté que les images de toutes les pages (sauf celle d’ accueil) n’ apparaissaient pas.

    J’ ai contacté mon hébergeur, qui m’ avait aussi fait remarqué que mes images étaient toujours aussi hébergées sur l’ ancienne Url.

    Donc mon problème vient peut être effectivement de là.

    Dans les reglages généraux du site, je constate que les adresses du site ne sont pas en https, mais en http. Je corrige et mes images apparaissent. Je pensais que mon problème était reglé.

     

    Du coup, comment cela se fait que mes images soient toujours hébergées sur mon ancienne url ?

    J’ ai bien modifé le fichier wp-config, avec les coordonnées de mon nouvel hebergeur. Dans Phpmyadmin, à la rubrique « options » , les urls (site url et home) sont les bonnes : https://www.ahpc-energie.fr

     

    Merci encore une fois pour le coup de main, bonne soirée.

     

     

    #2403584
    Flobogo
    Modérateur
    Maître WordPress
    20159 contributions

    Ben, l’ancienne URL existe toujours (je n’ai pas compris si c’est chez le même hébergeur ou un autre), et vos images de l’accueil ont cette URL. Ou alors, c’est la redirection de l’ancienne URL vers la nouvelle qui n’est pas bonne. À voir selon comment cela a été fait : dans le fichier .htaccess ? avec une extension ?

    #2403585
    ferman
    Participant
    Maître WordPress
    6998 contributions

    Phpmyadmin, à la rubrique « options » , les urls (site url et home) sont les bonnes

    Mais vous n’avez apparemment pas modifié les liens vers les images et comme l’ancien site existe encore, le nouveau va y chercher les images. Pour modifier les liens, personnellement, j’utilise le plugin « better search replace » .  Attention à ne pas faire d’erreur en l’utilisant autrement il faudra restaurer votre base de données. Lire les FAQ sur la page du plugin.

    • Cette réponse a été modifiée le il y a 2 années par ferman.
    • Cette réponse a été modifiée le il y a 2 années par ferman.
    • Cette réponse a été modifiée le il y a 2 années par ferman.
    #2403621
    ungars
    Participant
    Chevalier WordPress
    390 contributions

    Bonjour, merci pour vos réponse.

    J’ ai juste modifier le fichier config.php, et « options » dans phpmyadmin, ce n’ est donc pas suffisant ?

    Si je supprime l’ ancienne url, ce que je comptais faire, cela suffirait ?

    Merci beaucoup, bonne journée.

    #2403622
    ungars
    Participant
    Chevalier WordPress
    390 contributions

    Pour Flogobo, c’ est une url qui existe chez un autre hébergeur.

    Je n’ ai pas touché au fichier .htaccess

    #2403643
    ferman
    Participant
    Maître WordPress
    6998 contributions

    J’ ai juste modifier le fichier config.php, et « options » dans phpmyadmin, ce n’ est donc pas suffisant ?

    Non, ce n’est pas suffisant; il faut aussi modifier les liens des images. Et s’il y a des widgets avec des liens écrits « en dur » il faudra corriger manuellement ces adresses.

    Si je supprime l’ ancienne url, ce que je comptais faire, cela suffirait ?

    Non, comme il n’y aura plus d’image accessible avec le lien indiqué, vous n’aurez plus d’image du tout; juste un espace vide.

    Pour le remplacement avec « better search replace » il faudra sélectionner toutes les tables et faire:

    chercher:  http://www.casperland.net/adil

    remplacer par: https://www.ahpc-energie.fr

    Ne mettez pas de / à la fin de ces deux urls

    Faites un essai à blanc avant d’effectuer effectivement le remplacemnt.

     

     

     

     

     

    #2403671
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions

    Ou utiliser really simple ssl qui fait le job tout seul

    #2403758
    ungars
    Participant
    Chevalier WordPress
    390 contributions

    Bonsoir, merci pour votre aide.

    Le problème vient surement effectivement de mes Urls, qui sont restées chez mon ancien hébergeur.

    Les tutos que j’ avais suivi, dont celui de mon hebergeur ne parle pas tous de cette étape.

     

    Ou utiliser really simple ssl qui fait le job tout seul

    Pour forcer le https, j’ ai suivi la méthode de mon hébergeur .  Si je rajoute le plugin par dessus, est ce que cela ne posera pas problème ? Le plugin corrige aussi mon problème de redirection ?

     

    Avant d’ utiliser telle ou telle méthode, je vais faire une sauvegarde des mes fichier plus ma base de données.

     

    J’ ai vu aussi que l’ on pouvait faire une requète sql.  Vous en pensez quoi ?

    Si j’ ai bien compris, on ne peut pas le faire table par table à la main.

     

    Merci encore pour votre aide, et pour le temps que vous me consacrez. Bonne soirée.

     

     

    #2403763
    ferman
    Participant
    Maître WordPress
    6998 contributions

    Avant d’ utiliser telle ou telle méthode, je vais faire une sauvegarde des mes fichier plus ma base de données.

    Oui et c’est d’ailleurs recommandé par « better search replace ».

    J’ ai vu aussi que l’ on pouvait faire une requète sql.  Vous en pensez quoi ?

    Que c’est également une possibilité si vous n’avez pas peur d’aller dans la base de données et qu’il ne faut pas se planter.

    Si j’ ai bien compris, on ne peut pas le faire table par table à la main.

    Bien sûr que si. Que ce soit la requête ou avec le plugin. Mais vous voyez qu’ils ne font la requête que sur la table wp_posts. C’est suffisant. Faire les tables les unes après les autres est inutile..

     

     

     

    #2403764
    Flobogo
    Modérateur
    Maître WordPress
    20159 contributions

    c’ est une url qui existe chez un autre hébergeur.

    Si je comprends bien, puisque cette URL existe toujours, ça veut dire que vous payez toujours cet hébergement. Bon, c’est votre choix, mais c’est un peu … curieux 🙄

    Par contre, comme le dit @ferman, si vous supprimez cette URL (l’espace hébergement correspondant), vous n’aurez plus vos images.

    Donc, avant de faire ça, rapatriez toutes vos images chez votre nouvel hébergeur (téléchargez-les dans la médiathèque du site ahpc-energie). Et comme ça, elles seront directement en HTTPS.


    @lumiere-de-lune
    : sauf erreur de ma part, l’extension Really Simple SSL ne corrige que les URL des images internes, pas celles venant d’un contenu externe, ce qui est donc le cas ici.

    #2403823
    ungars
    Participant
    Chevalier WordPress
    390 contributions

    Bonjour, merci pour vos réponses.

    Je suis en train  de faire ma sauvegarde (fichiers + base de données).

    Je vais utiliser le plugin better search.

    Si je comprends bien, puisque cette URL existe toujours, ça veut dire que vous payez toujours cet hébergement. Bon, c’est votre choix, mais c’est un peu … curieux

    C’ est une url que j’ ai avec mon mail chez Online, et je m’ en suis servi pour commencer à faire le site de mon ami, avant de le voir pour acheter son nom de domaine (il voulait que l’ on le fasse ensemble) .

     

    Donc, avant de faire ça, rapatriez toutes vos images chez votre nouvel hébergeur (téléchargez-les dans la médiathèque du site ahpc-energie). Et comme ça, elles seront directement en HTTPS.

    Elles y sont bien, pourtant.  Mais si je vais dans la base de données sur la table ad_posts, les adresses sont bien sur l’ ancienne Url

     

    Merci encore, bonne journée à vous.

    #2403824
    ferman
    Participant
    Maître WordPress
    6998 contributions

    Elles y sont bien, pourtant. Mais si je vais dans la base de données sur la table ad_posts, les adresses sont bien sur l’ ancienne Url

    Oui, actuellement vos images sont dans l’ancien site ET le nouveau mais les liens dans la base de données pointent uniquement vers l’ancien site. C’est ce que « better search replace » modifie.

15 sujets de 1 à 15 (sur un total de 26)
  • Vous devez être connecté pour répondre à ce sujet.