[Résolu] Site planté : error 500 (Créer un compte)

  • WordPress :4.9
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #1985079
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Bonjour,

    Ce matin, sans aucune modification de ma part, je découvre mon site planté avec un message d’erreur 500.

    En me balladant sur le web j’apprends que je peux la contourner en renommant le fichier .htaccess en .htacces_bak

    Effectivement l’accès à ma page d’accueil fonctionne mais pas les liens internes qui donnent une erreur 404.

    En allant sur la page d’admin je trouve des remarques relatives à l’extension very-simple-SSL

    J’ai essayé de la supprimer, sans succès, et j’ai tenté de supprimer les données la concernant dans le fichier .htacces sans succès non plus.

    Je ne comprends pas car je suis totalement nul en programmation. Pouvez-vous me dire si ce problème est lié à mon site, à une mise à jour de WordPress qui se serait exécutée dans la nuit ou à mon fournisseur d’accès à internet ?

    Merci.

    #1985168
    PhiLyon
    Modérateur
    Maître WordPress
    26596 contributions

    Bonjour.

    Remplis le questionnaire que l’on y voit plus clair.

    🙂

    #1985192
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Salut,

    Je suppose que tu veux parler du détail de mon installation ?

    Je suis à jour de la dernière version 4,9 et j’utilise les extensions suivantes : Advanced Ads, Advanced Custom Fields, Akismet Anti-Spam, Avatar Manager, Bad Behavior, Block Bad Queries (BBQ), Broken Link Checker, Captcha, Cocorico Social, Colissimo Delivery Integration, Compact Audio Player, Contact Form 7, Events Manager, FD Feedburner Plugin, Flamingo, Flat Rate per State/Country/Region for WooCommerce, Limit Login Attempts, Livre d’or Gwolle (Gwolle GuestBook), MailPoet 3, Poll, Survey, Quiz, Slideshow & Form Builder, Print, PDF & Email by PrintFriendly, PS Auto Sitemap, Really Simple CAPTCHA, Really Simple SSL, Simple Cookie Notification Bar, Simple Tags, TinyMCE Advanced, WooCommerce, WordPress Database Backup, WP-Optimize, WP-PostViews, WPtouch Mobile Plugin, Yoast SEO.

    J’insiste sur le fait que cette configuration fonctionne sans problème depuis plusieurs mois et que certaines de ces extensions sont en place depuis plusieurs années. J’ai vérifié qu’aucune mise à jour automatique de WP ne s’est effectuée cette nuit, qui aurait pu interférer avec une extension devenue incompatible.

    #1985197
    PhiLyon
    Modérateur
    Maître WordPress
    26596 contributions

    L’adresse du site et l’hébergeur sont secrets ?

    🙂

    #1985208
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Non. Je suis chez Infomaniak et l’adresse est https://www.catharisme.eu

    Avec mon .htaccess renommé en .hataccess-bak la page d’accueil est accessible mais les liens internes ne fonctionnent plus (erreur 404). Si je remet le .htaccess normal j’obtiens l’erreur 505 à la place de la page d’accueil.

    #1985221
    Joss47
    Modérateur
    Maître WordPress
    4727 contributions

    Bonjour,

    Tu as essayé tout bêtement d’appliquer de valider les permaliens via le back office de WP ?

    #1985223
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Le problème semble venir du .htaccess

    Je viens de mettre un fichier ne contenant que les infos de base :

    <span class=”token comment” spellcheck=”true”># BEGIN WordPress</span> <span class=”token directive-inline property”>RewriteEngine</span> On <span class=”token directive-inline property”>RewriteBase</span> / <span class=”token directive-inline property”>RewriteRule</span><span class=”token regex”> ^index\.php$</span> – <span class=”token directive-flags keyword”>[L]</span> <span class=”token directive-inline property”>RewriteCond</span> <span class=”token variable”>%{REQUEST_FILENAME}</span> !-f <span class=”token directive-inline property”>RewriteCond</span> <span class=”token variable”>%{REQUEST_FILENAME}</span> !-d <span class=”token directive-inline property”>RewriteRule</span> . /index.php <span class=”token directive-flags keyword”>[L]</span> <span class=”token comment” spellcheck=”true”># END WordPress</span>

    Et cela semble fonctionner.

    Je vais continuer en rajoutant, petit à petit ce qu’il y avait avant.

    #1985225
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Je n’ai touché à rien en Back office depuis des mois. Cela aurait pu se modifier tout seul ?

    #1985226
    Joss47
    Modérateur
    Maître WordPress
    4727 contributions

    Voila, d’où ma question juste au dessus afin d’avoir un htacces propre ne sachant pas s’il y avait eu des modifications 😉
    Et oui, des plugins peuvent écrire dans le fichier htaccess donc quelque chose ne doit pas lui plaire, il faudra inspecter le fichier au jour le jour jusqu’au nouveau plantage

    N’oublie pas de passer en résolu en haut à gauche.

    #1985234
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Est-ce que je peux publier mon contenu du .htaccess pour que vous m’aidiez à la nettoyer car je n’y comprends rien ? Cela n’est pas susceptible d’aider un pirate à pénétrer mon site ?

     

    #1985239
    Joss47
    Modérateur
    Maître WordPress
    4727 contributions

    Oui tu peux même si je ne suis pas un expert de ce côté la…
    Mais au vu de tes extensions il y a fort à parier que la faute est de Really Simple SSL 🙂

    #1985242
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Sur tout le fichier .htaccess, la seule ligne de code qui provoque une erreur est la suivante :

    Options All -Indexes

    J’avais cru comprendre qu’elle servait à empêcher les pirates d’afficher mes répertoires internes.

    Si je la supprime cela n’affecte-t-il pas la sécurité de mon site ?

    #1985243
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    Voila mon .htaccess actuel (qui semble fonctionner) :

    # SECTION BEGIN SubDomainOnFolder
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^(forum)\.
    RewriteCond %{REQUEST_URI} !^/(forum)/
    RewriteCond %{DOCUMENT_ROOT}/%1 -d
    RewriteRule ^(.*)$ %1/$1 [L]
    # SECTION END SubDomainOnFolder

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.4.3]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    <IfModule mod_headers.c>
    Header set Strict-Transport-Security: “max-age=31536000” env=HTTPS
    </IfModule>
    # END rlrssslReallySimpleSSL

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    <files .htaccess>
    order allow,deny
    deny from all
    </files>

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https [NC]
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    #1985247
    Joss47
    Modérateur
    Maître WordPress
    4727 contributions

    Bon ba laisse le comme ça et ne le touche plus alors 😀 !

    N’oublie pas de passer en résolu en haut à gauche ;).

    #1985252
    Guilhem
    Participant
    Maître WordPress
    578 contributions

    MErci.

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.