[Résolu] site piraté (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
15 sujets de 61 à 75 (sur un total de 105)
  • Auteur
    Messages
  • #2394395
    ferman
    Participant
    Maître WordPress
    5394 contributions

    Et vous n’avez qu’une seule base de données? C’est à dire: quand vous avez installé wordpress vous n’avez pas créé une seconde base de données?  Pouvez-vous confirmer ce point?

    par ailleurs, faire une importation dans la base telle que vous la montrez sur la copie d’écran n’est pas possible: vous auriez une erreur.  Il faut auparavant la vider (pas la supprimer). Pour cela il faudra sélectionner toutes les tables puis faire : « avec la sélection: supprimer ».  Regardez ICI (en anglais mais ça ne pose pas de problème). Si quelque chose n’est pas clair demandez avant de continuer.

     

    #2394396
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    La ligne de code /** MySQL hostname */ define(‘DB_HOST’, ‘lillemet.mysql.db:3306’); correspond t elle bien à l’adresse serveur chez ovh ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2394403
    ferman
    Participant
    Maître WordPress
    5394 contributions

    D’après ce que je vois, non: vous ne devriez pas avoir  :3306. Je ne vois pas d’où ça vient. Essayez de l’enlever.

    #2394407
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    non je ne pense pas avoir créé une seconde base de données, de toute façon je devrai la voir afficher dans l’onglet base de donnée chez l’hébergeur ? J’ai modifié le mot de passe supprimé un profil suspect dans phpyadmin. C’est tout. Concernant la maj wordpress et le thème oceanwp, celui ci doit bien etre téléchargé à partir d’une version ‘saine’ / vierge sur wordpress.org ou fallait il télécharger le thème oceanwp à partir de l’ancienne version ?

    #2394410
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    c’est modifié mais rien de nouveau

    #2394422
    ferman
    Participant
    Maître WordPress
    5394 contributions

    celui ci doit bien etre téléchargé à partir d’une version ‘saine’ / vierge sur wordpress.org

    Oui, c’est ça.

    je devrai la voir afficher dans l’onglet base de donnée chez l’hébergeur

    Oui, vous la verriez.

    #2394425
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    N’y aurait il pas un pb au niveau de la compatibilité php et du thème wordpress oceanwp ? Une personne plus qualifiée m’a dit qu’il peut arriver aussi que les thèmes ne supportent pas les dernières versions php. Il me semble que le thème Oceanwp est limité à cet effet car il y avait effectivement un message de pb de compatibilité. J’ai essayé de rétrogradé la version php en 7.0 mais cela n’a pas changé. Mon soucis c’est que je n’ai plus aucun contenu, template vierge comme si je repartais de zero.

    #2394426
    ferman
    Participant
    Maître WordPress
    5394 contributions

    N’y aurait il pas un pb au niveau de la compatibilité php et du thème wordpress oceanwp

    Peut-être mais ça n’explique pas le problème. De plus Ocean wp est un bon thème qui accepte à coup sûr toutes les versions de php jusqu’à 7.4 (peut-être pas 8.0.  Rétrograder en 7.0 est mauvais  car cette version est obsolète.

    Je ne comprends pas très bien: dans la copie d’écran de votre base de données vous avez deux types de préfixes: wor3342_ et wp_.  A quoi cela correspond-il et quel est le préfixe mentionné dans votre wp-config? Vous n’avez pourtant pas deux sites sur la même base de données?

    Pouvez-vous lister l’ensemble des tables de votre base de données?

    • Cette réponse a été modifiée le il y a 8 mois par ferman.
    • Cette réponse a été modifiée le il y a 8 mois par ferman.
    #2394431
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    voici en aperçu le prefix dans le fichier wpconfig en pièce jointe. Es ce que cela répond à votre question ? Du coup, je me demande si je ne me serai pas emmêlé les pinceaux entre les sauvegardes export / import de la bdd via l’extension updraft et phpmyadmin ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2394433
    ferman
    Participant
    Maître WordPress
    5394 contributions

    je ne me serai pas emmêlé les pinceaux entre les sauvegardes export / import de la bdd via l’extension updraft et phpmyadmin ?

    Je dirais que c’est une possibilité (mais je ne sais pas ce que vous avez fait).  Je dirais(sans en être sûr) que vous avez importé des tables avec le préfixe wp dans une base contenant déjà des tables avec le préfixe wor3442, ou l’inverse. Si ce n’est que ça ce n’est pas trop grave. Pouvez-vous faire la liste des tables de votre base de données avec les deux préfixes. Il me semble aussi que vous avez woocommerce ou bien je me trompe? Je ne vois pas les tables correspondantes. Je pense qu’il va falloir clarifier tout ça et repartir sur des bases saines. Pour le moment il n’y a pas d’inquiétude à avoir. Avez-vous des sauvegardes de base de données autre que celles faites avec updraft plus? A la limite on pourra en récupérer chez l’hébergeur.

    • Cette réponse a été modifiée le il y a 8 mois par ferman.
    #2394449
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    Oui, je pense que je vous ai mis sur la piste. Il y a du avoir un couac avec la bdd. Voici un aperçu en pièce jointe des tables. Oui, j’ai fais quelques  sauvegardes updraft+phymyadmin, et il y en a aussi normalement chez ovh.

    « Pour le moment il n’y a pas d’inquiétude à avoir. » ça me rassure un peu car je vous avoue que je n’étais pas serein …

    • Cette réponse a été modifiée le il y a 8 mois par Webmaster59.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2394454
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    suite

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2394459
    ferman
    Participant
    Maître WordPress
    5394 contributions

    Essayez de remplacer dans wp-config le préfixe actuel par wp_.

    #2394463
    Flobogo
    Modérateur
    Maître WordPress
    18621 contributions

    Bonjour,

    Effectivement, vous avez des tables avec 2 préfixes différents, correspondant à 2 installations WP différentes. Ce qui est bizarre quand même, c’est que même celle avec le préfixe wor**** contient des tables pour Yoast, ce qui ne correspond pas à une installation vierge.

    Vous aviez fait une sauvegarde de wp-config.php avant d’attaquer tous les changements, comme je l’avais demandé ?

    Si oui, il suffit de regarder quel préfixe était indiqué, il est mentionné quelques lignes en-dessous du nom de base de données. Pareil d’ailleurs pour le nom de votre base de données. En fait, il vous suffit de vérifier si ce fichier est sain*, et si oui, vous le renvoyez par FTP à la place de l’autre, en modifiant au préalable juste le mot de passe puisque vous l’avez changé.

    * vérifier si le fichier est sain, ça ne veut pas dire le passer à l’antivirus de l’ordinateur (je pense que ça ne sert à rien), ça veut dire vérifier qu’il n’y a aucune ligne vierge avant la balise d’ouverture <?php et aucune ligne avec une série de chiffres et de signes, comme indiqué dans le tuto.

    De même, à aucun moment dans le tuto je ne parle de UpdraftPlus, donc qu’est-ce que ça vient faire là ? Votre site doit d’abord être réinstallé « de base », avec juste son contenu (textes-iamges), mais pas les extensions. Donc, ni Yoast, ni UpdraftPlus, ni aucune autre, sauf l’extension de maintenance puisqu’elle est est saine, elle a été téléchargée après.

    Si vous ne suivez pas les consignes, c’est les cafouillages sont inévitables, mais on va y passer encore plus de temps.

    #2394470
    Webmaster59
    Participant
    Chevalier WordPress
    335 contributions

    updraft est une extension qui permet d’effectuer des sauvegardes de la bdd, thème. Comment récupérer ces données sans installer l’extension, tout comme wp maintenance, comment mettre le site en maintenance si vous n’avez pas (activé) le plugin ? Je ne comprend pas votre question. Je n’ai pas trouvé de code bizarre dans le fichier. Je pense que j’ai du faire un import sans avoir supprimer les tables au préalable si je suis votre raisonnement qu’il ne devrait pas y avoir deux prefix.

    • Cette réponse a été modifiée le il y a 8 mois par Webmaster59.
15 sujets de 61 à 75 (sur un total de 105)
  • Vous devez être connecté pour répondre à ce sujet.