[Résolu] Site ne s’ouvre plus sous Firefox. (Créer un compte)

  • WordPress :5.7
  • Statut : résolu
8 sujets de 16 à 23 (sur un total de 23)
  • Auteur
    Messages
  • #2375591
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    WP Super cache n’était pas mentionnée dans vos extensions.

    A mon avis, le problème d’accès sou Firefox était juste lié au cache, et là, on a augmenté les problèmes au lieu de les résoudre. Il faut donc repartir sur des bases saines.

    Je vous conseille de désactiver WP Super cache pendant toute la durée des “travaux”. (si vous n’avez pas accès à l’admin’, passez par FTP, videz à nouveau le cache, et renommez l’extension avec -X à la fin : wp-content/plugins/wp-super-cache-X )

    Désactivez de la même façon l’extension de maintenance + l’extension qui protège l’accès à l’admin  (“protect wp-admin” ?) +Loginizer (si c’est une autre extension de protection de login ?) + Wordfence security

    Il faut d’abord accéder de manière “normale” au site et à l’admin’, pour voir dans un 2ème temps comment les protéger.

    #2375605
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    En effet bizarre que wp-protect ne soit pas listé …

    J’ai suivi les étapes ci-dessus et j’accède désormais à l’administration du site.

    Je ne vois pas de nouveau fichier htaccess créé: normal?

    #2375624
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    La page d’accueil est ok, mais les autres pages donnent une erreur 404 …

    #2375625
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    Toutes les pages sont en 404, même wp-admin ou wp-login.php ?

    Essayez en désactivant toutes les extensions, si besoin à un moment où le site est peu fréquenté. Si ça ne change rien, mettez un thème par défaut. (par FTP, désactivez le thème actuel en le renommant)

    Et supprimez (téléchargez une copie de sauvegarde avant) le fichier .htaccess  (voir ci-dessous) + vérifiez que les tous les dossiers ou sous-dossiers “cache” sont vidés

    C’est forcément soit une extension, soit le thème, soit le fichier .htaccess ou un problème de cache qui provoque cette erreur 404.

    Édit : je n’avais pas fait gaffe à ça :

    Je ne vois pas de nouveau fichier htaccess créé: normal?

    Non, ce n’est pas normal. Il faut que vous ayez accès à l’admin’ pour ré-enregistrer les permaliens. Sinon, reprenez votre fichier .htaccess précédemment sauvegardé et ne gardez que la partie entre # BEGIN WordPress et # END WordPress

    • Cette réponse a été modifiée le il y a 1 mois et 4 semaines par Flobogo. Raison: Édit
    #2375631
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Bonjour,

    je ré-enregistré les permaliens et tout refonctionne normalement.
    Voici le .htaccess généré:

    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Je viens de crééer un nouveau compte (qui était le problème initial) et cela fonctionne aussi !
    Une énorme merci pour votre aide.

    Je réactive Wordfence et j’abandonne les 2 extentions wp-protect et loganizer?

    #2375672
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    je ré-enregistré les permaliens et tout refonctionne normalement.
    (…)
    Je viens de créer un nouveau compte (qui était le problème initial) et cela fonctionne aussi !

    Super 👌

    Je réactive Wordfence et j’abandonne les 2 extentions wp-protect et loganizer?

    Il y a peut-être un conflit entre ces extensions, surtout les 2 dernières qui font la même chose (je crois). Commencez par réactiver WordFence, testez, puis si tout va bien, réactivez une des extensions de protection du login/de l’admin’, sauf si Wordfence propose aussi une option pour ça.

    Et pour finir, réactivez le cache, puis déconnectez-vous et testez à nouveau. Notez bien que le “rendu” du site après mise en cache peut être différent, selon qu’on est connecté ou non, car les changements effectués dans l’admin’ ne sont pas encore mis en cache côté visiteur.

    C’est probablement ce qui a déclenché votre problème sous Firefox : en fait, pas vraiment un problème, juste une mise en cache différente sur votre navigateur habituel.

    #2375674
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Bonjour,

    voilà c’est fait et tout fonctionne nickel.
    Je ne vais pas réactiver les plugin wp-protect et loginiser et me contenter de wordfence.

    Encore merci pour votre temps.

    Je mets le post en réglé.

    #2375765
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    Nickel. Merci d’avoir marqué le post en “résolu”.

8 sujets de 16 à 23 (sur un total de 23)
  • Vous devez être connecté pour répondre à ce sujet.