[Résolu] Site ne s’ouvre plus sous Firefox. (Créer un compte)

  • WordPress :5.7
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 23)
  • Auteur
    Messages
  • #2375014
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Ma configuration WP actuelle :

    • – Version de WordPress : 5.7
    • – Version de PHP/MySQL : 7.3.27 / 5.5.5
    • – Thème utilisé : LeadEngine
    • – Thème URI : http://www.leadengine-wp.com/
    • – Extensions en place : Breadcrumb NavXT (6.6.0), Contact Form 7 (5.4), Contact Form 7 Style (3.1.9), Cookiebot | GDPR/CCPA Compliant Cookie Consent and Control (3.10.0), Duplicate Page (4.4), Forum_wordpress_fr (4.2), KeyDesign Addon (3.9), Loco Translate (2.5.2), Loginizer (1.6.6), Post Types Order (1.9.5.6), Product Slider for WooCommerce (2.2.11), Protect WP-Admin (3.3.1), Really Simple CAPTCHA (2.1), Really Simple SSL (4.0.13), Redux (4.1.24), Slider Revolution (6.3.3), WooCommerce (5.1.0), WOOF – WooCommerce Products Filter (1.2.5.3), Wordfence Security (7.5.2), WordPress Importer (0.7), WPBakery Page Builder (6.5.0), Yoast SEO (16.1.1)
    • – Adresse du site : https://www.acelectronics.be
    • – Nom de l’hébergeur : Apache

     

    Problème(s) rencontré(s) :

    Suite à la création d’un nouvel utilisateur pour la gestion de la boutique de mon site, j’ai désactivé le mode maintenance.
    Depuis lors, l’accès à mon site sous Firefox indique le message ci-dessous:

    “La page n’est pas redirigée correctement
    Une erreur est survenue pendant une connexion à http://www.acelectronics.be.
    La cause de ce problème peut être la désactivation ou le refus des cookies.”

    Je n’ai pas de souci sous Chrome, ni sur Edge, ni sous IE.
    Une config dans mon Firefox?

    Merci pour votre aide.

    #2375015
    PhiLyon
    Modérateur
    Maître WordPress
    27821 contributions

    Bonjour.

    Une config dans mon Firefox?

    Vides le cache, chez moi ça fonctionne.

    🙂

    #2375074
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Merci PhiLyon.

    Ai tout effacé sous Firefox et toujours rien lorsque je veux le loguer en admin sur le site …

    #2375079
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Je vois un avertissement dans les réglages ssl:

    //Begin Really Simple SSL session cookie settings
    @ini_set(‘session.cookie_httponly’, true);
    @ini_set(‘session.cookie_secure’, true);
    @ini_set(‘session.use_only_cookies’, true);
    //END Really Simple SSL cookie settings

    à ajouter dans wp-config.php …

    #2375093
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Bonjour,

    le problème est apparu lorsque j’ai créé un nouvel utilisateur pour gérer la boutique …
    Lorsque je supprime son compte (via accès admin via Chrome), le site est à nouveau accessible en admin via Firefox …

    Quelqu’un aurait une idée du souci?

    Merci.

    #2375158
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    Je vois un avertissement dans les réglages ssl:

    Vous voyez ça où ? Quand ?

    à ajouter dans wp-config.php …

    Et bien, ajoutez ces lignes au wp-config.php (à éditer avec NotePad++ par FTP type Filezilla), en conservant par précaution une sauvegarde avant modification.

    #2375210
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    J’ai ajouté les lignes dans le wp-config.php, mais le problème subsiste.

    Ajout d’un user comme administrateur de la boutique –> message d’erreur.
    Idem si je lui attribue un autre rôle …

    Ci-dessous le httaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteRule ^xxxxx/?$ /wp-login.php [QSA,L]
    RewriteRule ^xxxxx/register/?$ /wp-login.php?action=register [QSA,L]
    RewriteRule ^xxxxx/lostpassword/?$ /wp-login.php?action=lostpassword [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    # Wordfence WAF
    <IfModule LiteSpeed>
    php_value auto_prepend_file ‘/home/acelfeyc/public_html/wordfence-waf.php’
    </IfModule>
    <IfModule lsapi_module>
    php_value auto_prepend_file ‘/home/acelfeyc/public_html/wordfence-waf.php’
    </IfModule>
    <Files “.user.ini”>
    <IfModule mod_authz_core.c>
    Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
    </IfModule>
    </Files>
    # END Wordfence WAF
    RewriteCond %{HTTP_HOST} ^xxxxx\.be$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.xxxxx\.be$
    RewriteRule ^autodiscover$ “https\:\/\/autodiscover\.xxxxx\.be\:443\/Autodiscover\/Autodiscover\.xml” [R=301,L]

    Merci.

    #2375222
    pasglop
    Participant
    Chevalier WordPress
    266 contributions

    Avant que tu mettes en mode maintenance, tous les liens de menu étaient de l’ordre

    <a href="#">

    quelque soit le navigateur. Je ne pense pas que ce fusse voulu ?

    Tu peux déjà voir en réenregistrant les permaliens.

    As-tu vérifié si la base de données n’était pas pleine ?

     

    #2375236
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Bonsoir,

    oui les liens des menus pointaient vers “#” car en attente de contenu …

    J’ai désactivé le mode maintenance, si cela peut aider …

    Je me renseigne pour la bdd car elle est hébergée sur le serveur du client …

    Je vois dans les réglages un protect wp-admin, mais rien de particulier, voir ici.

    Merci pour votre aide.

    #2375256
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    Ci-dessous le httaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    (etc)
    </IfModule>

    # END WordPress

    (etc)

    Le fichier .htaccess est incomplet tel que vous le partagez, puisqu’il fait apparaître END WordPress alors qu’il n’y a pas BEGIN WordPress avant

    #2375264
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Désolé, voici le htaccess en entier:

    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteRule ^xxxxx/?$ /wp-login.php [QSA,L]
    RewriteRule ^xxxxx/register/?$ /wp-login.php?action=register [QSA,L]
    RewriteRule ^xxxxx/lostpassword/?$ /wp-login.php?action=lostpassword [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    # Wordfence WAF
    <IfModule LiteSpeed>
    php_value auto_prepend_file ‘/home/acelfeyc/public_html/wordfence-waf.php’
    </IfModule>
    <IfModule lsapi_module>
    php_value auto_prepend_file ‘/home/acelfeyc/public_html/wordfence-waf.php’
    </IfModule>
    <Files “.user.ini”>
    <IfModule mod_authz_core.c>
    Require all denied
    </IfModule>
    <IfModule !mod_authz_core.c>
    Order deny,allow
    Deny from all
    </IfModule>
    </Files>
    # END Wordfence WAF
    RewriteCond %{HTTP_HOST} ^xxxxx\.be$ [OR]
    RewriteCond %{HTTP_HOST} ^www\.xxxxx\.be$
    RewriteRule ^autodiscover$ “https\:\/\/autodiscover\.xxxxx\.be\:443\/Autodiscover\/Autodiscover\.xml” [R=301,L]

     

    Merci pour votre aide.

    #2375473
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    Pour moi, le fichier .htaccess n’est pas correct, la partie entre # BEGUIN WordPress et # END WordPress n’est pas conforme.
    Je vous conseille de :

    • désactiver Wordfence, videz le cache, déconnectez-vous
    • télécharger ce fichier sur votre ordi par FTP (et par précaution, pour en avoir une copie)
    • puis de supprimer la version en ligne
    • de vous connectez en tant qu’admin’, d’aller dans Réglages > Permaliens, et choisissez votre réglage et ré-enregistrez
    • réactivez Wordfence

    Et vérifiez si tout fonctionne. (et comparer le nouveau fichier .htaccess avec l’ancien)

    #2375557
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    Bonsoir,

    je viens de faire les actions demandée.

    L’url de connexion à l’admin étant celle-ci, j’ai désormais un message d’erreur 404:
    “Not Found
    The requested URL was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    La connexion via l’url me renvoie à la page d’accueil sans possibilité de connexion à l’admin …
    Idem si j’uploade un htaccess d’origine …

     

    #2375566
    Flobogo
    Modérateur
    Maître WordPress
    17381 contributions

    Vous avez vidé le cache de Wordfence ? Et vous l’avez désactivée ensuite ?

    Pourquoi avez-vous une URL de connexion différente de l’URL normale ?

    #2375578
    vins1892
    Participant
    Chevalier WordPress
    161 contributions

    J’ai vidé le cache du site (via WP Super cache), mais pas celui de Wordfence en particulier: je ne vois d’option dans Wordfence pour le faire.

    C’est une refonte de site WordPress et le plugin wp-protect y était installé, avec les paramètres suivants.
    J’ai déjà essayé de le désactiver, mais sans résultat.

    Encore merci pour votre temps.

15 sujets de 1 à 15 (sur un total de 23)
  • Vous devez être connecté pour répondre à ce sujet.