[Résolu] Site introuvable suite à changement nom domaine (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #2419029
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    Bonjour,

    Ma configuration WP actuelle (plus accès à rien pour vérifier tout ça…)

    • Version de PHP/MySQL : ?
    • Thème utilisé : Colibri wp
    • Extensions en place : …
    • Nom de l’hébergeur : O2switch
    • Adresse du site : www. aretera.fr

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai changé le nom de domaine d’un site, anciennement peintur-elle.fr, pour devenir aretera.fr.

    J’ai suivi ce tuto pour ne rien oublier : https://www.journalducm.com/comment-changer-nom-de-domaine-site-wordpress/

    J’ai donc :

    – fais une sauvegarde complète,

    – redirigé le nouveau nom de domaine http://www.aretera.fr chez LWS vers les serveurs DNS de mon hébergeur O2switch,

    – changé l’url du site sur le tableau de bord du site,

    – ajouté dans mon fichier wp_config les lignes :

    define(‘WP_HOME’,‘https://aretera.fr’);

    define(‘WP_SITEURL’,‘https://aretera.fr’);

    – rien fait dans phpmyadmin, puisque les noms dans wp_options étaient déjà modifiés (par les démarches précédentes il me semble ?),

    – rien changé avec l’ancien nom de domaine, qui doit être redirigé vers un autre site (d’ici une dizaine de jours), ou je devrais d’ailleurs faire une redirection temporaire vers le nouveau nom de domaine, mais je me pencherai sur ce problème dès le précédent résolu !!

    J’ai attendu que les nouvelles DNS soient ok…. Et boum, plus rien, «  Site introuvable / Impossible de se connecter au serveur à l’adresse http://www.aretera.fr »

    • Ce sujet a été modifié le il y a 3 mois par Julie - Tadj.
    • Ce sujet a été modifié le il y a 3 mois par Julie - Tadj.
    #2419039
    mathieu42
    Participant
    Maître WordPress
    1754 contributions

    le domaine est actuellement géré par LWS et les serveur DNS sont ceux de o2switch. c’est bien ce qui est prévu ? vous n’allez pas transférer la gestion du domaine chez o2switch ?

    ensuite les serveurs dns d’o2switch ne connaissent pas ce domaine. avez-vous bien configuré l’hébergement o2switch comme indiqué là par exemple ?

    .https://faq.o2switch.fr/hebergement-mutualise/tutoriels-cpanel/domaines-compagnons

    #2419133
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    Merci !!

    Effectivement, j’avais oublié de créer un domaine supplémentaire… pfff

    Mais je n’y arrive toujours pas, je n’ai plus de message d’erreur du tout, juste une page blanche et pour ça, j’ai du accepter une exception de sécurité, car ça me dit « Impossible de vérifier sur le serveur qu’il s’agit bien du domaine aretera.fr, car son certificat de sécurité n’est pas considéré comme fiable par le système d’exploitation de votre ordinateur ». Ceci dit, même en l’acceptant, ça ne fonctionne pas du tout.

    (je ne pourrai pas être sur l’ordi avant samedi soir maintenant)..

    #2419218
    Li-An
    Modérateur
    Maître WordPress
    26959 contributions

    Bonjour, je suis très perplexe vis à vis de ce tuto. Changer le nom de domaine c’est une forme de déménagement et je ne comprends pas que les URL ne soient pas modifiés dans la base de données. Comment les médias – dont les URL sont en dur dans WP – vont-ils être reconnus correctement par exemple ? Un autre tuto qui me parait bien plus cohérent https://wpformation.com/deplacer-wordpress-nom-domaine/  avec le script d’Interconnect https://interconnectit.com/search-and-replace-for-wordpress-databases/ par exemple

    #2419648
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    Merci !!

    J’ai donc repris avec le tuto indiqué, mais le résultat est le même !! (non, ne pas m’arracher les cheveux.. )

    Ah et je n’ai même pas répondu à la question de Mathieu42, oui, c’est fait exprès que le nom de domaine soit chez LWS et l’hébergement chez O2switch.

    donc, j’ai lancé les scripts indiqués sur le tuto de wpformation, j’ai bien eu une paquet de modifications mais pas de changement de fond, la page est toujours bien blanche..

    Vers où est-ce que je peux chercher maintenant ??

     

    #2419654
    Li-An
    Modérateur
    Maître WordPress
    26959 contributions

    Ça ne trouve rien par les navigateurs et donc on peut supposer que le domaine n’est pas correctement redirigé. Il faudrait une capture d’écran des réglages DNS.

    #2419655
    Li-An
    Modérateur
    Maître WordPress
    26959 contributions

    En fait, ça semble être correct si j’en crois https://www.tophebergeur.com/outilswebmaster/whois/#lookup-result

    Chez O2switch, le nom de domaine pointe bien vers un répertoire ? Vous avez posé la question à O2switch ?

    #2419656
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    ça me semble bon, non ?

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2419658
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    J’ai envoyé une demande à O2switch, mais la réponse va devoir attendre demain..

    J’ai souvent des soucis lors des migrations local vers site en ligne, et je n’ai toujours pas trouvé d’où ça provenait. Je penchais plus vers un souci sur avec la base de données mais je ne sais pas quoi faire pour trouver l’erreur..

    Bon, j’attends de voir ce que me dit O2switch, merci de votre aide 😉

    #2419664
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    aah ben non, le support, c’est 24h/24 (encore une bêtise :p)

    Ils ont réglé « quelque chose » et tout est rentré dans l’ordre… mais je ne sais pas quoi du coup !

    #2419691
    Li-An
    Modérateur
    Maître WordPress
    26959 contributions

    Ah oui, c’aurait été intéressant de savoir quoi. Mais c’était peut-être un problème à leur niveau.

    #2419703
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    C’était bien moi la fautive !

    J’ai eu des informations supplémentaires, il s’agissait du fichier wp_config, en comparant les deux fichiers avant / après, 2 lignes ont été supprimées :

    define( 'WP_HOME', 'https://url-de-votre-site.com' );
    define( 'WP_SITEURL', ‘http://url-de-votre-site.com' );

    (rien à voir mais ça existe « aperçu avant d’envoyer » ici ? )

    • Cette réponse a été modifiée le il y a 2 mois et 4 semaines par Julie - Tadj.
    #2419708
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    Bonjour,

    (rien à voir mais ça existe « aperçu avant d’envoyer » ici ? )

    Ce serait une bonne idée ; mais non, ça n’existe pas.

    #2419714
    Julie – Tadj
    Participant
    Padawan WordPress
    53 contributions

    Merci, je me demandais si ma vue me faisait défaut 😉

    #2419778
    Li-An
    Modérateur
    Maître WordPress
    26959 contributions

    Le forum est sous BBPress qui est probablement la solution la moins efficace en terme de forum. Ce n’est pas les modérateurs qui ont choisi…

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.