Site inaccessible suite à un piratage

  • WordPress :4.9.8
  • Statut : non résolu
15 sujets de 16 à 30 (sur un total de 54)
  • Auteur
    Messages
  • #2205270
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    @hikker ,
    Il faut attendre, puisqu’ils vous disaient qu’ils prenaient l’opération à leur charge.

    En attendant, vous pouvez faire les mises à jour des plugins manuellement
    https://blogpascher.com/tutoriel-wordpress/comment-manuellement-mettre-a-jour-vos-plugins-wordpress

    #2205467
    hikker
    Participant
    Initié WordPress
    37 contributions

    Bonjour,

    Enfin ils ont activé la plateforme Revolution sur mon sous domaine.

    Maintenant quelle version PHP choisir  : 7.0 , 7.1 ou 7.2 ?

    Merci.

    #2205468
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    Bonjour @hikker ,
    Ravi pour vous, vous commencez à tester votre site avec PHP 7.0, si tout va bien, vous pouvez par la suite, passer à PHP 7.1, ainsi de suite.
    il faut tester, on ne sait jamais un plugin pourrait ne pas fonctionner sous PHP 7.1 ou PHP 7.2, il faut être prudent.

    #2208894
    hikker
    Participant
    Initié WordPress
    37 contributions

    bonjour,

    Je me permets de ré-ouvrir le ticket car google voit toujours mon site piraté, à travers la search console et après avoir demandé une exploration.
    <div class= »main-content »>
    <div id= »app-body »>
    <div class= »right-col »>
    <div id= »main-content »>
    <div id= »wmxbot-tabs-section »>
    <div id= »wmxbot-tab-contents-container »>
    <div id= »wmxbot-crawl-tab-content » class= »wmxbot-tab-content tabpage-selected »>
    <div id= »wmxbot-crawl-section »>
    <div>
    <div id= »wmxbot-response-container » dir= »ltr »>
    <div class= »CodeMirror cm-s-default »>
    <div class= »CodeMirror-hscrollbar »></div>
    </div>
    </div>
    </div>
    </div>
    </div>
    </div>
    </div>
    </div>
    </div>
    </div>
    </div>
    La réponse de google en pj, avec un bout du code html que google voit (je n’ai pas mis toute la page html).

    Ce que je ne comprends pas c’est que je ne vois pas le même contenu.

    S’agit-il de techniques de cloacking de la part des hackers .

    Merci.

    #2208895
    hikker
    Participant
    Initié WordPress
    37 contributions

    avec la pj c’est mieux.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2208917
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    Bonjour,
    Pourtant, vous avez bien, tout réinstaller au propre, vous n’avez rien écrasé, mais bien supprimer et remplacer.
    Vous avez bien changé de thème, Forestly , datait de 2015, sans mise à jour depuis.
    https://fr.wordpress.org/themes/forestly/

    Les plugins, ont été téléchargé, ceux sur le serveur supprimé, et remplacé par les versions fraîchement téléchargées.

    On est d’accord ?

    #2208941
    hikker
    Participant
    Initié WordPress
    37 contributions

    En effet, je n’ai pas tout fait à savoir:

    • changer de thème
    • les plugins ont été mis à jour mais pas supprimés : faut-il que je les désinstalle et les ré installe ?
    #2208943
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    @hikker
    J’avais mis un lien, dans mon premier message, vers l’article WP Formation, qui explique comment faire après qu’un site soit piraté.
    https://wpformation.com/wordpress-pirate-hack/

    Limite reprendre du coup à 0
    Supprimer tout sur FTP, sauf wp-content/uploads et les fichiers wp-config.php et .htaccess
    Après envoyer WordPress et les plugins fraîchement téléchargés, sans oublier le nouveau thème.

    #2209169
    hikker
    Participant
    Initié WordPress
    37 contributions

    Bonsoir,

    Décidément je cumule les problèmes.

    Après avoir fait ce que vous m’avez conseillé, j’ai maintenant un autre problème (que j’avais avant ) , je ne peux plus mettre à jour mes pages.

    Quand je suis en modification sur une page je ne vois pas le texte (voir pj) , je clique sur le bouton texte mais rine ne se passe la page reste blanche alors qu’en sélectionnant avec la souris je vois le texte apparaître dans les balises html.

    Je rajoute que les boutons permettant de modifier le texte (couleur, police …..) ne sont plus visibles : peut-être un problème javascript ou css  de wordpress 2.9.8 ?

    J’ai essayé de désactiver des plugins mais rien n’y fait. Avec Edge idem même problème.

    L’url m’indique bien (…………..action=edit) que je suis en mise à jour.

    merci pour vos conseils.

    #2209218
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    Bonjour,
    Pas de pièce jointe.
    Cela ressemble à un souci de mémoire allouée

    Il faudrait installer ce plugin pour le savoir
    https://wordpress.org/plugins/database-and-memory-usage-limits/

    Il faudra alors ajouter dans le fichier wp-config.php

    define('WP_MEMORY_LIMIT','256m');

    Avant cette ligne

    /* C'est tout, ne touchez pas à ce qui suit ! Bon blogging ! */

    Mais vous avez changé de thème, vous avez pris quel thème ?
    Vous avez pris dans les plus populaires ? Beaucoup d’installation active ?
    https://fr.wordpress.org/themes/browse/popular/

    Par exemple, comme OceanWP
    https://fr.wordpress.org/themes/oceanwp/

     

    #2209965
    hikker
    Participant
    Initié WordPress
    37 contributions

    Bonjour,

    Après avoir ajouté la ligne dans le wp-config après la ligne define(‘WPLANG’, ‘fr_FR’); j’obtiens le message d’erreur suivant dans le tableau de bord WordPress :

    <b>Fatal error</b>: Uncaught Error: Call to undefined function mysql_query() in /web/fabiennecheneau/www/wp-content/plugins/database-and-memory-usage-limits/database-memory-limit.php:187 Stack trace: #0 /web/fabiennecheneau/www/wp-includes/class-wp-hook.php(286): wpo_db_size(‘<span id= »foote…’) #1 /web/fabiennecheneau/www/wp-includes/plugin.php(203): WP_Hook->apply_filters(‘<span id= »foote…’, Array) #2 /web/fabiennecheneau/www/wp-admin/admin-footer.php(42): apply_filters(‘admin_footer_te…’, ‘<span id= »foote…’) #3 /web/fabiennecheneau/www/wp-admin/tools.php(76): include(‘/web/fabiennech…’) #4 {main} thrown in <b>/web/fabiennecheneau/www/wp-content/plugins/database-and-memory-usage-limits/database-memory-limit.php</b> on line <b>187</b>

     

    Dans Outils disponibles, je ne trouve pas le plugin ajouté (database-and-memory-usage). Ce qui doit expliquer l’erreur.

    Merci.

    Olivier

    #2209967
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    Bonjour,
    Votre fichier wp-config.php date de quand ?
    il n’y a plus cette ligne, maintenant.
    regarder le fichier wp-config-sample.php

    Supprimer ce plugin dans Extensions et installer à  la place celui ci « Server IP & Memory Usage Display »
    https://wordpress.org/plugins/server-ip-memory-usage/

    #2209971
    hikker
    Participant
    Initié WordPress
    37 contributions

    le dernier thème que j’ai installé est Mesmerize dernière version.

    #2209973
    Noaneo
    Participant
    Maître WordPress
    29402 contributions

    Pourquoi me parlez-vous de votre thème ?
    Vous n’avez plus le thème forestly, c’est très bien.

    Il faut supprimer l’extension « Database and Memory Usage Limits » et installer à la place l’extension  » Server IP & Memory Usage Display »

    #2210885
    hikker
    Participant
    Initié WordPress
    37 contributions

    Bonjour,

    En fait je vous dis quel était le thème installé car vous me l’avez demandé.

    Sinon j’ai activé « Server IP & Memory Usage Display » mais je ne vois où consulter les résultats. voir mes pj sur les outils et les réglages.

    Merci

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
15 sujets de 16 à 30 (sur un total de 54)
  • Vous devez être connecté pour répondre à ce sujet.