Site inaccessible ainsi que la page de modif wordpress (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2412936
    melissacabinet
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    je m’excuse à l’avance pour le manque d’information, car je n’ai pas toutes les données en main, c’est concernant le site de mon employeur qui ne fonctionne plus avec ce message d’erreur :  <b>Parse error</b>: syntax error, unexpected T_STRING in <b>/home/allodoc/www/wp-includes/load.php</b> on line <b>1242</b>

    Et lorsque je vais pour régler le problème via la page où l’on peut faire toutes les modifications j’ai ce message d’erreur : <b>Parse error</b>: syntax error, unexpected T_OBJECT_OPERATOR in <b>/home/allodoc/www/wp-login.php</b> on line <b>118</b>

    Je ne sais malheureusement pas donner plus d’informations pour le moment, si je pouvais au moins accéder à la page de modification du site je pourrais peut être essayer les solutions diverses que j’ai vu passer sur le forum.

    Merci d’avance et désoler si ma demande n’est pas complète.

    #2412945
    ferman
    Participant
    Maître WordPress
    5263 contributions

    Bonjour,

    Donnez au moins l’adresse exacte du site (en pièce jointe si vous voulez)  pour que quelqu’un puisse éventuellement vous aider. Avec l’adresse du site il est possible de vérifier quelques petites choses. Et il y a plus d’un « allodoc ».

    #2412947
    melissacabinet
    Participant
    Initié WordPress
    4 contributions

    Bien sur, pardon je vous note ceci de suite :

    https://allo-doc.be

    Merci 🙂

    • Cette réponse a été modifiée le il y a 1 semaine et 2 jours par melissacabinet.
    #2412949
    ferman
    Participant
    Maître WordPress
    5263 contributions

    Chez OVH votre version PHP est 4.4.9 datant de 2008. C’est beaucoup trop vieux. Pour que wordpress fonctionne  il vous faut au moins  7.X et pour qu’il fonctionne correctement en principe 7.4.

    Normalement, la version de PHP se change facilement chez OVH mais là ce sera difficile car vous devez avoir un hébergement particulier (« legacy ») c’est à vérifier auprès d’OVH. En plus vous devez avoir un tas de choses (extensions, wordpress) obsoletes. Si c’est le cas il y a beaucoup de travail en perspective.

    Etes vous  sûr que votre site est bâti avec wordpress; je n’arrive pas à le déterminer? Voir pj.

    • Cette réponse a été modifiée le il y a 1 semaine et 2 jours par ferman.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2412957
    melissacabinet
    Participant
    Initié WordPress
    4 contributions

    Merci pour votre réponse, est-ce que vous pensez que c’est quelque chose que je pourrais réparer moi-même en me renseignant un peu? Ou bien je devrais faire appel à quelqu’un de compétent dans ce système?

    Merci en tout cas pour vos détails (même si je n’ai pas tout compris j’en prends bonne note)

    #2412965
    mathieu42
    Participant
    Maître WordPress
    1344 contributions

    comme le disait ferman, la 1re chose à tester est d’augmenter la version de php.

    cela fera fonctionner le cœur de wordpress s’il est à jour. mais ensuite il peut y avoir des extensions qui ne sont pas compatibles et dans ce cas vous aurez des autres messages d’erreur et des morceaux du site qui seront manquants.

    #2412966
    ferman
    Participant
    Maître WordPress
    5263 contributions

    C’est quelque chose que vous pourriez réparer avec du temps et une aide conséquente du forum WPFR et sans doute en plus du forum OVH pour ce qui concerne le côté hébergeur (changement de version PHP entre autres) mais ce ne sera pas simple.

    PHP est le langage principal de wordpress et il évolue sans arrêt, en particulier sa syntaxe. Ce qui était correct il y a 14 ans ne l’est plus forcément aujourd’hui et cela conduit à des erreurs comme celle que vous voyez. Regardez ICI pour voir à quelle vitesse PHP évolue.  Dans votre cas, il faudrait passer à une version intermédiaire (7.0) ce qui pourrait redonner l’accès au site et à partir de là, il faudrait voir les mises à jour à faire: wordpress, thème, extensions (il y en a sûrement), puis ensuite passer à la version actuelle de PHP (7.4). Ce n’est pas simple et c’est long. Si vous pouvez vous le permettre, il serait mieux de passer par quelqu’un qui s’y connaît, qui aura accès à votre hébergement et à l’administration de votre site et qui fera ce travail beaucoup  plus facilement.

    Mais de toute façon, il faudrait d’abord savoir si votre site est bien « propulsé » par WordPress. Ça ne me semble pas être le cas et donc ce forum ne pourra pas vous aider.

    #2412970
    melissacabinet
    Participant
    Initié WordPress
    4 contributions

    Très bien, je vous remercie pour le complément d’informations 🙂

    #2413010
    Flobogo
    Modérateur
    Maître WordPress
    18521 contributions

    @ferman :

    de toute façon, il faudrait d’abord savoir si votre site est bien « propulsé » par WordPress. Ça ne me semble pas être le cas

    Le site est bien construit sous WordPress, au vu du message mentionnant wp-includes :

    Parse error: syntax error, unexpected T_STRING in /home/allodoc/www/wp-includes/load.php on line 1242


    @melissa
    :

    Suivez donc les infos de Ferman, puisque votre site est bien sous WordPress. Par contre, essayez de passer d’abord en PHP 5.6 chez votre hébergeur, si votre site est très ancien et n’a pas été mis à jour depuis hyper longtemps.
    Quand vous serez en PHP 5.6, vérifiez si vous pouvez accéder au site, soit côté admin, soit côté public.

    Vous disiez :

    je n’ai pas toutes les données en main, c’est concernant le site de mon employeur

    Il va falloir accéder à la gestion de l’hébergement chez OVH, ainsi que savoir accéder à la base de données (PhpMyAdmin) et aussi utiliser le logiciel Filezilla (ou équivalent) pour gérer les fichiers. Cela va vous demander (un peu / beaucoup) de travail, à vous ou à votre employeur.

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.