[Résolu] Site « Deprecated ». J’ai besoin de votre aide svp

  • WordPress :4.9.9
  • Statut : résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #2231745
    Octa
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.6
    • Thème utilisé : MH Theme
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.rosa-lux.fr

    Problème(s) rencontré(s) :

    J’ai souhaité faire la mise à jour de mon site à la dernière version de WordPress (5.0) et voilà le résultat (+ capture d’écran) :

    <b>Warning</b>: mysqli_real_connect(): (HY000/1040): Too many connections in <b>/home/rosalux/www/wp-includes/wp-db.php</b> on line <b>1531</b>

    <b>Deprecated</b>: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in <b>/home/rosalux/www/wp-includes/wp-db.php</b> on line <b>1562</b>

    <b>Warning</b>: mysql_connect(): Too many connections in <b>/home/rosalux/www/wp-includes/wp-db.php</b> on line <b>1562</b>

    Jusque-là, j’ai toujours réussi à m’en sortir (des erreurs de WP), mais là… je suis perdu et je ne sais absolument pas quoi faire. Je ne peux pas me permettre de perdre mon site.

    Je n’y connais rien en code mais si on m’explique pas à pas comment faire, j’y arriverai.

    Je compte énormément sur votre aide et vous remercie d’avance.

    P.S : n’oubliez pas svp, je ne suis pas codeur et n’y entend rien en PHP. Soyez indulgent

     

    #2231763
    PhiLyon
    Modérateur
    Maître WordPress
    21190 contributions

    Bonjour.

    Passes ton PHP en 7.2 chez OVH et dis-nous.

    🙂

    #2231774
    Octa
    Participant
    Initié WordPress
    12 contributions

    Merci pour ta réponse, c’est fait, voici le message d’erreur :

    <b>Warning</b>: mysqli_real_connect(): (HY000/1040): Too many connections in <b>/home/rosalux/www/wp-includes/wp-db.php</b> on line <b>1531</b>

    #2231775
    Octa
    Participant
    Initié WordPress
    12 contributions

    et voici la ligne 1531 :

    if ( WP_DEBUG ) {
    mysqli_real_connect( $this->dbh, $host, $this->dbuser, $this->dbpassword, null, $port, $socket, $client_flags );
    } else {

    #2231780
    PhiLyon
    Modérateur
    Maître WordPress
    21190 contributions

    Ton thème et tes extensions sont à jour ?

    🙂

    #2231782
    Octa
    Participant
    Initié WordPress
    12 contributions

    Trois extentions devaient être mise à jour aujourd’hui. J’ai préféré mettre le thème à jour avant.

    Ce n’était peut-être pas une bonne idée ?

    #2231784
    Octa
    Participant
    Initié WordPress
    12 contributions

    J’ai reçu les mises à jour aujourd’hui

    #2231786
    PhiLyon
    Modérateur
    Maître WordPress
    21190 contributions

    Tu mets tout à jour, peu importes l’ordre.

    🙂

    #2231787
    Octa
    Participant
    Initié WordPress
    12 contributions

    ça n’est plus possible malheureusement

    #2231791
    Octa
    Participant
    Initié WordPress
    12 contributions

    Ma sauvegarde est en PHP 5.6.

    Évidemment, si je compare les deux fichiers wp-db.php (5.6 et 7.2), ça n’a plus rien à voir désormais.

    S’agit-il d’un pb de connexion à la base de données ?

     

    #2231798
    PhiLyon
    Modérateur
    Maître WordPress
    21190 contributions

    Tu en es où exactement là, tu as fait une restauration chez OVH, tu parles de sauvegarde ?

    🙂

    #2231799
    Octa
    Participant
    Initié WordPress
    12 contributions

    Impossible de me connecter à phpMyAdmin :

    mysqli_real_connect(): (08004/1040): Too many connections

    D’après un site anglophone, il s’agirait soit d’un trafic trop élevé (peu probable), soit d’une connexion entretenue par un script.

    il est conseillé de fermé la connexion à la base de données.

    Sais-tu comment faire ?

    Merci de ta réponse

    • Cette réponse a été modifiée le il y a 1 week et 4 days par  Octa.
    #2231815
    PhiLyon
    Modérateur
    Maître WordPress
    21190 contributions

    Là il faut voir avec OVH.

    🙂

    #2232020
    Noaneo
    Participant
    Maître WordPress
    29498 contributions

    Bonjour,

    Attention il y a des travaux chez OVH
    http://travaux.ovh.net/?do=details&id=35689&PHPSESSID=12e864362ae3f043d36cb0a9a429e5c2

    J’ai souvent lu, qu’il fallait mettre à jour les extensions, les thèmes en premier, puis WordPress.
    Ainsi les extensions, les thèmes sont bien compatible ou conforme avec la dernière version de WordPress, c’est plus sûr.

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.