[Résolu] Site cassé ! Help me please !! (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
  • Ce sujet contient 16 réponses, 2 participants et a été mis à jour pour la dernière fois par sam.pasche, le il y a 1 mois.
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #2415333
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :  7.4.30
    • Thème utilisé : Neve (version 3.3.6)
    • Extensions en place : Elementor Pro (version 3.4.1)
    • Nom de l’hébergeur : Infomaniak
    • Adresse du site : http://www.lesessentiels.ch

    Problème(s) rencontré(s) :

    HEEEEELLLLPPP !!!, Mon site est cassé, je ne peux même plus accéder à mon tableau de bord et j’y connais rien ! J’ai essayé de restaurer une ancienne version depuis mon hébergeur mais rien n’y fait !

    #2415339
    ferman
    Participant
    Maître WordPress
    5363 contributions

    Bonjour,

    Vous avez quand même réussi à afficher une page « coming-soon ». Comment avez-vous fait sans avoir accès à l’admin?

    Apparemment, le 17 août, le site était encore visible. Que s’est-il passé entre-temps?  Vous avez fait des mises à jour? Regardez les logs du serveur chez infomaniak à la date du 17 août . Si vous ne savez pas comment faire, demandez à l’hébergeur.

    La sauvegarde que vous avez restaurée datait bien d’avant le 17 août et vous avez bien restauré aussi la base de données?

    #2415341
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Merci pour la réponse. J’ai restauré une ancienne sauvegarde du site et depuis j’ai le « coming-soon », mais je ne sais pas pourquoi.

    Le site ne fonctionne plus depuis une dizaine de jours. Mais c’est le 17 que l’on a fait cette sauvegarde.

    Je viens de faire une restauration du site au 17 août mais cela n’a rien changé.

    Non, je ne sais pas restaurer la base de donnée.

    Je vous mets en annexe le mail reçu par WP qui peut peut-être vous aider !

    MERCI !!

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2415347
    ferman
    Participant
    Maître WordPress
    5363 contributions

    C’est une erreur qui provient du module « theme-builder » de Elementor. Vous utilisez la version Pro de Elementor et vous devez donc les contacter  ICI.

    #2415348
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Un grand MERCI, je vais essayer de les contacter.

    Je vous tiendrais au courant.

    Encore merci pour l’aide et excellent week-end.

    #2415727
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    J’ai reçu la réponse d’Elementor qui me renvoie vers… WP !

    Je ne sais vraiment plus comment faire !

     

     

    #2415737
    ferman
    Participant
    Maître WordPress
    5363 contributions

    Je ne sais vraiment plus comment faire !

    Vous pouvez déjà donner la réponse exacte de Elementor. Ça pourra peut-être nous aider.

    #2415749
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Voici la réponse d’Elementor :

    You need contact WordPress support for that issue, they will turn back your access.

     

     

    #2415750
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Une erreur de type E_ERROR a été causée dans la ligne 48 du fichier /home/clients/eb666a1d2b5fb65ab17bae85fa58cdf4/lesessentiels.ch/httpdocs/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php. Message d’erreur : Uncaught ReflectionException: Method get_site_editor_type does not exist in /home/clients/eb666a1d2b5fb65ab17bae85fa58cdf4/lesessentiels.ch/httpdocs/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php:48
    Stack trace:
    #0 /home/clients/eb666a1d2b5fb65ab17bae85fa58cdf4/lesessentiels.ch/httpdocs/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php(48): ReflectionClass->getMethod(‘get_site_editor…’)
    #1 /home/clients/eb666a1d2b5fb65ab17bae85fa58cdf4/lesessentiels.ch/httpdocs/wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php(129): ElementorPro\Modules\ThemeBuilder\Documents\Theme_Document::get_site_editor_type_bc()
    #2 /home/clients/eb666a1d2b5fb65ab17bae85fa58cdf4/lesessentiels.ch/httpdocs/wp-content/plugins/elementor/core/common/modules/finder/categories/create.php(94): ElementorPro\Modules\ThemeBuilder\Documents\Theme_Document::get_create_url()
    #3 /home/clients/eb666a1d2b5fb65ab17bae85fa58cdf4/lesessentiels.ch/httpdo

    #2415757
    ferman
    Participant
    Maître WordPress
    5363 contributions

    Bonjour,

    Essayez ce qui est décrit ICI ( commenter une ligne d’un fichier comme indiqué au paragraphe 6). Voir ICI pour la même solution. Si ça règle le problème, revenez nous le dire ici.

    Il ne s’agit que d’une réparation temporaire. la vraie solution devrait venir de la prochaine mise à jour de Elementor.

    Essayez d’abord de réinstaller Elementor Pro. On ne sait jamais.

    C’est clairement un problème avec Elementor, pas WordPress. La réponse que Elementor vous a faite n’est pas satisfaisante (surtout pour un produit pro, payant).

    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    #2415769
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Merci !

    Le problème est que je ne connais rien en code (je sais, je suis mauvais) et que j’ai aucune idée ou rentrer ceci.

    Alors ok j’abuse un peu mais vous pouvez m’aider ?

    #2415770
    ferman
    Participant
    Maître WordPress
    5363 contributions

    Par FTP, Il faut aller visiter les fichiers de votre site. Là vous chercherez  le fichier wp-content/plugins/elementor-pro/modules/theme-builder/documents/theme-document.php:48 et modifierez la ligne concernée (48) comme indiqué dans le post précédent. Vous pouvez faire ça à partir de votre tableau de bord chez l’hébergeur. Si ce n’est pas clair, il faut demander de l’aide à votre hébergeur. Il me semble que infomaniak le fait sans problème.

    ps. le code , dans ce cas , se limite à mettre « // » au début d’une ligne 🙂

    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    #2415783
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    Merci !

     

    Bien entendu, comme rien n’est simple dans mon cas, le tableau de bord infomaniak me marque « aucun compte FTP / SSH pour le moment ».

    Je leur ai demandé leur aide à tout hasard 🙂

     

     

    #2415784
    ferman
    Participant
    Maître WordPress
    5363 contributions

    aucun compte FTP / SSH pour le moment

    Là ils doivent vous répondre (pas à tout hasard). Sur ce forum, à moins de tomber sur un intervenant hébergé chez Infomaniak qui voudra bien répondre, il sera difficile de vous aider. Vous devez impérativement disposer d’un accès FTP car on en a très souvent besoin pour résoudre des problèmes, même simples,  liés à wordpress (en fait le plus souvent à des extensions ou thèmes).

    Par exemple, dans votre cas,  il suffit peut être de mettre à jour Elementor pro mais si vous n’avez pas accès à votre administration il faut avoir un accès FTP. Tenez-nous au courant quand vous aurez résolu cette question de compte FTP.

    En principe lorsque l’on prend un hébergement , l’hébergeur vous fournit automatiquement des identifiants et mots de passe pour accéder à votre base de données d’une part et aux dossiers du site d’autre part (le FTP). A ma connaissance, tous les hébergeurs  le font.

    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    • Cette réponse a été modifiée le il y a 1 mois par ferman.
    #2415793
    sam.pasche
    Participant
    Initié WordPress
    12 contributions

    MERCI !!

    C’est bon, j’ai pu atteindre infomaniak et régler le problème de la ligne 48 !

    Je peux accéder à mon tableau de bord wp et j’ai lancé la mise à jour Elementor.

    Y-a t’il d’autre chose que je doive faire ?

    En tout cas, encore un immense MERCI !

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.