site avec erreur depuis PHP version 7.0 (Créer un compte)

  • WordPress :4.2.1
  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #1604333
    tp26
    Participant
    Initié WordPress
    46 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0
    • Thème utilisé :  Nosign<span class= »theme-version »>Version : 1.0.0 </span>Par nosign based on Zhen Huang / nosign based on Reverie
    • Extensions en place :
    • Nom de l’hébergeur : 1&1
    • Adresse du site : http://www.vision-laser.fr

    Problème(s) rencontré(s) :

    Bonjour a tous,

    je poste ce message pour avoir de l’aide sur le site http://www.vision-laser.fr hebergé chez 1&1. La semaine dernière ils nous contactent pour nous expliquer que la version de PHP utilisée sur le site n’etant plus valide, et font le transfert vers la version 7.0.

    Le probleme depuis est que le message d’erreur suivant s’affiche en haut de chaque page:

    <b>Warning</b>: Declaration of description_walker::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in <b>/homepages/36/d461137857/htdocs/wp-content/themes/nosign/functions.php</b> on line <b>144</b>

    Le theme utilisé (il y a env 5 ans): Nosign<span class= »theme-version »>Version : 1.0.0 </span>Par nosign based on Zhen Huang / nosign based on Reverie

    Le site reste en ligne, mais cette ligne d’erreur apparait en haut de chaque page.

    De plus, il est maintenant impossible de telecharger de nouveaux themes ou meme d’ajouter des widgets…

    Quelqu’un saurait-il comment procéder pour arrabger ce probleme?

    merci de votre aide

    #1604352
    WP Traduction
    Modérateur
    Maître WordPress
    2043 contributions

    Bonjour,

    Si je comprends bien, votre thème a au moins 5 ans et il n’a jamais été mis à jour ?

    Si c’est bien le cas, alors changez de thème car il ne sera certainement pas compatible avec cette version de Php.

    #1604444
    tp26
    Participant
    Initié WordPress
    46 contributions

    Bonsoir et merci de votre réponse.

    Je changerai de theme s’il  n’existe pas d’autres alternatives, mais je me demandais s’il n’etait pas possible de le garder et de le « corriger » afin de le rendre compatible php 7.0 ?

    merci

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.