Sidebar qui disparait avec Simpla 101

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #449175
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.04 fr
    – Thème utilisé : Simpla 101
    – Plugins en place : plusieurs
    – Nom de l’hebergeur : Free

    Problème(s) rencontré(s) :

    Ayant repéré quelques phrases texte “en dur” dans le modèle, j’ai voulu les franciser. J’ai introduit un texte en français dans le “mod-le principal” et Le panneau latéral a disparu.

    J’avais trouvé une solution : on recharge Simpla 101, on en transfère une nouvelle version dans le répertoire ad hoc quitte à customiser à nouveau ce qui était déjà customisé.

    Et bien : rien de neuf. Tout se passe comme si on n’avait pas rechargé le nouveau thème. Je suis très perplexe ???:rolleyes: :(:(

    #583516
    artxtra
    Participant
    Chevalier WordPress
    149 contributions

    Tout dépend ce que tu as francisé : il faut rester sur les éléments ou les valeurs d’attributs des balises HTML et pas plus : ni tag, ni fonction, ni attribut.
    Exemple :

    <a href="URL/de/mon/fichier" title="valeur_de_l'attribut">élément_de_la_balise</a>
     // fonction, à ne pas traduire
    <?php echo ('<a href="'..'” title=”‘..'”>je_traduis</a>‘); ?>

    Dernier exemple pas très limpide sans coloration syntaxique.
    Il faut bien identifier ce qui est à l’intérieur du HTML, quand ce dernier est inclus à l’intérieur du PHP. C’est pas évident au début : repère les guillements doubles et simples (apostrophes). Renseignes-toi sur la fonction echo() et les bases de PHP pour avancer.

    #583517
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    J’avais voulu franciser ceci : Read the rest of this entry qui commençait par des guillemets simples continuait par une virgule suivi un mot-clef de programmation et d’un guillemet.

    Je n’ai pas bouffé la virgule.

    Le plus bizarre est que si je regarde (regardais, parce que ce matin, Free est en panne) l’éditeur de thème, la sidebar est bien là avc tous les trucs que j’ai mis et qui fonctionnent.

    Ce qui me trouble le plus c’est que la tentative de dépannage n’a pas résolu la question
    A+

    #583518
    artxtra
    Participant
    Chevalier WordPress
    149 contributions

    mets l’intégralité de la phrase dans le post stp

    #583519
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    Pour le moment, je ne peux pas : Free est en panne !
    Merci, je le ferai dès que cela refonctionnera 😇

    #583520
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    Hello,

    J’ai recopié ci dessous tout ce qu’on trouve dans le thème principal de simpla 101. La partie que j’avais voulu franciser se trouve ci-dessous en gras ; comme cela ne fonctionnait pas, j’ai remis le passage en anglais. Mais ça va pas mieux. Pour le “get sidebar()”, là je sais qu’il ne faut pas franciser (j’ai fait un peu de javascript, il y a quelques années)

    <?php if (have_posts()) :?>

    <div class="entry entry-“>

    <a href="” rel=”bookmark” title=”Permanent Link to “>

    <?php the_content(‘Read the rest of this entry »’); ?>

    Not Found

    Sorry, but you are looking for something that isn’t here.

    <?php

    Je me demande ce qui ne va pas ???

    #583521
    dreamer
    Participant
    Chevalier WordPress
    484 contributions

    Salut

    A +

    #583522
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    Merci cher Dreamer…. Pour l’anglais, c’est pas un problème. Le problème est :
    Pourquoi ayant mis du français à cet endroit, la sidebar a-t-elle disparu ? Et pourquoi ayant remis de l’anglais, elle n’est pas revenue ?

    A+

    #583523
    Qwindoo
    Modérateur
    Maître WordPress
    2866 contributions

    Es-tu certain de n’avoir modifié que cela ? 😋

    Les languages de programmation sont tellement logiques qu’il est presqu’impossible qu’un bug ne puisse pas se corriger en remettant le code original 🙂

    Pharisien Libéré wrote:
    Pour le “get sidebar()”, là je sais qu’il ne faut pas franciser (j’ai fait un peu de javascript, il y a quelques années)

    Attention à ne pas franciser ça, malheureux :D :D

    Tout ce qui est entre est … du PHP (pas du JavaScript) et ne fonctionne que si les instructions sont en Anglais 😉

    #583524
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions
    MS-DOS_1991 wrote:
    E
    Attention à ne pas franciser ça, malheureux :D :D

    Tout ce qui est entre est … du PHP (pas du JavaScript) et ne fonctionne que si les instructions sont en Anglais 😉

    C’est ce que je disais. Ayant fait un peu de javascript, il y a quelques années, j’ai quelques idées sur ce qu’il ne faut pas franciser.

    1- Le problème ne me semble pas là. J’ai sûrement retiré un truc microscopique (guillemet ? virgule ? point virgule ?) qui est fonctionnel et que je ne retrouve plus.
    2- Pourquoi le problème ne se résoud-il pas quand on transfère à nouveau le thème dans le wp-content/theme ?
    Merci

    #583525
    dreamer
    Participant
    Chevalier WordPress
    484 contributions

    Le cache ?????????

    A +

    #583526
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    J’ai nettoyé le cache. Cela ne va pas mieux.
    J’ai aussi remis le thème dans le répertoire ad hoc et rien n’a changé.

    Merci pour votre aide:boulet:

    #583527
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    Décidement, cela ne vous inspire pas, cette histoire de Sidebar qui disparait avac un navigateur respectant les standards ?

    Figurez vous que la sidebar du theme Zimpla disparait aussi quand on consulte avec MS-IE. Des idées ?

    #583528
    Pharisien Libere
    Membre
    Padawan WordPress
    79 contributions

    Trouvé ceci dans la rubrique “thèmes abîmés”
    mag-10 La feuille de style manque.
    Simpla Le mod�le manque.

    Où puis-je trouver le modèle de simpla ? Où puis-je trouver la feuille de style de mag-10 ?
    10000 mercis

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.