set_time_limit() has been disabled for security reasons in (Créer un compte)

  • WordPress :5.2
  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2289151
    Jean-Philippe53
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    Ma configuration WP actuelle

    • – Version de WordPress : 5.3.1
    • – Version de PHP/MySQL : 7.3.12 / 5.6.41
    • – Thème utilisé : MH FeminineMag
    • – Thème URI : https://www.mhthemes.com/themes/mh/femininemag/
    • – Extensions en place : All-in-One WP Migration (7.12), All-in-One WP Migration Unlimited Extension (2.33), All In One SEO Pack (3.3.3), Black Studio TinyMCE Widget (2.6.9), Broken Link Checker (1.11.9), Contact Form 7 (5.1.6), Cookie Notice (1.2.48), Count Per Day (3.6.1), Duplicate Post (3.2.4), Email Subscribers & Newsletters (4.3.6), Enhanced Media Library (2.7.2), Forum_wordpress_fr (4.2), Instant Images (4.1.0), Loco Translate (2.3.1), Slimstat Analytics (4.8.8.1), Smush (3.3.2), TinyMCE Advanced (5.3.0), WordPress Importer (0.6.4), WP Maintenance Mode (2.2.4), WP Statistics (12.6.12), WP Super Cache (1.7.0)
    • – Adresse du site : https://lptv.fr

    Problème(s) rencontré(s) :

    Bonjour,

    Je suis passé à la 3.5.1 ce matin.

    Depuis j’ai le message suivant après les mises à jour des extensions :

    « Warning: set_time_limit() has been disabled for security reasons in /home/clients/—-/web/lptv/wp-admin/includes/class-wp-upgrader.php on line 468 »

    Mais les mises à jour se font normalement. Est-ce que c’est le signal d’un problème important et y a-t-il un moyen du supprimer ce message ?

    Merci si vous pouvez m’aider.

    • Ce sujet a été modifié le il y a 4 années et 5 mois par mathieu42.
    • Ce sujet a été modifié le il y a 4 années et 5 mois par Jean-Philippe53.
    #2289152
    mathieu42
    Participant
    Maître WordPress
    2012 contributions

    ce blocage vient souvent de l’hébergeur qui a bloqué cette fonction.

    cela peut être embêtant pour le téléchargement de gros fichiers qui ne pourra pas aller jusqu’au bout.

    #2289155
    Jean-Philippe53
    Participant
    Initié WordPress
    29 contributions

    C’est curieux. Quand je lis le message, je comprends que c’est dans le « class-wp-upgrader.php » à la ligne 468 que le set_limit a été désactivé. En plus, si on a desactivé la limite de temps, il ne devrait pas y avoir de problème. Je suis le seul à avoir le problème ?

    Edit : je viens de regarder chez mon hébergeur et, la fonction « set time linit » était bien désactivée. Jed l’ai activée mais je ne comprends toujours pas l’idée. Parce qu’en l’activant, pour le coup je bloque l’exécution des scripts. Et quand je regarde le fichier « class-wp-upgrader.php » à la ligne 468, je vois « set_time_limit( 300 ); »

    Donc j’ai une limite dans wordpress. Je n’en avais pas chez mon hébergeur. Ca ne devrait pas générer un message d’erreur, il me semble.

     

    • Cette réponse a été modifiée le il y a 4 années et 5 mois par Jean-Philippe53.
3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.