Santé du site – erreur critique : serveur trop lent (Créer un compte)

  • WordPress :6.1
  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #2431703
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : popularis
    • Extensions en place :
    • Nom de l’hébergeur : hostinger
    • Adresse du site : https://tom-spirit.com/

    Problème(s) rencontré(s) : Santé du site, problème critique

    Bonjour à tous!

    Ne trouvant aucune réponse sur internet avec mon problème, j’essaye ici, et j’espère que ça servira à d’autres!
    J’ai une erreur critique dans la santé de mon site : Voici ce qui est affiché :

    1 problème critique

    L’utilisation de la mise en cache des pages améliore la vitesse et les performances de votre site en servant des pages statiques au lieu de générer entièrement chaque page à chaque visite d’un internaute.

    Le cache de page est détecté en recherchant une éventuelle extension de cache active sur le site, et aussi en effectuant trois requêtes sur la page d’accueil et en recherchant un ou plusieurs en-têtes de réponse de mise en cache du client HTTP parmi les en-têtes suivants :

    cache-control, expires, age, last-modified, etag, x-cache-enabled, x-cache-disabled, x-srcache-store-status, x-srcache-fetch-status.

    •  Le temps de réponse médian du serveur était de 808 millisecondes. Il devrait être inférieur au seuil recommandé de 600 millisecondes.
    •  Aucun en-tête de réponse de cache client n’a été détecté.
    •  Une extension de mise en cache des pages a été détectée.

    Est-ce que quelqu’un aurait une idée de ce qu’est le cœur de mon problème et comment le résoudre? Je n’arrive pas à comprendre, même en changeant d’extension et en purgeant les caches.

    Merci à vous.
    Tom

    • Ce sujet a été modifié le il y a 2 semaines et 4 jours par tom-spirit.
    • Ce sujet a été modifié le il y a 2 semaines et 4 jours par tom-spirit.
    #2431742
    LucieR
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Il faut que vous installiez un plugin de mise en cache et que la mise en cache soit activée.

    Par ex sur wp optimize, il ne suffit pas d’installer l’outil, mais il faudra aller dans cache et activer le cache de la page.

     

    Normalement, le « problème » ne devrait plus apparaitre.

    J’espère avoir répondu à la question 😉

    Belle journée

    #2431792
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Bonjour, merci pour votre réponse. En effet ça fait sens, mais ça fait plus d’un an que j’ai ce plugin (LS cache), qui est bel et bien actif et configuré depuis tout ce temps. Mon problème vient de survenir pour je ne sais quelle raison.

    • Cette réponse a été modifiée le il y a 2 semaines et 4 jours par tom-spirit.
    #2431853
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Information complémentaires…

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2431930
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    Bonjour,

    Même si vous n’avez pas touché (vous-même) à l’extension de cache LS Cache, il peut y avoir eu des changements récents sur votre site : modification de la version de PHP ? Modification de la version WP (mise à jour automatique en 6.1.1 ?) ? Mise à jour (automatique ou non) de l’extension LS Cache ? ou autre ?

    #2432082
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Non, rien n’a été changé. Néanmoins j’ai changé d’extension et installé WP SUPER CACHE et j’ai trouvé qu’il y avait un problème de mise en cache du à des horodateurs qui ne correspondent pas et j’arrive pas à comprend leurs instructions… Je ne comprend pas où et comment modifier le code source HTML, le sauriez-vous?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2432088
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    On ne vous demande pas de modifier le code HTML, mais de visualiser le code-source de votre page (clic-droit → code source de la page), et de vérifier le temps de chargement tout en bas.

    #2432093
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Oui effectivement c’est ce que j’ai fait, je vois une heure affichée mais je ne comprend pas ce que je dois faire avec cela

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2432095
    tom-spirit
    Participant
    Initié WordPress
    9 contributions
    1. Chargez votre page d’accueil dans un navigateur en mode privée et vérifiez l’horodatage à la fin du code source HTML. Puis rafraîchissez la page et comparez l’horodatage. La mise en cache fonctionne si les horodatages sont identiques.

      —> Je l’ai fait, j’ai vérifié l’heure, elle est mauvaise

    2. Autorisez la journalisation dans la page de débogage. Cela devrait vous aider à identifier le problème

      —> J’ai activé, rien ne se passe

    #2432302
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Quelqu’un ici est prestataire? Je recherche toujours de l’aide

    #2432488
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    Quelqu’un ici est prestataire?

    Non, ici nous sommes bénévoles … mais les conseils sont gratuits.

    Autorisez la journalisation dans la page de débogage. (…)
    —> J’ai activé, rien ne se passe

    Il faut aussi activer l’affichage des informations, ou aller les chercher dans les fichiers de logs

    → utilisez wp_debug_log ou wp_debug_display selon ces instructions.

    #2433065
    FloraSupertramp
    Participant
    Padawan WordPress
    94 contributions

    Bonjour,

    J’ai le même problème et j’ai pour ma part, fais la dernière mise à jour WordPress (6.1.1), pensez-vous que cela soit dû à ça ? Si oui, qu’est-ce que je dois faire pour régler ce problème.. ?

    Merci beaucoup.

    #2433070
    Flobogo
    Modérateur
    Maître WordPress
    18914 contributions

    Bonjour @florasupertramp

    Ce problème est trop spécifique pour qu’on vous réponde sans avoir un minimum d’informations. Merci d’ouvrir votre propre sujet, en complétant le questionnaire de configuration, et en donnant les infos sur la situation de votre site (message d’erreur, problèmes observés, dernières manip’ effectuées)

    #2433561
    tom-spirit
    Participant
    Initié WordPress
    9 contributions

    Salut Flora, tu as résolu le problème?

    J’ai trouvé plusieurs solutions pour le régler. Pour ma part, c’était dû à un conflit avec un plugin qui empêchait la synchronisation des horodateurs. C’est parti une fois que je l’ai désactivé mais puisqu’il était essentiel, j’ai changé d’extension de cache tout simplement.

    Une autre chose qui causer le problème peut venir de la minification si tu utilises Cloudflare. Si c’est le cas, vas sur ton tableau de bord Cloudflare > Speed > Optimization > Auto Minify et décoche CSS et HTML mais garde bien ces mêmes options activées sur Litespeed.

    Dis moi si ça t’as aidé

    • Cette réponse a été modifiée le il y a 1 semaine par tom-spirit.
14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.