RSS enrichit (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 19)
  • Auteur
    Messages
  • #450660
    fredooo13
    Participant
    Padawan WordPress
    62 contributions

    Bonjour,

    Netvibes viens d’être mis à jour semble-t’il, et certains sites, dont “le monde” ont un rss enrichit, c’est à dire que dans l’agrégateur on a non seulement le titre, mais aussi le debut du billet et une image.

    Les flux générés par WordPress ne semble pas avoir tant d’informations … existe t’il quelque chose pour avoir un joli flux comme “le monde” ?

    Merci d’avance

    #592652
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Par défaut, WordPress fourni un titre, un extrait de l’article. (ca peut se configurer dans les options, le nb de billet, etc, extrait, ou article complet…)

    Ajouter une image, facilement non.

    #592653
    fredooo13
    Participant
    Padawan WordPress
    62 contributions

    justement, dans mes options j’ai mis “article complet” et il n’y a que les titres dans netvibes… d’où ma question, car je ne suis pas développeur (malheureusement)

    #592654
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Pourtant en mettant ‘article complet’, moi j’obtiens bien le texte complet, le titre et les images…

    #592655
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Tu utilise kel version de WP ?

    #592656
    fredooo13
    Participant
    Padawan WordPress
    62 contributions

    J’utilise WPMU .. effectivement, si l’on clique sur le titre de l’article, le reader s’ouvre et j’ai l’article complet, ce n’etait pas de ça que je parlais …. je vais faire des screen se sera plus simple 😉

    #592657
    fredooo13
    Participant
    Padawan WordPress
    62 contributions

    voila le flux du monde :
    image-3.png

    et voila celui d’un site WordPress :
    image-2.png

    dans le flux WP il n’y a que le titre ( avant clic) et celui du monde il y a plus d’infos semble t’il …;

    #592658
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Ah… s’il s’agit de WordPress Mu, c’est peut-être différent de la version de WordPress alors…

    #592659
    fantome
    Participant
    Chevalier WordPress
    234 contributions

    Je relance ce sujet. Je suis avec la version 2.0.7 de WordPress et mes images n’apparaissent pas dans le flux RSS2, pourtant j’ai l’option “texte complet” activée.

    #592660
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Sur WP 2.1.1

    Ajuster le fichier wp-rss2.php pour qu’il ressemble à ca :

    
    		<![CDATA[]]>
    
    		<![CDATA[]]>
    	post_content ) > 0 ) : ?>
    		<![CDATA[]]>
    	
    		<![CDATA[]]>
    	

    Et hop on affiche également les photos.

    #592661
    fantome
    Participant
    Chevalier WordPress
    234 contributions

    Merci Amo, je vais donc devoir attendre et me décider à migrer vers le 2.1.1.🙂

    #592662
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Je pense pas que la modification que j’ai proposé soit différente sur WP 2.0.x

    #592663
    fantome
    Participant
    Chevalier WordPress
    234 contributions

    Et oui, cela marche avec la 2.07. MERCI Amo !

    #592664
    fredooo13
    Participant
    Padawan WordPress
    62 contributions

    chez moi ça marche pas avec mon flux : http://podcom.fr/pauvcast/feed/

    c’est un WPMU… y a t’il une différence ?

    voici le code :

    
    <?php echo '’; ?>
    
    <!– generator="wordpress/” –>
    <rss version="2.0" 
    	xmlns:content="http://purl.org/rss/1.0/modules/content/"
    	xmlns:wfw="http://wellformedweb.org/CommentAPI/"
    	xmlns:dc="http://purl.org/dc/elements/1.1/"
    	
    >
    
    
    	<title></title>
    	
    	
    	
    	http://wordpress.org/?v=
    	
    	
    	
    	
    		<title></title>
    		
    		
    		
    		
    		
    
    		
    
    
              <![CDATA[]]>
          
              <![CDATA[]]>
            post_content ) > 0 ) : ?>
              <![CDATA[]]>
            
              <![CDATA[]]>
            
          
    
    		
    
    	
    	
    	

    #592665
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Moi je vois bien des images dans tes articles.

15 sujets de 1 à 15 (sur un total de 19)
  • Vous devez être connecté pour répondre à ce sujet.