[Résolu]MyGallery : dézippage impossible

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #448312
    jeclic
    Membre
    Initié WordPress
    7 contributions

    Je ne peux pas dézipper un répertoire sur le serveur.

    Cette commande, pose problème :
    exec (« unzip -j $my_zipfile -d $zipdir ») or die(‘

    ‘.__(‘Unable to unzip!’, ‘myGallery’).’

    ‘);

    J’ai l’impression qu’elle a été désactivée sur mon hébergement (ovh mutualise : 1000gp)
    Sinon je pense qu’il faut recoder cette ligne avec des fonctions php.

    Quelqu’un l’a t’il déjà fait ?

    Wordpress : Version 2.0.4
    Mygallery : Version 1.2

    #577987
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    J’ai l’impression qu’elle a été désactivée sur mon hébergement (ovh mutualise : 1000gp)

    Dans ce cas la majorité des hébergeurs le désactivent aussi. J’ai déjà essayé sur 3 sites que j’ai installés (sur 3 serveurs différents dont un payant) et je n’ai jamais été capable non plus de dézipper quoi que ce soit avec mygallery. C’est dommage d’ailleurs parce que je trouve que ce plugin fonctionne très bien, à part cela.

    #577988
    AmO
    Participant
    Maître WordPress
    4452 contributions

    la fonction zip est très rarement activé sur les serveur mutualisés car gourmande en ressources 😉

    #577989
    jeclic
    Membre
    Initié WordPress
    7 contributions

    Merci pour les deux réponses, je me doutais en effet que c’était désactivé.
    En tout cas, j’ai trouvé, suffit juste de rééecrire un peu de code et hop ! ça refonctionne !
    Disons que l’auteur n’a pas pensé à cette éventualité côté hébergeur…
    Je l’ai contacté pour l’en informé…

    #577990
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Tu peux partager ta modification ?

    #577991
    jeclic
    Membre
    Initié WordPress
    7 contributions

    L’auteur va (normalement) intégrer cela dans sa mise à jour.
    Tu peux télécharger la page qui pose problème ici.

    Garder quand même un original.

    #577992
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Merki 😉

    #577993
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    En tout cas ce n’est pas résolu pour moi.

    J’ai chargé le mygallerymain.php que jeclic a modifié et gentiment partagé puis je l’ai poussé sur le serveur (un serveur payant, donc je suppose avec plus de service qu’un serveur gratuit).
    J’ai choisi l’option Charger une archive d’images au format zip depuis mon ordinateur : dans l’admin>mygallery. Il avait l’air de charger, mais j’ai reçu Aucun fichier entré comme résultat.
    J’ai été voir via le FTP, et en effet il n’y a rien. Le directory n’a pas été créé non plus. pourtant le directory Galeries est en chmod 777. Le problème ne doit donc pas être là.
    Mais que dois-je faire pour que ça fonctionne chez moi ? :(

    #577994
    jeclic
    Membre
    Initié WordPress
    7 contributions

    C’est ch….. si ça ne fonctionne toujours pas. En tout cas, il y a eu une autre version en bêta, peut-être que ça peut solutionner ton problème.
    Je me suis aussi aperçu qu’il manquait juste une ligne qui faisait que les vignettes n’étaient pas crées quand on les inséraient déjà dans une gallerie existante.
    Tu peux la retélécharger, c’est corrigé.

    Si tu as une combine pour modifier la taille des vignettes qui s’affichent dans la page ?
    J’ai beau tout essayé, elles retent toujours à la même taille.
    D’autres ont le problème, l’auteur leur a répondu quelque chose que je ne comprends pas…

    Si tu as déjà eu ce problème, je suis preneur….

    #577995
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    En effet j’ai essayé de changer la taille de mes vignettes et elle reste toujours la même.
    Quant à dire pourquoi, là c’est une autre affaire.
    Mais en effet j’ai le problème aussi.

    #577996
    jeclic
    Membre
    Initié WordPress
    7 contributions

    Bon, ben, c’est cool.
    L’auteur me dit que c’est le cache du navigateur ou la config.
    J’ai eu beau tout tester, rien à faire.

    Je vais quand même essayer de récréer une autre répertoire de gallerie.
    Repartir de 0 quoi !

    Affaire à suivre…

    #577997
    AmO
    Participant
    Maître WordPress
    4452 contributions

    En modifiant directement la base de données ?

    #577998
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Ca va être pratique si il faut refaire la bdd chaque fois qu’on veut changer les vignettes … :boulet:

    :fouet: J’espère que l’auteur trouvera une solution pour résoudre le problème. :fouet:

    #577999
    AmO
    Participant
    Maître WordPress
    4452 contributions

    lol

    #578000
    jeclic
    Membre
    Initié WordPress
    7 contributions

    Ben, ouais, on ne peut pas toujours travailler dans la bdd. D’autant plus que l’administration ne se fait pas forcément par des gens qualifiés en informatique, donc solution malheureusement pas possible.

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.