[Résolu]Message d’erreur lorsqu’un commentaire est posté-gethostbyaddr (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 18)
  • Auteur
    Messages
  • #447252
    MU
    Membre
    Padawan WordPress
    89 contributions

    Bonjour,

    Ouhla, cela faisait longtemps que je ne m?étais pas rendu vers chez vous et j?espère que vous allez toutes et tous bien !

    Bref, passons les politesses? Je m?étais habitué depuis peu à essayer de me débrouiller tout seul dans l?élaboration de mon ptit blog mais là? j?ai un gros problème que je ne comprends absolument pas, et comme je ne trouve pas la réponse sur le forum malgré de nombreux mots clefs utilisés, j?en passe par l?écriture avec mon p?tit clavier de mon p?tit problème?

    Au début, je pensais qu?il s?agissait d?un problème dû à mon thème zen minimalist sur mon nouveau blog mais non car le souci réapparaît quel que soit le thème.

    En fait, à chaque commentaire posté ou à chaque validation de commentaire, je me retrouve avec les messages d?erreurs suivants :

    Pour le post :

    Warning: gethostbyaddr() has been disabled for security reasons in
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/comment-functions.php on line
    113

    Warning: gethostbyaddr() has been disabled for security reasons in
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/pluggable-functions.php on line
    380

    Warning: Cannot modify header information – headers already sent by (output
    started at
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/comment-functions.php:113) in
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-comments-post.php on line 54

    Warning: Cannot modify header information – headers already sent by (output
    started at
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/comment-functions.php:113) in
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-comments-post.php on line 55

    Warning: Cannot modify header information – headers already sent by (output
    started at
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/comment-functions.php:113) in
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-comments-post.php on line 56

    Warning: Cannot modify header information – headers already sent by (output
    started at
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/comment-functions.php:113) in
    /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/pluggable-functions.php on line
    247

    Pour la modération :

    Warning: gethostbyaddr() has been disabled for security reasons in /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/pluggable-functions.php on line 303

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/data/woo/3/M/4/C/3M4CA43K/wp-includes/pluggable-functions.php:303) in /var/www/data/woo/3/M/4/C/3M4CA43K/wp-admin/post.php on line 284

    J?utilise actuellement le thème InternetJobs traduit par AmO que je remercie énormément au passage.

    Ah oui, j?oubliais, pour aller voir l?erreur en direct, voici l?adresse du site : SNRT-CGT YPSO FRANCE .

    En vous remerciant par avance de vos réponses,

    À très bientôt,

    #571770
    AmO
    Participant
    Maître WordPress
    4447 contributions

    Quel est ton hebergeur ?

    Il n’a pas l’air d’apprécier la fonction gethostbyaddr()
    Réupload également le contenu des dossier wp-includes et wp-fonction en v2.0.2
    Ptete que ya un ptit pb lors de l’envoi :s

    #571771
    MU
    Membre
    Padawan WordPress
    89 contributions

    Merci AmO pour ta réponse, je vais effectivement réuploader les deux dossiers pour voir…
    Pour information, mon hébergeur est Wanadoo ^_^
    Je te tiens au courant dès que j’ai remis en place les deux dossiers….

    Merciiiii !

    #571772
    AmO
    Participant
    Maître WordPress
    4447 contributions

    Wanadoo?

    Avec l’option PHP/MySQL ?

    #571773
    AmO
    Participant
    Maître WordPress
    4447 contributions

    c pa ca ton site : http://d.athuil.free.fr/ ?

    #571774
    MU
    Membre
    Padawan WordPress
    89 contributions

    ça c’est mon ptit blog perso en fait mais pour celui de mon syndicat, il est hébergé par wanadoo… et oui, je ne choisis pas hélas… lol …

    #571775
    MU
    Membre
    Padawan WordPress
    89 contributions

    Oui oui, mon syndicat a payé l’option premium ^_^

    #571776
    AmO
    Participant
    Maître WordPress
    4447 contributions

    Wanadoo desactive :

    Pour des raisons de sécurité et de charge d’exploitation, Wanadoo a décidé de supprimer l’accès à certaines fonctions PHP sur les hébergements Premium. En voici la liste :
    checkdnsrr, chgrp, chmod, chown, diskfreespace, dl, exec, fsockopen, ftp_connect, get_current_user, gethostbyaddr, gethostbyname, gethostbynamel, getmxrr, getmypid, getmyuid, imap_mail, ini_alter, ini_restore, ini_set, leak, link, listen, mb_send_mail, mysql_list_dbs, openlog, passthru, pfsockopen, php_uname, popen, proc_open, putenv, realpath, rmdir, sem_acquire, sem_get, set_time_limit, shm_attach, shmop_open, socket_listen, syslog, system, tmpfile.
    NB : les fonctions mysql_connect et mysql_pconnect ont été modifiées. Leurs 3 premiers paramètres, à savoir le nom (ou l’IP) du serveur, le login et le mot de passe ne sont pas obligatoires.

    Hors WP utilise une de ses fonctions…
    Jvé regarder du coté du forum anglais mais à mon avis l’hebergement de wanadoo ne convient pas à WP

    #571777
    MU
    Membre
    Padawan WordPress
    89 contributions

    Merci beaucoup, j’avais regardé sur le site mais je n’avais pas trouvé cette liste… Je viens d’envoyer un message à Wanadoo pour savoir comment faire… j’espère qu’ils pourront me répondre rapidement et qu’ils auront une solution. En tout cas merci beaucoup pour ton aide à ce sujet !

    #571778
    AmO
    Participant
    Maître WordPress
    4447 contributions

    la solution :
    faire un code spécifique en mettant en dur le nom de ton serveur …

    #571779
    MU
    Membre
    Padawan WordPress
    89 contributions

    Wahooo ! j’en suis grave incapable… va falloir que je cherche ça rapido ^_^

    #571780
    AmO
    Participant
    Maître WordPress
    4447 contributions

    Edite le fichier comment-fonctions.php

    et remplace la ligne 129

    $comment_user_domain = apply_filters(‘pre_comment_user_domain’, gethostbyaddr($comment_author_IP) );

    par ca

    //	$comment_user_domain = apply_filters(‘pre_comment_user_domain’, gethostbyaddr($comment_author_IP) );

    #571781
    MU
    Membre
    Padawan WordPress
    89 contributions

    Mais tu es un génie dis moi ! Trop fort !
    Par contre, peux-tu m’expliquer ce que tu viens de faire et la différence entre les deux lignes de code et leurs applications…
    Cela me permettra de comprendre et donc d’apprendre…
    En tout cas, je te remercie grandement pour ton aide ! ça a l’air de marcher impeccablement !

    Merciiiiiiii !

    #571782
    AmO
    Participant
    Maître WordPress
    4447 contributions

    Le rajout des 2  » //  » devant met en commentaire la ligne…

    C’est à dire que php n’interpretera plus la ligne correspondante
    Dans le cas présent, le filtrage au niveau des utilisateur sur un meme domaine…

    je sais pas trop à quoi ca sertt mais bon :s
    Pas d’autre probleme?

    Edit : L’idée s’est de commenter toutes les lignes faisant appel à la fonction interdite ^^

    #571783
    MU
    Membre
    Padawan WordPress
    89 contributions

    Oki doki, je comprends mieux…

    J’ai le même problème si les personnes ne sont pas encore enregistrées pour l’envoi du commentaire… Ce problème est en ligne 380 sur le fichier pluggable-functions.php et je vais essayer de faire la même chose pour voir… Je te tiens au courant…

    Par contre l’envoi quand tu es loggé et la modération fonctionnent à nouveau sans problème… ^_^

15 sujets de 1 à 15 (sur un total de 18)
  • Vous devez être connecté pour répondre à ce sujet.