[Résolu]Erreur de permalien, impossible de revenir en mode par défaut !!

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 24)
  • Auteur
    Messages
  • #448322
    GanZ
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    – Version de WordPress :2.0.4 fr
    – Nom de l’hebergeur : free

    Problème(s) rencontré(s) :

    Je désirais donc modifier mes permaliens (comme un idiot que je suis :fouet:) je passe en mode personnalisé et je commence à écrire ma variable. Tout à coup ne me demander pas pourquoi je touche sans le faire exprès la touche « entrée » et je fini avec ça : /http:/gn%postname% .
    De là découle donc une erreur 500. Je me précipite donc ici, je chine avec la fonction :search: tout ce qui concerne les permaliens.

    Je trouve donc mon bonheur, sur le papier. Je vire mon fichier .htaccess, retourne dans mes options, permaliens où je revois cette horreur /http:/gn%postname%, je passe donc en permalien par défaut, je « submit » et là BOOOMMMM re-erreur 500, re fichier .htaccess, re-problème quoi !!!!

    Bref, je n’arrive pas à me dépêtrer de cette saucissonnade, help me !!!!

    Signé : un WP Users désespérer

    😗 Désolé pour cette affolement mais je viens de refaire la manipulation et cela refonctionne correctement, je ne comprend pas.😇

    Bref vous avez tous le droit de me :fouet:

    #578075
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Lol oki

    #578076
    Laetitia83
    Membre
    Initié WordPress
    5 contributions

    Bonjour
    Je suis confronté exactement au même problème.
    Je n’arrive pas à revenir au mode par défaut – car erreur 500
    Mon fichier .htaccess est recréé automatiquement
    Comment as tu résolu le problème ? Cela semble assez mystérieux sur la fin de ton poste.
    Laetitia

    #578077
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    La solution donnée dans notre FAQ peut-elle t’aider ?

    #578078
    Laetitia83
    Membre
    Initié WordPress
    5 contributions

    J’ai bien sûr essayé la manip proposée dans la FAQ.
    Je vire le .htaccess depuis Filezila.
    Je vais dans la partie admin pour modifier l’option pour les permaliens.
    Le problème c’est que je ne peux plus revenir à l’option par défaut pour l’attribution des permaliens. Dès que j’essaye de changer : j’ai une erreur 500 internal server error.
    Mon site est alors bloqué. Je dois retourner sur Filezilla pour enlever le .htaccess qui s’est recréé automatiquement.

    #578079
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Etrange… Normalemeent avec les permaliens par défaut, il ne doit pas recréer de htaccess… donc la manip doit être mal faite à un moment donné. Lorsque tu reviens dans les options des permaliens ensuite, quelle valeurs est coché les permaliens pas dédfaut comme tu viens de le mettre ou les permaliens perso tels que tu veux les mettre ?

    #578080
    Laetitia83
    Membre
    Initié WordPress
    5 contributions

    Ouf…après 5 heures de bidouillage je crois avoir résolu le problème.
    Comme je l’avais expliqué (et je crois que je ne suis pas la seule dans ce cas) il m’était impossible de modifier les options des permaliens pour revenir à la valeur par défaut – car j’obtenais une erreur 500, même lorsque j’avais pris soin au préalable de supprimer le fichier .htaccess créé automatiquement depuis Filezilla.
    Finalement : j’ai créé un fichier .htaccess vide (0ko – aucun texte dedans) que j’ai placé à la racine de mon blog. J’ai augmenté les autorisations de ce fichier (attribut 777).
    Je suis retournée sur l’interface administrateur et j’ai peu enfin revenir à la valeur par défaut.
    Maintenant le blog remarche – mais les permaliens sont moches (les ugly one comme ils disent dans le codex anglais voir Codex permalinks)
    Je dois dire à présent que j’hésite à passer à l’étape 4 de la FAQ : créer des permaliens personnalisés de la forme /index.php/categorie etc…
    Une question me taraude. Est-ce que mon arborescence n’a pas été à la source du problème. J’ai en effet mis le fichier index.php à la racine du site au coté du dossier nommé « blog » qui contient tous les fichiers et sous dossier wordpress. Dans cette configuration est-il possible de modifier la structure des permaliens ?
    Merci

    #578081
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Normalement ce n’est pas gênant. j’ai la même configuration et mes permaliens sont OK. 😉

    #578082
    nerv
    Membre
    Initié WordPress
    3 contributions

    Bonjour à tous,

    Il viens de m’arriver la même chose, et à cause de plusieurs recherches infructieuses, j’ai crée un nouveau post.
    Puis je suis tombé sur celui là.
    Par contre, Laetitia83, comment as-tu fait pour chmoder le htaccess en 777 étant donné que free empèche cette opération?
    Quel client ftp as-tu utilisé? (je vois plus haut filezilla…?)
    Sinon je pensais transferer mon blog en local, résoudre le problème sur mon systeme apache/mysql et renvoyer mon blog chez free. Mais si tu connais un moyen de chmoder ce fichier chez free, je suis prenneur 🙂

    Merci 😋

    Edit : Ah bah non, c’est pas Laetitia83 qui est chez free, mais Ganz.
    Donc je vais m’en tenir à ma première idée, rétablir la situation en local, et rebalancer sur free…
    Ou alors même je sens que je vais me prendre un petit hébergement à 15?/an chez one and one, et ça seras réglé, plus de problèmes de ce type 🙂

    Bye

    #578083
    Many
    Membre
    Maître WordPress
    1485 contributions

    Bonjour Nerv. Moi je suis chez free et après avoir rencontré le même problème (à l’instant) jai réussi à le résoudre sans trop de peine (ouf) mais non sans panique :D.

    Je n’ai pas lu le FAQ donc je ne sais pas ce qui y a été conseillé dans ce genre de situation (vilain) :fouet:

    Donc j’ai voulu modifié la structure de mes permaliens et paf, Internal sever error. Bref peux plus rien faire. Qu’est-ce que j’ai fait ?

    Comme je n’avais plus accès à mon panel admin je suis allé direct dans ma BDD et j’ai mis la valeur par défault (cad rien. Tu effaces ce qu’il y a d’inscrit et tu le laisse à vide).

    Ensuite j’ai viré le fichier htaccess et c’est tout. Tout remarche comme avant. Je peux me reconnecter. Dans mes options la strucutre de mes permaliens est revenu immédiatement à la valeur par défault.

    Je pense que tu as déjà résoud ton problème mais je poste tout de même ça ici au cas où. Ca peut aider d’autres qui sont chez Free ^^

    #578084
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Merci d’avoir partager ton astuce 😉

    Ben => A mettre dans la FAQ 😋

    #578085
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    AmO > Par contre pour mettre dans la FAQ, il faudrait que je sache dans quelle table aller dans la base de données et quelles info supprimer… car là dedans, je n’y connais pas grand chose… 😉

    #578086
    Many
    Membre
    Maître WordPress
    1485 contributions

    Salut ben. Bon je détails les étapes ici alors et à toi de faire le reste dans le FAQ 😉

    Il faut donc aller dans PhpMyAdmin puis afficher la table « wp_options« .

    Ensuite chercher l’option « permalink_structure« . Elle se trouve à la ligne 34. Selon le nombre de lignes affichées par page elle peut se trouver vers la fin de la première page ou en début de la deuxième page.

    Ensuite cliquer sur « Modifier » et effacer ce qu’il y a d’inscrit. Quand vous avez l’option « structure des permaliens par défault » cochée dans la console admin de WP, cette case est vide.

    Enfin faire « Exécuter » et c’est bon 🙂

    Voili voilou !!

    #578087
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Voilà c’est fait ! J’ai mis à jour l’article de la FAQ sur ce sujet.

    Many > J’ai repris ton texte que j’ai copié-collé, l’explication étant impeccable. J’espère que ça te gêne pas. 😉

    #578088
    Many
    Membre
    Maître WordPress
    1485 contributions

    Du tout ! 🍺

15 sujets de 1 à 15 (sur un total de 24)
  • Vous devez être connecté pour répondre à ce sujet.