[Résolu] WordPress ne crée pas de miniatures (upload d’images) (Créer un compte)

  • Statut : non résolu
8 sujets de 16 à 23 (sur un total de 23)
  • Auteur
    Messages
  • #647271
    Li-An
    Modérateur
    Maître WordPress
    24112 contributions

    Euh, en règle générale, WP ne propose que les choses qu’il peut retailler. Vérifie dans tes options les tailles de miniatures ?

    #647272
    Arkados
    Participant
    Initié WordPress
    26 contributions

    Mmmmmh….

    sanstitrejiz.png

    Rien d’anormal ici je suppose…
    (l’image était un PNG, donc normalement traité par WP)

    #647273
    Li-An
    Modérateur
    Maître WordPress
    24112 contributions

    Essaie quand mm avec un jpg ?

    #647274
    Arkados
    Participant
    Initié WordPress
    26 contributions

    Marche pas non plus 😕
    Je vais comparer les fichiers de config entre l’ancien et le nouveau, tester des changements de paramètres,…

    Si ça peut aider, j’ai basé ma nouvelle config sur ces docs:
    http://doc.ubuntu-fr.org/lamp
    http://doc.ubuntu-fr.org/tutoriel/securiser_apache2

    Edit: toujours rien -_-; j’ai saladé mes fichiers de config à en faire planter plusieurs fois le serveur, sans résultat espéré. Des directives htaccess, options pour Directory aux addhandlers php en passant bien sûr par les droits d’exécution d’Apache et des permissions d’accès aux dossiers… en vain.

    Les logs d’Apache me montrent un désespérant “[14/Jul/2009:16:46:22 +0200] “POST /blog/wp-admin/async-upload.php HTTP/1.1” 200 4 “-” “Shockwave Flash”
    – – [14/Jul/2009:16:46:25 +0200] “POST /blog/wp-admin/async-upload.php HTTP/1.1” 200 5594 “/blog/wp-admin/media-upload.php?post_id=6726&type=image&” “”
    – – [14/Jul/2009:16:46:26 +0200] “GET /blog/wp-content/uploads/2009/07/test.jpg HTTP/1.1” 200 70329 “/blog/wp-admin/media-upload.php?post_id=6726&type=image&” “”

    .. Status code 200 d’Apache: OK. Aucun indice -_-

    Edit2: oui mais là….
    J’ai réinstallé à l’identique la structure sur un PC à moi et là ça marche sans problème. Des configurations d’Apache aux permissions d’accès aux fichiers/dossiers en passant par la config de PHP et les options du VirtualHost, tout est IDENTIQUE (à part bien sûr les directives servername, serveralias, namevirtualhost…).
    Avec ou sans Xcache, avec ou sans apache2-prefork-dev…. tout ce qui m’est passé par la tête…

    #647275
    Arkados
    Participant
    Initié WordPress
    26 contributions

    Après de nombreux tests, 2 théories deviennent de plus en plus plausibles:

    -Apache et/ou PHP ne sont pas assez à jour (versions 2.2.8 et 5.2.4 installées)
    -Mon serveur est sous influence des voyageurs venus de Proxima du centaure (oui ce bug me fait perdre le sens commun)

    En tout cas, c’est synonyme de gros travaux: vais devoir mettre à jour tout le système (merci le blocage de versions d’Ubuntu). Et sans garantie que ça résoudra ce problème avec les miniatures…

    Si quelqu’un a une idée pour passer outre ce genre d’opérations, merci de ne pas tarder à me le faire savoir.

    #647276
    Jos
    Membre
    Initié WordPress
    1 contributions

    Salut,

    Installe [url=apt://php5-gd]php5-gd[/url]
    http://forum.ubuntu-fr.org/viewtopic.php?id=338181

    #647277
    Arkados
    Participant
    Initié WordPress
    26 contributions

    Désolé pour la réponse tardive, j’avais résolu ça plus tard sans m’en rendre compte quand j’avais réinstallé des tonnes de librairies PHP (dont php5-gd je vois) sur un autre serveur.

    Donc maintenant je comprends mieux pourquoi, là ça me parait tellement simple que j’en reviens pas.
    Bref, plus d’excuses pour faire chacun son WordPress chez lui !

    #647278
    slayem13
    Membre
    Initié WordPress
    1 contributions
    Arkados wrote:
    Désolé pour la réponse tardive, j’avais résolu ça plus tard sans m’en rendre compte quand j’avais réinstallé des tonnes de librairies PHP (dont php5-gd je vois) sur un autre serveur.

    Donc maintenant je comprends mieux pourquoi, là ça me parait tellement simple que j’en reviens pas.
    Bref, plus d’excuses pour faire chacun son WordPress chez lui !

    bonjour Arkados

    j’ai la meme probleme que toi wordpress ne veut plus créer de réductions des images uploadées (des miniatures): il me conserve toujours les dimentions original

    j’ai fais un transfer vers un nouveau hébergeur Giga-hosting.

    et j’ai pas trouvé la solution . SVP aide moi

8 sujets de 16 à 23 (sur un total de 23)
  • Vous devez être connecté pour répondre à ce sujet.