[Résolu] WordPress 2.8 et Free font-ils bon ménage ?

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 20)
  • Auteur
    Messages
  • #471089
    imported_BenKenobi
    Membre
    Padawan WordPress
    93 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.8
    – Thème utilisé : Gossip City
    – Plugins en place : Tous désactivé
    – Nom de l’hebergeur : Free (surement le problème d’ailleurs !!)
    – Adresse du site : http://saint.maur.c.est.fou.free.fr/

    Problème(s) rencontré(s) :

    Voici l’erreur qui apparait dans le tableau de bord après mise à jours de 2.7.1 vers 2.8 :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1474560 bytes) in /mnt/163/sda/2/c/saint.maur.c.est.fou/wp-includes/class-simplepie.php on line 4852

    et l’erreur qui apparait dans la barre latérale du blog coté public :

    Fatal error: cannot yet handle MBCS in html_entity_decode()! in /mnt/163/sda/2/c/saint.maur.c.est.fou/wp-includes/default-widgets.php on line 711

    Bien sur tout ce qui doit être chargé après ces lignes ne se chargent pas.

    J’ai tenté à plusieurs reprises de recharger sur le FTP tout ou partie des fichiers WordPress mais rien ne change.
    C’est pas de veine… une de mes rares mise à jour qui foire… ca faisait longtemps !!

    #676694
    gloubis
    Participant
    Initié WordPress
    16 contributions

    Bonjour BenKenobi,

    J’ai eu les mêmes erreurs, ce n’est pas la mise à jour qui foire 😉
    C’est parce que tu utilises free avec php4 (par défaut).
    Tu peux le vérifier en créant un fichier php contenant la ligne suivante :

    Il faut utiliser php5. Pour cela, il te suffit de créer un fichier .htaccess sur la racine du site contenant cette ligne :

    php 5

    et tout sera réglé.

    Pour info, toutes mes extensions passent.

    Glou

    #676695
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    OK merci de l’astuce. Ca marche impeccable 😉

    #676696
    chamomor
    Participant
    Maître WordPress
    1914 contributions

    Bon
    Pour passer en php5 chez free, il suffit de placer dans un fichier .htaccess la seule ligne:

    php 1

    ce que le fichier test phpinfo confirme:

    “PHP Version 5.1.3RC4-dev”

    reedit :

    Mise à jour tentée à nouveau, toujours le même problème bien que passé en php5…

    #676697
    chamomor
    Participant
    Maître WordPress
    1914 contributions

    Mon problème est résolu, moyennant les modifications suivantes :

    Je suis chez Free, il faut donc obliger ce serveur à passer en php5:

    1° créer fichier .htaccess
    qui contient une seule ligne :
    php 1

    2° Au moment de réactiver les extensions, une à une, à côté de la page des extensions, ouvrir dans un autre onglet la page du tableau de bord et chaque fois vérifier (en actualisant chaque fois la page) si tout va bien, si on peut cliquer sur les options. Dès qu’une extension fait tout planter, la désactiver puis la supprimer avec filezilla

    voici les plugins qui chez moi font foirer et que j’ai été obligé d’enlever:

    WordPress Database Backup
    All in One SEO Pack
    WP Ajax Edit Comments
    StatpressCN fonctionne jusque l’avant dernière version (ne pas mettre à jour quoi)

    #676698
    Anonyme 2
    Participant
    Maître WordPress
    10594 contributions

    Bonjour,

    arrivez vous à accéder à votre base de donnée chez Free?

    #676699
    Fan Jiyong
    Participant
    Chevalier WordPress
    133 contributions
    Lupi wrote:
    Bonjour,

    arrivez vous à accéder à votre base de donnée chez Free?

    bonjour
    moi non plus je n’arrive pas.

    #676700
    gloubis
    Participant
    Initié WordPress
    16 contributions

    Pareil pour moi.
    Si tu connais les requêtes que tu veux exécuter, tu peux utiliser le plugin WP-DBManager qui permet (entre autres) d’en exécuter.
    J’ai testé, ça passe.

    #676701
    chamomor
    Participant
    Maître WordPress
    1914 contributions

    Bonjour, non effectivement je n’y ai pas accès

    #676702
    chris84
    Participant
    Initié WordPress
    15 contributions

    Bonjour, j’ai moi aussi le message d’erreur avec “class-simplepie.php”. J’ai désactivité les plugin 1 à 1 rien ne change.

    #676703
    Anonyme 2
    Participant
    Maître WordPress
    10594 contributions

    L’idéal serait que vous arriviez à accéder à votre base de donnée
    http://sql.free.fr/phpMyAdmin/
    puis de la sauvegarder pour ainsi pourvoir réinstaller votre blog.

    #676704
    mll
    Membre
    Initié WordPress
    16 contributions
    chamomor wrote:
    Bon
    Pour passer en php5 chez free, il suffit de placer dans un fichier .htaccess la seule ligne:

    php 1

    ce que le fichier test phpinfo confirme:

    “PHP Version 5.1.3RC4-dev”

    reedit :

    Mise à jour tentée à nouveau, toujours le même problème bien que passé en php5…

    Nickel, marche pour moi, merci ! 🙂

    #676705
    chris84
    Participant
    Initié WordPress
    15 contributions

    bonjour et bien moi toujours meme erreur malgré le fichier .htaccess avec php 1.
    l’erreur est :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1474560 bytes) in /mnt/102/free.fr/d/a/motobalade84/wp-includes/class-simplepie.php on line 5359

    merci d’avance

    #676707
    moudugnou
    Membre
    Initié WordPress
    2 contributions

    Bonjour,

    J’utilise également Free, a priori la version de php est 5.2 selon MySQL, mais dès que je veux inserer un photo en utilisant “Envoyer/inserer” dans modifier un article, j’ai un message d’erreur similaire à Chris84

    atal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 10240 bytes) in /mnt/142/sda/a/c/clemetmobi/wp-admin/includes/image.php on line 147

    Je n’y connais pas grand chose mais si vous avez des indications, merci d’avance !

    Clement

    #676706
    Anonyme 2
    Participant
    Maître WordPress
    10594 contributions

    Bonjour,

    soit votre image est trop grosse ou trop grande.

15 sujets de 1 à 15 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.