[Résolu] [UTW] 404 sur la recherche par tags

  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #450031
    Neige
    Membre
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.6
    – Thème utilisé : Default
    – Plugins en place : Ulimate Tag Warrior, Widgets, UTW-cloud
    – Nom de l’hebergeur : moi

    Problème(s) rencontré(s) :

    J’ai installé un WordPress tout neuf. Ca marche bien. L’url rewriting entièrement géré par WP c’est vraiment le pied (c’est d’ailleurs ce qui m’a fait renoncer à dotClear).
    J’ai donc installé Ultimate Tag Warrior ainsi que le moteur de widgets, accompagné par le widget UTW-cloud, qui génère un joli nuage de tags.
    Tout ça, c’est très bien, sauf que : si j’active la réécriture d’url pour les tags, lors d’une recherche par tag (classiquement /index.php?tag=truc devient /tag/truc) je me retrouve avec une erreur 404 made in WP. Démonstration :
    http://neige.orphyx.net/index.php?tag=wordpress
    http://neige.orphyx.net/tag/wordpress

    Je n’ai d’ailleurs pas réussi à reproduire cette erreur manuellement (ie en variant sur l’url). J’obtiens plein de choses, mais pas la même erreur.
    Comme je suis encore un peu néophyte avec WordPress, mes quelques (rapides) recherches dans le code ne m’ont pas permis d’identifier l’origine du problème (je ne sais donc pas si ça vient du plugin UTW, du widget utw-cloud, du .htaccess que je n’arrive pas à modifier sans me taper une HTTP 500…).

    D’ailleurs, le .htaccess généré par WP automatiquement, le voici :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Je le répète, il fonctionne très bien pour l’url rewriting de tout le reste…

    Si quelqu’un a une petite idée… (recherche resté infructueuse…)

    D’avance merci, bonne année, joyeuses pâques, bon anniversaire, etc…

    P.S. : C’est pas vraiment urgent ni important, puisque si je ne réécris pas les url des tags, ça marche… C’est juste que c’est plus joli…

    #588511
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Met à jour tes permaliens pour voir ?

    #588512
    Neige
    Membre
    Initié WordPress
    2 contributions

    Je suis vert… Ca fonctionne…
    J’avoue que je ne comprends pas ce que le simple clic sur ce bouton peut faire, alors que je n’ai changé aucune option…

    Bon… Ben merci… C’était tout con, mais fallait y penser…

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.