[Résolu] Soucis avec plusieurs noms de domaine

  • Statut : non résolu
5 sujets de 16 à 20 (sur un total de 20)
  • Auteur
    Messages
  • #577520
    steph2dijon
    Membre
    Chevalier WordPress
    132 contributions

    J’ai viré cette partie là :

    if ( strpos($_SERVER[‘HTTP_HOST’], ‘www.’) === 0  && strpos(get_bloginfo(‘home’), ‘http://www.’) === false ) {
    header(‘HTTP/1.1 301 Moved Permanently’);
    header(‘Location: http://’ . substr($_SERVER[‘HTTP_HOST’], 4) . $_SERVER[‘REQUEST_URI’]);
    exit();
    
    } elseif ( strpos($_SERVER[‘HTTP_HOST’], ‘www.’) !== 0 && strpos(get_bloginfo(‘home’), ‘http://www.’) === 0 ) {
    header(‘HTTP/1.1 301 Moved Permanently’);
    header(‘Location: http://www.’ . $_SERVER[‘HTTP_HOST’] . $_SERVER[‘REQUEST_URI’]);
    exit();

    Et ça fonctionne 😎

    Merci à tous en tout cas de vous être penché sur mon problème 🙂

    #577521
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Nickel…

    (on avait pas tout les éléments en main la 😋 )

    #577522
    steph2dijon
    Membre
    Chevalier WordPress
    132 contributions
    AmO wrote:
    Nickel…

    (on avait pas tout les éléments en main la 😋 )

    Non c’est clair. En fait ce thème est super je trouve, mais il intègre de base des plug-ins, etc, donc potentiellement des fonctions que l’on ne recherche pas particulièrement.

    Celle-ci en était une.

    #577523
    c12
    Participant
    Padawan WordPress
    66 contributions

    Content tu ais trouvé et règlé le soucis !
    Longue vie à ton blog.

    #577524
    steph2dijon
    Membre
    Chevalier WordPress
    132 contributions
    c12 wrote:
    Content tu ais trouvé et règlé le soucis !
    Longue vie à ton blog.

    Merci, c’est très sympa :D

5 sujets de 16 à 20 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.