[Résolu] Souci avec Image Manager (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #451499
    soupolait
    Membre
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1.3
    – Thème utilisé : Freshy
    – Plugins en place : Akismet, ImageManager, Lightbox, Sidebar Widgets, Single Bookmark Category, WYSI-Wordpress (au passage TinyMCE ne fonctionnait plus d’ou cet autre éditeur wysiwyg…)
    – Nom de l’hebergeur : Trust Telecom
    – Adresse du site : http://www.soupolait.net

    Problème(s) rencontré(s) :
    Depuis que j’ai installé ImageManager, je n’arrive pas à uploader des images. J’ai vérifié les permissions (elles sont bien en 777 sur le dossier uploads). Je l’ai désistallé puis réinstallé, j’ai désactivé les autres plugins, et rien n’y fait.
    Quand j’uploade une image, elle apparaît ainsi :

    uploadimagemanager.jpg

    Et bien sûr, quand elle est intégrée dans un post, ça donne ça…

    uploadimagemanager2.jpg

    Quelqu’un aurait une solution à m’apporter par hasard ?

    Merci

    #597515
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    Bonjour,

    Juste une question est ce que vous utilisiez ImageManager avec une ancienne version de WordPress ?
    Pour ma part j’ai fait un essai avec la version 2.1.2 de wordpress et 2.4.1 d’ImageManager… Cela n’a jamais fonctionné (l’icône n’apparaissait plus) ! Je suis donc revenue à la version 2.0.9 de WordPress et 2.3.7 d’ImageManager et tout est rentré dans l’ordre. Peut-être qu’avec la version 2.2 de WordPress …

    En tout cas si quelqu’un a une solution je suis intéressée :rolleyes:

    #597516
    soupolait
    Membre
    Initié WordPress
    6 contributions

    J’ai essayé avec les versions 2.1.2 et 2.1.3 (mise en ligne hier) de WP et avec la dernière version de IM, sans succès. Par contre débutant sous WP, je n’ai jamais testé avec d’anciennes versions…

    #597517
    Tatane
    Membre
    Initié WordPress
    4 contributions

    pour le souci d’Elisabeth j’en ai rencontré un moi aussi, il me semble qu’on parle du même,
    j’ai écrit un billet pour m’en rappeller 😉
    http://blog.arobanet.com/bug-imagemanager-et-wordpress/4

    #597518
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions
    Tatane wrote:
    pour le souci d’Elisabeth j’en ai rencontré un moi aussi, il me semble qu’on parle du même,
    j’ai écrit un billet pour m’en rappeller 😉
    http://blog.arobanet.com/bug-imagemanager-et-wordpress/4

    Merci Tatane, j’ai fait le test, ça fonctionne !

    #597519
    Tatane
    Membre
    Initié WordPress
    4 contributions

    et bien hormis moi tu es la première à tester mon “debug”, au moins je peux savoir que ça marche ailleurs que chez moi 😉
    merci du retour 😉

    #597520
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    En fait, j’ai seulement eu à modifier le fichier tiny_mce_gzip.php car le fichier imagemanager-plugin.php était correct.
    :D

    #597521
    Tatane
    Membre
    Initié WordPress
    4 contributions

    ok je note …

    #597522
    nicoclimb
    Membre
    Initié WordPress
    5 contributions

    Bonjour,

    J’ai le même problème “Soupolait”: je n’arrive pas à uploader des images avec imagemanager. Il semblerait que le problème soit lié aux permissions. Sur mon dossier “upload”, la permission est fixée à 777, lorsque j’upload une image via mon ftp (dans Ivalue Host, via CPanel), le droit sur l’image est fixé à 644 et elle est donc visible et utilisable dans IM (ImageManager), par contre, lorsque j’upload limage via IM, le droit est fixé à 600 et je ne la vois donc pas dans IM…

    help-1.jpg

    Version de IM: 2.4.1
    Version de WP: 2.1.3

    Autres plugins installés: Calendar, Cforms, Role Manager, WP-dtree.

    Au passage, est-il déconseillé d’utiliser IM avec WYSI-Wordpress et WP lightbox Plus ?

    Merci beaucoup pour votre aide!

    #597523
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Sur un serveur dédié ?

    #597524
    nicoclimb
    Membre
    Initié WordPress
    5 contributions

    Un serveur partagé je suppose… (www.Ivaluehost.com)

    #597525
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    Soupolait, je ne sais pas si tu as résolu ton problème, mais j’ai peut être une solution :
    En combinant l’astuce donné sur le site http://www.soderlind.no/forum/viewtopic.php?id=212

    The point is that tiny_mce_gzip.php has a bug.

    Line 173 of tiny_mce_gzip.php
    $plugins = explode(“,”, $plugins);

    Gives you a wrong list of plugin installed, for me was :
    inlinepopups,autosave,spellchecker,paste,wordpress,

    Note the , at the end. This makes tiny_mce_gzip.php look for
    YOUR_ROOT/js/tinymce/plugins/editor_plugin.js
    that doesn’t exist

    So, to fix it you can

    1) Create the empty file in YOUR_ROOT/js/tinymce/plugins/editor_plugin.js
    2) Fix tiny_mce_gzip.php in this way
    Code:

    $plugins = explode(“,”, $plugins);
    foreach ($plugins as $plugin) {

    if ($plugin != ”) {

    $pluginFile = realpath(“plugins/” . $plugin . “/editor_plugin” . $suffix . “.js”);
    /* WP $languageFile = realpath(“plugins/” . $plugin . “/langs/” . $lang . “.js”); WP */

    if ($pluginFile)
    TinyMCE_echo(file_get_contents($pluginFile));

    /* WP if ($languageFile) WP */
    TinyMCE_echo(wp_tinymce_lang(“plugins/” . $plugin . “/langs/%s.js”)); // WP

    }
    }

    Avec celle donnée par Tatane : http://blog.arobanet.com/bug-imagemanager-et-wordpress/4

    Et hop hop hop, miracle, ça marche pour le thème Freshy !!!!

    #597526
    nicoclimb
    Membre
    Initié WordPress
    5 contributions

    Bon, merci pour la réponse.

    Mon problème vient peut-être de là: je n’ai aucune trace de tiny_mce_gzip.php dans mes plugins ou même ailleurs… Dois-je réinstaller TinyMCE, si oui, où puis-je trouver ce plugin?

    #597527
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    Bonjour,

    Le fichier tiny_mce_gzip.php est situé dans wp-includes/js/tinymce/
    Il suffit juste de faire les modif indiquées dans le fichier 😉
    Si tu n’as pas le fichier tiny_mce_gzip.php , tu le trouveras dans la mise à jour de WP 2.1.3

    #597528
    nicoclimb
    Membre
    Initié WordPress
    5 contributions

    Autant pour moi…

    J’ai trouvé tiny_mce_gzip.php. Mais malgré les modifications, ça ne marche toujours pas… J’ai toujours ce problème de droit fixé sur 600 lors de l’upload via l’interface de wordpress!

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.