[Résolu] Problèmes avec WeatherIcon

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #448468
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.4
    – Thème utilisé : Alpha Mx4 customisé
    – Plugins en place : Advanced Wysiwyg editor, MyGallery, Timezone, WP-Useronline, WP_Onlinecounter,
    WordPress Database Backup
    – Nom de l’hebergeur : Nathosting

    Problème(s) rencontré(s) :
    Je viens de changer mon blog d’hébergeur. J’ai downloadé tous les fichiers du blog et fait un export de la bdd.
    J’ai uploadé tous les fichiers sur le nouveau serveur et j’y ai importé la bdd (avec les modif nécesaires d’url).

    Le site s’ouvre. Super. :D
    Mais ça n’a pas duré longtemps. :(

    Une fois dans l’admin, j’ai voulu réactiver les plugins. Tout allait bien jusqu’à l’activation de WeatherIcon. Dès que j’y touche, je reçois le message suivant :

    Warning: Cannot modify header information – headers already sent by (output started at /home/deneyer/public_html/wp/wp-content/plugins/WeatherIcon/WeatherIcon.php:1) in /home/deneyer/public_html/wp/wp-includes/pluggable-functions.php on line 272

    J’ai désactivé le plugin, je l’ai supprimé du serveur et j’ai effacé la table de la bdd. J’ai uploadé le plugin original (pas celui que j’avais downloadé de l’ancien serveur). Et j’ai exactement le même message.

    Pourtant le plugin fonctionne sur le blog, mais je ne suis plus capable d’atteindre l’admin. Dès que j’essayer de me logger sur l’admin, je reçois ce message.

    J’ai exactement le même problème avec WP-Onlinecounter qui me renvoit :

    Warning: Cannot modify header information – headers already sent by (output started at /home/deneyer/public_html/wp/wp-content/plugins/wp-onlinecounter.php:1) in /home/deneyer/public_html/wp/wp-includes/pluggable-functions.php on line 272

    et avec juste WP-onlinecounter installé (WeatherIcon supprimé), quand j’essaye d’entrer dans l’admin j’ai :

    Warning: Cannot modify header information – headers already sent by (output started at /home/deneyer/public_html/wp/wp-content/plugins/wp-onlinecounter.php:1) in /home/deneyer/public_html/wp/wp-login.php on line 9

    Warning: Cannot modify header information – headers already sent by (output started at /home/deneyer/public_html/wp/wp-content/plugins/wp-onlinecounter.php:1) in /home/deneyer/public_html/wp/wp-includes/pluggable-functions.php on line 309

    Warning: Cannot modify header information – headers already sent by (output started at /home/deneyer/public_html/wp/wp-content/plugins/wp-onlinecounter.php:1) in /home/deneyer/public_html/wp/wp-includes/pluggable-functions.php on line 310

    Warning: Cannot modify header information – headers already sent by (output started at /home/deneyer/public_html/wp/wp-content/plugins/wp-onlinecounter.php:1) in /home/deneyer/public_html/wp/wp-includes/pluggable-functions.php on line 272

    D’où est-ce que ça peut venir ?

    Merci de vos z’avis z’avisés,
    Jean-Marc

    #578886
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Supprime WP-Online Counter
    Vire les infos de la BDD le concernant
    Vire le des plugins actifs (y’a une ligne active_plugins)

    Normalement tu devrais avoir accès à ta console…
    Installe WeatherIcon

    Vérifie que tout marche
    et réinstalle WP Online Counter ^^ logiquement y’a pas de raison pour que ^

    #578887
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    J’avais supprimé WeatherIcon et Onlinecounter et supprimé les tables dans la bdd.
    J’ai commencé par Onlinecounter (C’est juste un fichier au lieu d’un répertoire complet avec icônes etc) et dès que j’essaye d’activer le plugin, je reçois le message.
    Je ne comprend vraiment pas et j’avoue que je n’ai pas fort envie de faire une install de 0, puis réintroduire tous les posts, galeries etc à la main et en “tout neuf”.

    Vire le des plugins actifs (y’a une ligne active_plugins)

    C’est où ?
    Quand je supprime un plugin du serveur, il passe automatiquement en désactivé, puisque je dois le réactiver après l’avoir remis sur le serveur.
    J’ai essayé aussi de désactiver le plugin, puis de le supprimer, puis de supprimer sa table dans la bdd, puis de le remettre sur le serveur, puis de l’activer. Et là … message :(

    De plus, ce qui est bizarre aussi c’est que je reçois ces messages, mais si je vais sur le blog, tout fonctionne correctement (au vu des visiteurs). On dirait que c’est juste dans l’admin que ça m…

    #578888
    Andy
    Participant
    Chevalier WordPress
    109 contributions

    Tu es sûr de ne pas avoir introduit par inadvertence des espaces avant ou après le de fin de fichier ?
    En général, ces messages viennent de là.

    #578889
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Dans quel fichier ? Je vais vérifier.
    J’ai juste downloadé les fichiers d’un serveur et uploadé sur l’autre. Je ne vois pas comment des espaces se seraient introduits.
    Par contre je me souviens que sur l’ancien serveur j’avais un plugin de mise à jour pour WP 2.0.3 et en écrivant cet article je ne me souviens pas de l’avoir vu sur le nouveau serveur. Serait-ce une piste ?

    #578890
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Je pense avoir trouvé la raison de ces messages. :D
    Après une bonne journée de recherche, je me suis rendu compte que ce soit des plugins que j’avais convertis en UTF8 au lieu de ANSI pour éviter de coder les caractères accentués. Sur l’ancien hébergeur, ça passait nickel, mais il semble que celui-ci le refuse catégoriquement. A moins que ce soit moi qui ait configuré les bdd différemment (jeux de caractères et interclassement), pourtant j’ai mis la nouvelle bdd en UTF8 unicode pour que ces pages passent.
    J’ai reconverti les fichiers en ANSI et j’ai codé tous les caractères accentués (enfin, je pense. Il peut en rester un ou l’autre qui traîne).

    Si qqn sait pourquoi des fichiers php sont acceptés en UTF8 sur un serveur et pas sur un autre, ça m’intéresserait de le savoir.

    Jean-Marc

    #578891
    nowhereman
    Membre
    Initié WordPress
    28 contributions

    Bonjour ou plutôt bonsoir.
    J’ai une question concernant le plugin WeatherIcon (version 2.3.1) avec WordPress 2.0.3 hébergé chez Free.
    J’ai essayé de l’installer comme cela était indiqué dans le fichier “Read me” joint mais j’ai eu quelques soucis.
    Le nom “Météo” apparait avec des caractères chinois (ou japonais ?) à la place des “é” et de certaines des lettres qui l’entourent (ex : m鴩o) dans la fenêtre des plugins installés. Et cela se produit également quand je passe dans la fenêtre Editeur de plugins pour d’autres mots qui ont des caractères accentués (y en pas des masses mais bon). Et si j’active ce plugin, rien n’apparait.

    J’ai entendu parler de codage mais qu’en est-il réellement ? Comment faire pour bien faire fonctionner ce plugin ? Faut-il faire des copier-coller partiels de ce fichier ou autre chose ?

    Merci d’avance

    PS : Je suis débutant dans WordPress…

    #578892
    cali
    Participant
    Chevalier WordPress
    119 contributions

    essaye comme ca => météo

    é =>é =>
    è =>è =&gt
    à =>à =>
    ù =>ù =>
    ê =>ê =>

    #578893
    nowhereman
    Membre
    Initié WordPress
    28 contributions
    cali wrote:
    essaye comme ca => météo

    é =>é =>
    è =>è =&gt
    à =>à =>
    ù =>ù =>
    ê =>ê =>

    je vais voir si ça fonctionne ^^
    en tout cas, merci de l’info 🙂

    le seul hic c’est que j’ai toujour un problème d’installation pour ce plugin : la solution, c’est pour faire apparaitre les “é” et autres lettres avec accents non ?! Et pour faire apparaitre le temps sur mon blog, ça le résoue aussi en même temps car là je sèche :s

    #578894
    nowhereman
    Membre
    Initié WordPress
    28 contributions
    nowhereman wrote:
    cali wrote:
    essaye comme ca => météo

    é =>é =>
    è =>è =&gt
    à =>à =>
    ù =>ù =>
    ê =>ê =>

    je vais voir si ça fonctionne ^^
    en tout cas, merci de l’info 🙂

    le seul hic c’est que j’ai toujour un problème d’installation pour ce plugin : la solution, c’est pour faire apparaitre les “é” et autres lettres avec accents non ?! Et pour faire apparaitre le temps sur mon blog, ça le résoue aussi en même temps car là je sèche :s

    Coucou à tous.

    J’ai résolu mon problème. Celui-ci était lié au fait que mon plugin n’avait pas été transféré sur ma page perso. J’ai pu paramétrer mon logiciel FTP et faire le nécessaire (cf post “Wordpress et serveur”) et installer également la nouvelle version du plugin de WeatherIcon (version 3) qui fonctionne à merveille. Bon, elle est en anglais mais ça ne fait rien ^^.

    Merci encore pour les conseils sur les accents dans le php.

    Bye 🙂

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.