[Résolu] Problème WP Grins (Créer un compte)

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #450521
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1
    – Thème utilisé : Fresh
    – Plugins en place : Countdown; WP-Stats; WP-UserOnline; WP Grins
    – Nom de l’hebergeur : Dedibox

    Problème(s) rencontré(s) :

    C’est pour WP Grins
    L’étape 3 indique la modification du fichier wp-admin/quicktags.php hors je n’utilise pas Quicktags
    Je passe a la deuxième méthode et je ne trouve dans aucun des trois fichiers les lignes et id=”content”

    L’étape 4 indique la modification du fichier wp-comments.php hors je ne l’est pas a la racine du blog;
    J’ai wp-comments-post.php & wp-commentsrss2.php et dans aucun des deux je ne trouve

    Peut être que cela vient de la version 2.1 de WP ?

    #591758
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Bonsoir DotWoot,

    WP Grin connait des probleme avec la version 2.0. Et je sais que custom smileys est bien plus efficace et fonction correctement avec la version 2.1 !

    Si tu veux voir, faire un tour sur mon blog !

    Oo

    #591759
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Merci ca fonctionne mais j’ai un petit problème …

    2uae8sfg.png

    J’ai mis un total de 13 Smileys; sur la ligne les deux permiers fonctionne et les autres pas du tout …
    Soit il affiche le code du smiley, soit il affiche complètement rien …

    #591757
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Bonjour DOtWoot,

    Tu as bien ajouter le CSS ?

    Oo

    #591760
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Oui j’ai mis dans le style.css

    .wp-smiley {
    border: 0pt none;
    margin: 0px;
    padding: 0px;
    vertical-align: middle;
    }

    Est ce que cela pourrai venir du fichier vars.php ?

    #591761
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Bonjour DotWoot,

    Sachant que c’est le fichier que tu modifies, il y a des chances !

    Oo

    #591762
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Beh j’ai seulement modifier les lignes de smilies

    // if the config file does not provide the smilies array, let’s define it here
    if (!isset($wpsmiliestrans)) {
    	$wpsmiliestrans = array(
    	      ‘:D’ => ‘icon_biggrin.png’,
    	      ‘;)’ => ‘icon_wink.png’,
    	      ‘:)’ => ‘icon_smile.png’,
    	      ‘:P’ => ‘icon_razz.png’,
    	      ‘:cool:’ => ‘icon_cool.png’,
    	      ‘:$’ => ‘icon_redface.png’,
    	      ‘:huh:’ => ‘icon_eek.png’,
    	      ‘:/’ => ‘icon_confused.png’,
    	      ‘:cry:’ => ‘icon_cry.png’,
    	      ‘:(‘ => ‘icon_sad.png’,
    	      ‘:|’ => ‘icon_neutral.png’,
    	      ‘:mad:’ => ‘icon_mad.png’,
    	      ‘:*’ => ‘icon_kiss.png’,
    	);
    }

    #591763
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    J’ai trouver ! lol 😋
    Dans /wp-admin/options-writing.php il y a une options qui dit:

    Mise en forme : Convertir les émoticônes comme 🙂 et :-P en images à l’affichage

    Mais quand je coche cette options et que je clique sur Mettre à jour les options
    La boite de message m’affiche Options sauvegardées. mais l’options se décoche automatiquement

    – Ensuite quand je désactive le plugins ; et recoche l’options ca fonctionne !
    Et sur le blog le smiley s’affiche … lol 😕

    – Ou alors j’ai du mal placé les lignes dans comments.php
    Dans cette page il nous disent pas ou les metteres [ http://qad.donationcoders.com/wp/custom-smileys ]

    – Et moi j’ai pas ca [ http://qad.donationcoders.com/wp/wp-content/uploads/2006/07/smileysdbx.png ] lol

    #591764
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Bonsoir DotWoot,

    Alors finalement, tu as pris l’extension Custom Smileys ! :D Pour ma part, le code dans comment.php, je l’ai ajouté juste avant le champ de saisi du commentaire.

    J’ai donc ajouté ceci avant le textarea !

    <!-- Clickable smileys start here -->
    
    <!-- Clickable smileys end here -->

    Ensuite pour avoir les smileys pour écrire un article dans l’administration, il faut que tu ailles dans ton admin sous Option > Custom Smileys et que tu coches la case : Add a docking box to Write page. Cela fera apparaitre la fenetre dans ton editeur d’article.

    Oo

    #591765
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    <form action="/wp-comments-post.php” method=”post” id=”commentform”>

    <a href="/wp-admin/profile.php”>. <a href="/wp-login.php?action=logout” title=””> »

    <input type="text" name="author" id="author" value="” tabindex=”1″ />

    <input type="text" name="email" id="email" value="” tabindex=”2″ />

    <input type="text" name="url" id="url" value="” tabindex=”3″ />


    <?php
    if ( function_exists(csm_comment_form) ) {
    csm_comment_form();
    }
    ?>

    <input name="submit" type="submit" id="submit" tabindex="5" value="” />
    <input type="hidden" name="comment_post_ID" value="” />

    ID); ?>

    Voila mon code dans comments.php; mais quand j’activer le plugins c’est la que ca plante;
    Impossible de cocher l’options [c]Convertir les émoticônes comme 🙂 et :-P en images à l’affichage[/c] avec le plugins activer …

    Peut être que cela vien du fichier ? custom-smileys.php?
    Il n’y a que celui la a mettre dans le dossier wp-content/plugins?

    #591766
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Arf je viens d’essayer de le reinstaller comme il l’a demander …

    1. Unzip custom-smileys.zip and upload to your wordpress directory
    2. A folder named yahoo should be placed under wp-includes/images, while custom-smileys.php is put under wp-content/plugins
    3. Go to your Admin panel and activate Custom Smileys 2.4
    4. Navigate to your smileys’ management page & options page for more information

    1. Dezipper l’archive custom-smileys.zip et uploader dans mon WordPress
    2. Le dossier yahou doit être placer dans wp-includes/images, tandis que custom-smileys.php est mis dans wp-content/plugins
    3. Aller dans votre panneau d’Admin et activer Custom Smileys 2.4.

    Toujours même problème impossible de cocher l’option
    Convertir les émoticônes comme 🙂 et :-P en images à l’affichage

    Et plugin qui plante a l’affichage des smileys avec plugin activer …

    Voila … 😕

    #591767
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Bonsoir,

    Sache que chez moi la case n’est pas coché et tout fonctionne bien !!!

    Après avoir activé l’extension, as tu entré les smileys ? Car il faut configurer le type de smiley [format des images] et ensuite entrer les raccourcis !!!

    Oo

    #591768
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Oui;

    4fsry53q.png

    nor8vgfl.png

    Il y a t-il des tables SQL a installer ou … 😕

    #591769
    DotWoot
    Participant
    Initié WordPress
    40 contributions

    Bon allez je me suis dit pourquoi chercher comme un con et faire chier les modérateurs de WordPress FR! 😋
    Alors j’ai changer bref; j’ai pris Smiley JS Buttons [ http://aranea.zuavra.net/index.php/18/ ]
    Aussi simple; aussi efficace

    C’est bon Oo tu peut mettre [REGLE] 😉

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.