[Résolu] Probleme sur mon header

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #447113
    meandme
    Membre
    Padawan WordPress
    97 contributions

    Bonjour a tous,

    J’ai un petit probleme (rien de tres grave) sur mon site en haut (header) :

    header6zv.png

    (1) – “Billets aléatoires” – les liens ne fonctionnent pas

    Avez vous une idée….. ci dessous mon header de mon theme – Contempt 1.5 by Michael Heilemann (traduit par AmO – merci AmO)

    < !DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


    /images/blue_flower/bg.jpg) repeat-y top center #AAAAAA fixed;”>

       Billets aléatoires :
    < ?
    $post=$wpdb->get_results(“SELECT ID,post_title,guid FROM $wpdb->posts
    WHERE post_status= “publish” ORDER BY RAND() LIMIT 1″);
    $p=$post[0];
    echo (‘guid . ‘”>’ . $p->post_title . ‘‘);
    ?>

    ” title=”RSS .92″>RSS .92| ” title=”RSS 2.0″>RSS 2.0|
    ” title=”ATOM 0.3″>ATOM 0.3

  • < ?php wp_list_pages('title_li='); ?>

#570820
AmO
Participant
Maître WordPress
4452 contributions

Une précision pour les experts…

Le truc c’est que les liens ne fonctionne pas à tout les coups… C’est une histoire de perma liens, mais je vois pas ou ca foire…
^^

#570821
meandme
Membre
Padawan WordPress
97 contributions
AmO wrote:
Une précision pour les experts…

Le truc c’est que les liens ne fonctionne pas à tout les coups… C’est une histoire de perma liens, mais je vois pas ou ca foire…
^^

AmO, j’ai trouvé d’ou viens le probleme mais je ne sais pas le resoudre…. En faite les “billets aléatoires” qui s’affichent et qui ont ete faits apres la mise a jour du theme (la traduction en français que tu a fait) fonctionnent mais pas ceux d’avant…

#570822
AmO
Participant
Maître WordPress
4452 contributions

La traduction n’intervient pas dans la génération des URLs …. 😕

Essai de desactivez les permaliens? et dis moi si cela fonctionne 🙂

#570823
meandme
Membre
Padawan WordPress
97 contributions
AmO wrote:
La traduction n’intervient pas dans la génération des URLs …. 😕

Essai de desactivez les permaliens? et dis moi si cela fonctionne 🙂

Non… ce ne sont pas les permaliens….. en faite c’est un bug de WP…mais ça tu le sais, puisque c’est toi qui a trouvé le Bug… et résolu mon probléme… Merci encore AmO.

Allez champagne !!! Non pas champagne !!! Pourquoi !! Un quoi ! ….. Un forum sans alcool ! Bon bain Orangina alors….

#570824
AmO
Participant
Maître WordPress
4452 contributions

Le code résolvant le probleme

get_results(“SELECT ID,post_title,guid FROM $wpdb->posts
			WHERE post_status= “publish” ORDER BY RAND() LIMIT 1″);
			$p=$post[0];
			echo (‘<a>ID .'”>’ . $p->post_title . ‘</a>‘);			
			?>

A l’origine la requete récupere le guid ^^
mais le probleme , c’est que le guid ne se met à jour lors de l’édition d’un billet, ou d’un changement de permaliens…ce qui provoque des erreurs 404

Donc j’ai adapté pour récupèrer le id 🙂 😉

D’ailleurs ca peut considérer comme un bug… le guid doit etre mis à jour lors d’une édition… ^^

#570818
cisjoc
Participant
Initié WordPress
6 contributions

Salut,
J’ai utilisé le template corporate play pour mon Blog, mais lorsque l’on clique sur le titre du blog, l’on va à la page http://www.dossier avec tous mes sites
alors que mon Blog est http://www.dossier avec tous mes site/mon Blog.
Voici le code du Header, quelle ligne dois-je changer pour rectifier cela.
Merci

<meta http-equiv="Content-Type" content="; charset=” />

<meta name="generator" content="WordPress ” />

@import url( );

<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="” />
<link rel="alternate" type="text/xml" title="RSS .92" href="” />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="” />

<link rel="pingback" href="” />

#570819
damino
Participant
Maître WordPress
1243 contributions

@cisjoc : salut, c’est pas hyper clair ton histoire et comme nous le disons et le redisons sur ce forum, pensez à laisser un lien vers votre blog. C’est plus clair et facile d’identifier et régler un problème.

Enfin (je fais un peu la morale …) merci d’utiliser les balises bbcode pour mettre du code par exemple. Ce sera plus lisible pour nous tous. Merci à toi et aux autres.

#570825
cisjoc
Participant
Initié WordPress
6 contributions

Désolé je suis nouveau et j’ ai pas encore compris comment tout marche. Voilà l’adresse du blog que j’éssaie de faire : http://www.marleylegacy.com/ mais lorsque l’on clique sur le titre du blog, l’on retrouve la page principale de mon serveur, j’aimerais savoir comment l’on peut faire en sorte qu’il revienne à la page home du blog. Voici le code du Header. Merci encore





    <meta http-equiv="Content-Type" content="; charset=” />

    <title></title>
   
    <meta name="generator" content="WordPress ” /> <!-- leave this for stats please -->

    
        @import url(  );
    

    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="” />
    <link rel="alternate" type="text/xml" title="RSS .92" href="” />
    <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="” />
   
    <link rel="pingback" href="” />
    
    
    




<table align="center" id="winpost" cellspacing="0" cellpadding="0">

<tr><td colspan="2">
<div id="header2"><a href="/"></a></div>
<div id="header3"><a href="/"></a></div>
</td></tr>

<tr><td valign="top">

<table class="ssd ssa ssl" cellspacing="0" cellpadding="0"><tr><td>
<br />
<div id="rap">
<div id="content">
<!-- end header -->

#570826
AmO
Participant
Maître WordPress
4452 contributions

Remplace

<div id="header2"><a href="/"></a></div>
<div id="header3"><a href="/"></a></div>

par

<div id="header2"><a href="/”></a></div>
<div id="header3"><a href="/”></a></div>

#570827
cisjoc
Participant
Initié WordPress
6 contributions

Merci beaucoup, ça marche et c’est magique.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.