[Résolu] Problème pour migrer le blog en local -> en ligne

  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #504862
    pipin
    Membre
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.3
    – Version de PHP/MySQL : 5.1.56
    – Thème utilisé : Mystique 2.5
    – Extensions en place : Next Gen Gallery, Pie Register, Contact form…
    – Nom de l’hebergeur : O2switch
    – Adresse du site : edmondarcanson.com

    Problème(s) rencontré(s) :

    J’ai fait le site en local. Tout marche bien. j’ai voulu le mettre en ligne, pour cela j’ai suivi ce tutoriel : http://searchbox.fr/migration-wordpress-local-distant/

    J’ai tout fais, il y a juste le champ “home” que je ne trouve pas (le point n°13 du tuto).

    Voici le message d’erreur que j’ai :

    Not Found

    The requested URL /wp-admin was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Avez-vous un autre tutoriel? il y quelque chose d’autres a faire?…

    Merci d’avance pour le coup de main !

    #812823
    luciole135
    Participant
    Maître WordPress
    13753 contributions
    pipin wrote:
    J’ai tout fais, il y a juste le champ “home” que je ne trouve pas (le point n°13 du tuto).

    Le champs “home” se trouve dans la table wp_options (bien regarder dans toutes les pages de cette table) accessible avec PhpMyAdmin…

    #812824
    pipin
    Membre
    Initié WordPress
    5 contributions

    Merci Luciole 135, j’ai trouver “home” je n’avais pas vu qu’il y avait plusieurs pages.

    Cependant, ça ne marche toujours pas j’ai toujours la même erreur!

    des idées d’où cela peut venir?

    #812825
    luciole135
    Participant
    Maître WordPress
    13753 contributions

    Au point 7 de votre tuto, une fois votre base exportée, il vous faut en plus :
    – ouvrir votre fichier avec notepad++ ou un éditeur de texte et remplacer l’adresse locale http://localhost/wordpress par exemple par l’adresse distante http://edmondarcanson.com – là vous pouvez l’importer sur le distant.

    Puis modifier dans la table options les lignes siteurl et home pour y mettre l’adresse du site distant

    #812826
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Je complète ce qu’explique luciole : il faut effectivement ajouter une étape entre l’exportation et l’importation.
    1/ ouvrir le fichier SQL généré par l’exportation
    2/ faire un rechercher/remplacer complet sur l’ensemble du fichier en remplaçant http://www.source.tld par xxx.destination.zzz (sans http devant)
    3/ importer le fichier ainsi modifié
    (et du coup, pas besoin de modifier en plus la table wp_options, cette manip l’aura déjà fait).

    Et évidemment, ne pas oublier d’aligner (avec un client FTP) le contenu de /wp_content (thèmes, plugins, upload…)

    #812822
    pipin
    Membre
    Initié WordPress
    5 contributions

    c’est bon, merci pour votre aide !

    #812827
    FrereHamley
    Participant
    Initié WordPress
    2 contributions

    Salut,

    Après une après-midi de bataille avec WP et PHPMA, j’ai suivi ce topic et le tuto énoncé au premier post, ainsi que les conseils donnés par “Luciole135” et “Comme Une Image”.

    Ceci fait, j’arrive a un résultat mitigé. J’ai accès tout à fait normalement à l’admin de mon site via “www.monsite.com/wp-admin”, par contre, si j’essaie d’afficher mon site directement avec son URL, le site ne s’affiche pas. Je me doute qu’il doit y avoir un problème d’URL quelque part mais allez savoir où.. J’ai bien exécuté la fonction “Rechercher et Remplacer” pour l’URL, sans le “http”, dans mon fichier “.sql”.

    Je ne vois pas ce qui peut pêcher, j’ai suivi à la lettre toutes les explications. Si vous avez quelques pistes, elles sont les bienvenues,

    Merci et à bientôt 🙂

    #812828
    FrereHamley
    Participant
    Initié WordPress
    2 contributions

    Euh.. je me sens un peu bête car ça marche, après avoir rechargé la page quelque dizaines de fois…

    En tout cas merci à la communauté pour l’aide qu’elle apporte!

    Vraiment merci :D

    #812829
    luciole135
    Participant
    Maître WordPress
    13753 contributions
    FrereHamley wrote:
    Euh.. je me sens un peu bête car ça marche, après avoir rechargé la page quelque dizaines de fois…

    En tout cas merci à la communauté pour l’aide qu’elle apporte!

    Vraiment merci :D

    Vous aviez simplement oublié de vider le cache de votre navigateur, cela m’arrive souvent !

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.