[Résolu] Problème de retour à la ligne

  • Statut : non résolu
  • Ce sujet contient 15 réponses, 6 participants et a été mis à jour pour la dernière fois par z720, le il y a 14 années.
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #446658
    imported_BenKenobi
    Membre
    Padawan WordPress
    93 contributions

    Décidément je rencontre plein de petits problèmes bien embêtant en ce moment. En fait c’est sans soute du plus à mon ignorance dans la programmation…

    Donc, ce soir ce sont les retours à la ligne lors de la rédaction de mes posts de mon blog qui pose problème.
    Je suis obligé de faire 2 fois “entrée” pour faire un retour à la ligne… seulement ce n’est plus un retour un la ligne mais un saut de paragraphe qui se créé de ce fait.

    Si je ne fait qu’une fois entrée comme il le faudrait lorsque je publie le post le retour à la ligne n’apparait pas.
    Le plus louche c’est que parfois cela fonctionne correctement et d’autres fois non… je ne comprends plus rien.

    J’ai regardé le code et a priori cela vient des balises

    mais comment faire pour qu’elles ne viennent pas me mettre ma présentation en l’air ? en effet, dans le formulaire de rédaction de post je ne pas les controler directement ces balises…

    Merci de vos conseils… 🙂

    Exemple : Dans le premier paragraphe du post :
    Y aurait-il un poids deux mesures en matière de justice face aux affaires de piratages informatique en France ? Deux affaires récentes peuvent le laisser croire :

    Normalement la 2e phrase devrait être à la ligne (c’est en tout cas ainsi qu’elle est saisie dans le formulaire de rédaction), or elle est à la suite de la première phrase…

    #567403
    gP
    Participant
    Chevalier WordPress
    358 contributions
    BenKenobi wrote:
    Exemple : Dans le premier paragraphe du post :
    Y aurait-il un poids deux mesures en matière de justice face aux affaires de piratages informatique en France ? Deux affaires récentes peuvent le laisser croire :

    Normalement la 2e phrase devrait être à la ligne (c’est en tout cas ainsi qu’elle est saisie dans le formulaire de rédaction), or elle est à la suite de la première phrase…

    Rajoute un
    . 😐

    #567404
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Oui effectivement ça marche.
    Mais c’est tout de même pas pratique de rajouter des
    à chaque fois qu’on veux faire un retour à la ligne dans un article…

    #567405
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Voui, spa normal…

    #567406
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    N’y aurait-il un paramètre du CSS à modifier au niveau des paragraphes… ?

    Je vais essayer de jeter un oeil… au cas où. 😉

    Edit : Après un tour vite fait dans le CSS je n’ai rien repréré à propos des paragraphes…

    #567407
    damino
    Participant
    Maître WordPress
    1243 contributions
    gP wrote:
    Rajoute un
    . 😐

    Si l’on veut respecter le XHTML ce serait plutôt

    Voilà c’est juste pour être pinailleur !

    Ceci dit j’ajoute que selon le navigateur, le retour à la ligne appliqué dans la rédaction d’un article n’est pas interprété de la même façon … il me semble.

    #567408
    gP
    Participant
    Chevalier WordPress
    358 contributions
    Damino wrote:
    gP wrote:
    Rajoute un
    . 😐

    Si l’on veut respecter le XHTML ce serait plutôt

    Voilà c’est juste pour être pinailleur !

    WP, le fait “totomatiquement” à l’enregistrement, mais tu as “farpaitement” raison.
    C’est bien d’être pinailleur. :D

    #567409
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Et de toute façon j’avais corrigé tout seul. 🙂

    Mais je le redis c’est rudement pas pratique !!

    #567410
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Ces maudits retour à la ligne commencent à m’énerver. :(
    C’est pas évident… même avec les

    Je suis en train de me prendre la tête sur la mise en page d’un simple article… entre les différents paragraphes, des listes à puces, des passages en italiques… c’est prises de tête assurée !
    Je suis obligé de mettre des
    partout et merci la galère avec mes listes à puces et autres retraits de paragraphes…

    Comment cela se fait-il que les simples retour à la ligne avec entrée ne soit pas pris en compte ?

    Exemple : Pour écrire cet article –> voici le code utilisé :

    Suite à une question que j’ai posé sur les newsgroup de Free concernant l’éventuel dégroupage de l’Indre et surtout de Châteauroux par <a href="http://www.free.fr">Free</a>, Alexandre Archambault (Responsable des Affaires Règlemenaires de Free) m’a répondu que celui-ci interviendrait probablement vers la fin 2006, si tout va bien. <strong>
    
    Voici donc les dernières informations officielles</strong> :
    <!--more--><blockquote>
    <strong>Benoît CATHERINEAU 2005/11/15 16:58</strong>
    <br />Bonjour habitant dans l’Indre à Châteauroux, je me demandais si le dégroupage par Free était prévu pour bientôt ?
    La carte présente sur le site de Free reste désespérément vierge pour notre département… y a-t-il des prévisions à moyen terme, un calendrier établi ?
    J’ai entendu des rumeurs parlant de 2006 mais ne voyant aucune indication officielle sur le site je doute de la véracité de ces dires… qu’en est-il officiellement ?
    <br />
    <br /><strong>Alexandre Archambault 2005/11/15 18:33</strong>
    <br />Le dégroupage de Chateauroux, et d’une manière générale de toutes les villes à potentiel non encore dégroupées, sera à l’ordre du jour le jour où des infrastructures alternatives de raccordement existeront à des conditions compatibles avec une offre grand public à 30 euros.
    <br />
    <br /><strong>Benoît CATHERINEAU 2005/11/15 20:38</strong>
    <br />[…] Qu’entendez-vous, Monsieur Archambault, par “<em>infrastructures alternatives de raccordement existeront à des conditions compatibles avec une offre grand public à 30 euros</em>“. Qui a la charge de ces dites infrastructures alternatives ? FT, Free, les collectivités locales… d’autres organismes…? Quelles sont ces conditions selon vous ?
    Je vous remercie d’avance de ces quelques éclaircissements.
    <br />
    <br /><strong>Alexandre Archambault 2005/11/17 14:52</strong>
    	<li><em>[…] Qu’entendez-vous, Monsieur Archambault, par “infrastructures alternatives de raccordement existeront à des conditions compatibles avec une offre grand public à 30 euros</em>“</li>
    En clair, de la fibre noire illuminée par Free mise à dispo dans des conditions financières non délirantes, et non de simples offres de transmission dont l’experience a montré qu’à terme cela revient à créer plus de problèmes que cela n’en résoud.
    <br />
    	<br /><li><em>Qui a la charge de ces dites infrastructures alternatives ? FT, Free, les collectivités locales… d’autres organismes…?</em></li>
    Sur cet aspect, Free n’a pas de religion sur le propriétaire de la fibre : cela peut être aussi bien elle-même si les conditions s’y prettent, qu’un autre opérateur (y compris FT, mais FT n’est pas vraiment pro-active en la matière), ou un pool d’opérateurs, ou une collectivité locale…
    <br />
    	<br /><li><em>Quelles sont ces conditions selon vous ?</em></li>
    <ul>1 – une dispo de fibre noire (et surtout pas de la simple bande passante)</ul>
    <ul>2 – des tarifs de mise à dispo qui ne remettent pas en cause l’équilibre économique de l’offre</ul>
    <br /><li><em>Je vous remercie d’avance de ces quelques éclaircissements.</em></li>
    Pour revenir à votre question initiale, Chateauroux est inscrite au programme des négos 2006 laissant entrevoir *si tout va bien* (ie c’est une échéance fournie à titre indicatif, donc inutile de prendre cela comme une promesse) un dégroupage à l’horizon fin 2006. Lorsque la visibilité deviendra meilleure, les cartes prévisionnelles du dégroupage seront alors mises à jour en conséquence pour cette zone.
    </blockquote>
    
    <br />Pour consulter le newsgroup en question, <a href="http://webnews.ft-sucks.com/thread-proxad.free.adsl-472438-_degroupage_de_lind.html">c’est ici.</a>
    <br />L’information a été reprise par le site <a href="http://www.freenews.fr/ca.php?itemid=2731">freenews.fr</a>.

    Des
    partout !! Pourtant il me semble qu’il fut un temps où je parvenais simplement à faire un article simplement avec des retours à la ligne normaaux juste en appuyant sur entrée…

    #567411
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Je confirme, c’est bizarre.
    Essaye non pas de réinstaller Windows, mais de re-uploader les fichiers de l’admin.

    #567412
    gP
    Participant
    Chevalier WordPress
    358 contributions
    Xavier wrote:
    Je confirme, c’est bizarre.
    Essaye non pas de réinstaller Windows, mais de re-uploader les fichiers de l’admin.

    :D 😮 😆
    Quoi, je suis méchant ? :rolleyes:

    #567413
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Mea culpa, je voulais dire WordPress, bien sûr 😉

    #567414
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Bon j’ai profité du re-upload des fichiers admin pour carrément faire la mise à jour que je n’avais pas encore fait vers la version 1.5.2 de WP.

    Apparemment le problème à l’air cette fois résolu pour de bon… oon verra avec le temps si cela revient.

    Merci encore à toi Xavier. 😉

    #567415
    z720
    Membre
    Maître WordPress
    579 contributions

    En même temps si tu ne mets pas les UL qui vont avec les LI c’est normal que tu ais des problèmes de mise en page…

    #567416
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Seulement quand je le fais, les puces ne se mettent pas où je le souhaite voire ne se mettent pas du tout.
    Donc je procède de la façon qui me donne l’affichage que je souhaite. 😉

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.