[Résolu] problème de permaliens (Créer un compte)

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #447271
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    Bonjour

    Je tiens d’abord à remercier WordPress et son équipe pour cet outil fabuleux :D

    Alors voilà j’ai un petit soucis j’ai installer wordpress et depuis que j’ai eu la mauvaise idée d’aller dans la partie Options->permaliens plus aucunes de mes pages n’est disponible, page introuvable, il faut alors que j’efface le fichier .htaccess du serveur pour pouvoir liberez mon blog, mais des que je retourne dans l’option permalien c’est reparti pour un tour 😕 et depuis lors les liens catégories du blog méne à une page introuvable, j’ai beau effacer le repertoire wordpress de mon serveur et reinstaller le tout, rien n’y fait.

    Si quelqu’uns pouvais m’aider pour savoir comment faire une réinstallation compléte et propre j’apprécierais énormement.

    Merci

    #571948
    creatix
    Participant
    Chevalier WordPress
    138 contributions

    c’est quoi ton hebergeur moi avec free je n’ai jamais reussi a metre sa :s dommage pourtant free suporte bien les permaliens normalement car l’url rewrited marche pour d’autres trucs

    #571949
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    je suis chez free, et j’ai bien sur activer la base de donnés via le site de free, en faite le blog fonctionnais comme sur des roulettes jusqu’à ce que j’ai eu la mauvaise idée de chipotter à l’option permaliens :(

    #571950
    codfingers
    Participant
    Maître WordPress
    541 contributions

    Pareil ! aussi mieux vaut ne pas toucher à ce truc !
    Il ne semble pas qu’il y ait de solution pour l’instant, le premier qui le saura sera notre Benkanobi… 😉

    #571951
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4073 contributions

    Encore une fois une recherche dans les entrailles de ce forum aurait donné plusieurs réponses. Ce sujet ayant été abordé et résolu de nombreuses fois…

    Chez Free, c’est simple, il suffit d’utiliser cette forme de permaliens : /index.php/…….

    😉

    #571952
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    Merci pour vos interventions mais ce que je veux dire c’est qu’il ne m’est plus possible de faire aucune modifications dans l’option permaliens des que je confirme la modification j’obtiens une page introuvable, la seule solution étant d’effacer le .htaccess pour revenir à la normale, le fait que les boutons catégories mene aussi à une page introuvable viens t-il aussi de là ?

    Ce que je ne comprend pas c’est que même apres une suppresion du repertoire wordpress et une reinstallation le problème est toujours bien present 😕

    #571953
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    Désoler BenKenobi mais si la solution à mon problème se trouve sur le forum j’ai beau chercher sans succes, j’ai pourtant l’habitude d’utiliser la recherche pour eviter de créer des doublons, en faite si quelqu’uns pouvais m’expliquer comment faire une installation « propre » ca m’arrangerais aussi, je n’ai pas de bases de données actuellement vu que je suis occuper à installer le blog en ce moment.

    Merci et desoler encore si mon problème à déjà été resolu mais d’après codfingers je ne suis pas le seul dans ce cas.

    #571954
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4073 contributions

    Comment fais-tu pour utiliser WP si tu n’a pas encore créer ta base de données ?

    Sinon pour les permaliens tu devrais trouver ton bonheur dans cette discussion :
    http://www.wordpress-fr.net/support/viewtopic.php?id=22

    ou d’autres dans les résultats donnés par une recherche avec le mots « permaliens »…

    #571955
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    Excuse moi je me suis mal exprimer par bases de données je voulais parler du contenu du blog, qui là est inexistant pour l’instant, bon ben je ne comprend pas comment utiliser ce /index.php/ ?

    j’ai beau faire n’importe quelle modification ca plante le blog, en faite à la base je ne cherchais même pas à modifier les permaliens lol je m’en fiche, je voudrais juste que le blog fonctionne correctement comme il le faisait avant que je ne touche à cette satané option.

    merci pour ton aide et desoler si j’ai crée un doublon 😕

    #571956
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4073 contributions

    Donc j’essaie de reprendre :
    1. Supression du htaccess dans ton FTP
    2. Remettre la valeur par défaut des permaliens (le champ de saisie doit être vide)
    3. Valider
    4. Normalment tout doit refonctionner.

    Ainsi tu retrouveras les paramètres d’origine et ton blog refonctionnera sans permaliens mais avec les liens d’origine.

    Si tu veux ensuite, il suffit simplement de mettre /index.php/%year/…. pour mettre tes permaliens.

    #571957
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    j’ai suivi à la lettre ton aide, c’est toujours le même resultat, le blog plante quelque soit la modification que j’effectue dans l’option -> permaliens, pire il suffit que je clique sur permalien sans même rien toucher pour que le blog plante des que je clique sur une autre option du menu 😕

    je suis un peu desesperer là :(

    #571958
    AmO
    Participant
    Maître WordPress
    4449 contributions

    Au pire va dans phpmyadmin…
    Sur ta base de données où est installé WordPress

    Va dans wp_option et supprime le contenu du champ : permalink_structure

    Et supprime le cache ensuite !

    #571959
    Quantumin
    Membre
    Initié WordPress
    7 contributions

    Merci infiniment AmO :D

    Ca refonctionne enfin !!! milles mercis 😉

    PS: on peux considerer mon problème comme résolu 🙂

    #571960
    codfingers
    Participant
    Maître WordPress
    541 contributions

    L’idée de toucher aux permaliens me donne des boutons. brrrr… quelle trouille ! encore les mains pleines de cambouis… berk !:(

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.