[Résolu] Problème de macrons (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #545276
    keio
    Membre
    Initié WordPress
    9 contributions

    Ma configuration WP actuelle

    – Version de WordPress : 4.0.1
    – Version de PHP/MySQL :
    – Thème utilisé : Impreza
    – Extensions en place : Visual Composer, SuperFly Menu, Justified Image Grid, Fast Secure Contact Form, Modal Login, Captcha, Revolution Slider, Share Buttons by AddToAny
    – Nom de l’hebergeur : Digital Oceans
    – Adresse du site : closer-japan.com (le site n’est pas actualisé pour l’instant : je travaille en local avec instant WP)

    Problème(s) rencontré(s) :

    Bonjour,

    Je reposte ici, m’étant trompé d’endroit, mes excuses je ne suis pas familier du wp francophone.

    Comme indiqué dans le titre, je rencontre un problème de macrons sur mon site, mais uniquement à certains endroits. (le macron est un diacritique employé généralement pour écrire avec des accents -entre autre- ce qui est mon cas, puisque devant écrire des noms communs japonais en caractères alphabétiques soit du rōmaji – excellent exemple de macron d’ailleurs, sur le “o”).

    Exemple du problème ici.

    La police d’origine du thème (Noto Sans) est à priori parfaitement adaptée pour l’affichage de tous types de caractères, étant une des Google Font les plus répandues. UTF-8 est naturellement déclaré, donc aucun souci non plus à ce niveau. Le problème ne se produit ni dans mes titres de pages ni dans les contenus texte de mes articles et pages, mais uniquement dans les modules du thème utilisés via Visual Composer (de type iconbox, infobox, etc).

    J’ai évidemment sollicité l’aide du support du thème, mais ils sont long à la détente, et ne m’ont pas fourni de piste valide jusqu’à présent. Après avoir patienté quelques jours, le dev en charge ayant demandé une version du site (je travaille en local sur instant wp) m’a répondu après avoir fait des tests que le problème venait du slider (revolution slider, intégré au thème) et qu’il avait réussi en l’enlevant puis le recréant à régler le problème. Pas d’autres détails. Bien que sceptique, j’ai également tenté cette opération sans succès. En désespoir de cause j’ai même totalement supprimé le slider, mais même sans, le problème demeure.

    Voilà en gros la raison qui me pousse à solliciter l’aide de la communauté francophone WP puisque nous nous y connaissons généralement mieux en accents. =)

    Je vous remercie d’avance pour toute information ou conseil qu’il vous plaira de me donner.

    keio

    #987086
    Lumiere de Lune
    Participant
    Maître WordPress
    19374 contributions
    keio wrote:
    closer-japan.com (le site n’est pas actualisé pour l’instant : je travaille en local avec instant WP)

    Un peu dommage de ne pas pouvoir voir le problème.
    Cela provient sans doute d’un subset de caractères incomplets, les polices ne sont jamais packagées “complètes”, ce serait trop lourd pour rien.

    Tu peux charger ton propre subset ici
    http://www.google.com/fonts#UsePlace:use/Collection:Noto+Sans
    Il te faut sans doute le latin extended et pas le latin

    #987087
    keio
    Membre
    Initié WordPress
    9 contributions

    Merci pour ta réponse rapide ! Malheureusement tout cela est déjà fait… Je ne l’avais pas précisé, mais j’ai évidemment activé l’option latin-ext dans la partie typographie du thème, et j’avais également chargé la font-face adéquate à titre d’essai sans obtenir de meilleur résultat. =(

    #987088
    Lumiere de Lune
    Participant
    Maître WordPress
    19374 contributions

    C’est pour ça qu’il faudrait pouvoir voir…

    #987089
    didier07
    Participant
    Maître WordPress
    1965 contributions

    Visual composer utilise du javascript, peut etre aussi que lui n’aime pas trop ces caractères là 🙂

    #987090
    keio
    Membre
    Initié WordPress
    9 contributions

    Merci à vous deux pour votre aide. =)

    Oui, VC utilise du js mais n’est pas à l’origine du problème puisque titres, slider et articles ne souffraient pas du problème bien que créés eux aussi à l’aide de VC.
    Mais inutile de nous casser davantage la tête sur ce souci, puisque contre toute attente, avec l’aide d’un dev et d’un utilisateur (moi ^^) aussi têtus l’un que l’autre, le problème a été résolu.

    En fait, la raison était une de mes premières suspicions, et pourtant j’avais déjà suivi cette piste, mais n’avais pas réussi à régler le souci. Comme indiqué plus haut, la police intégrée au thème est également celle que j’utilise plus ou moins partout sur le site web, mais ayant bêtement recopié le style.css de mon précédent thème (même site) j’avais laissé la première ligne appelant Noto Sans de Google. En somme, j’avais deux requêtes pour la même police. Le pire c’est que je l’avais remarqué dès mon changement de thème, et effacé cette ligne lors de mes essais de résolution du problème sans observer le moindre changement.

    Lorsque j’ai lu l’email de mon dev auquel était joint un screenshot des différentes requêtes, j’ai remarqué cette ligne à nouveau et instinctivement je me suis dit “bah, re-supprime la quand même cette ligne en trop, même si ça ne règle pas le problème, ça sera plus propre et allègera le temps de chargement de la page” et en faisant mon petit ctrl+shift+r, quelle ne fut pas ma surprise de voir s’afficher mes macrons correctement…

    Morale de l’histoire, ne négligez rien, même si cela semble insignifiant, et lorsque tout bloque, faites un break, aérez-vous, faites autre chose et revenez une fois “zen” au problème pour un nouvel aperçu sous de meilleures perspectives. 😉

    Merci quand même à vous deux !

    keio

    #987091
    Lumiere de Lune
    Participant
    Maître WordPress
    19374 contributions

    Et donc c’était bien un problème de subset de caractères 🙂 🙂

    #987092
    keio
    Membre
    Initié WordPress
    9 contributions

    C’était surtout une grosse prise de tête ! :D J’ai traîné ce problème durant 4 jours, désinstallé, réinstallé, recréé un site test avec un nouveau slider, et que sais-je encore pour cette misérable ligne… grmbl

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.