[Résolu] Problème de BDD

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 20)
  • Auteur
    Messages
  • #448161
    Nooka
    Membre
    Initié WordPress
    7 contributions

    Depuis deux jours, après la rédaction d’un article lorsque je clique sur “Enregistrer” j’ai ce message d’erreur qui s’affiche: :(

    WordPress database error: [Lost connection to MySQL server during query]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES (’39’,’_encloseme’,’1′)

    WordPress database error: [MySQL server has gone away]
    SELECT ID FROM wp_posts WHERE TRIM(to_ping) != ” LIMIT 1

    WordPress database error: [MySQL server has gone away]
    SELECT post_id FROM wp_postmeta WHERE meta_key = ‘_pingme’ OR meta_key = ‘_encloseme’ LIMIT 1

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM wp_posts WHERE ID = ’39’ LIMIT 1

    Warning: Cannot modify header information – headers already sent by (output started at /home.10/xxxxxxx/www/wp-includes/wp-db.php:102) in /home.10/xxxxxx/www/wp-admin/post.php on line 127

    Malgré ce message d’erreur, l’article est pourtant bel et bien enregistré et affiché sur le blog… Je précise que je suis chez OVH.
    Une idée sur ce problème ?

    #577066
    Nooka
    Membre
    Initié WordPress
    7 contributions

    Oups, en faisant une recherche je suis tombé là-dessus: http://www.wordpress-fr.net/support/viewtopic.php?id=1198

    Mais pas d’extension Firefox chez moi qui puisse provoquer un bug…
    J’ai lu aussi que le serveur OVH pouvait être à l’origine du problème, mais pourquoi seulement depuis deux jours alors qu’avant tout fonctionnait très bien ?…

    #577067
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Dès que la base de donnée est un peu remplit… OVH fait ces erreurs… nous aussi on subit sur WP – Fr ^^

    Ca dépend aussi des heures… vive OVH !

    #577068
    Nooka
    Membre
    Initié WordPress
    7 contributions

    J’ai envoyé un mail sur leur hotline, j’attends leur réponse…

    #577069
    Nooka
    Membre
    Initié WordPress
    7 contributions

    Réponse de la hotline:

    Effectivement vous avez tout à fait raison, ce probléme survient lorsqu’il y a trop de connexion ouverte en simultanées.
    Je vous rappel que vous n’avez le droit qu’à 3 connexions simultannées avec votre offre 60gp.
    Le mieux à faire pour régler vos difficultés, serait de passer sur l’offre 90plan ou vous bénéficiez de 10 connexions simultannées. Lorsque vous prenez une offre, et notamment pour un cms, il faut regarder les performances sql c’est très important.

    Au vu du trafic light généré pour le moment par mon tout nouveau blog, je doute un peu des “3 connexions simultanées”, notamment à certaines heures creuses de la journée, et je ne sais pas si le fait de passer à l’offre 90plan résoudrait le problème…

    #577070
    nicoulina
    Participant
    Initié WordPress
    27 contributions

    J’ai exactement le même message d’erreur depuis la migration du serveur 60gp en juillet. Comme vous, je doute que cela soit dû aux connexions simultanées car ma fille, qui a un blog privé (dont elle n’a pas communiqué l’adresse) chez le même hébergeur a la même erreur également. La hotline m’a répondu de “revoir mon code et optimiser la base de données” !
    nicoulina

    #577071
    efelant
    Participant
    Chevalier WordPress
    109 contributions

    Bonjour

    Je confirme que le 60gp ne changera rien, j’ai un 90plan et c’est la galère…normalement j’ai les mêmes messages d’erreurs que vous ci dessus et ce matin, lors de validation du post erreur 500 internal server error…le post a été validé mais bon je commence à avoir un peu peur. Je me demande vraiment ce qu’on pourrait faire de notre côté pour améliorer la compatibilité avec OVH!

    A+

    #577072
    soungalo
    Membre
    Initié WordPress
    9 contributions

    Hello,
    j’ai ce probleme sur un plan 720 d’OVH…
    C’est trés frustrant de voir ses messages d’erreur 1 fois sur 3 …

    J’ai écrit à OVH pour tenter de faire avancer la chose.

    #577073
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Bonsoir à tous,

    Et bien j’ai le même problème et ce, quasiment à chaque fois que j’enregistre un message… J’ai remarqué au début que c’était provoqué en partie par le plugin Autometa. Je l’ai désactivé et j’ai toujours ça:

    WordPress database error: [Lost connection to MySQL server during query]
    SELECT `comment_post_ID` as `post_id`, COUNT(comment_ID) as `comment_count`, comment_approved FROM `wp_comments` GROUP BY `comment_post_ID`

    WordPress database error: [MySQL server has gone away]
    SELECT `ID` ,`post_modified`, `post_date`, `post_status` FROM `wp_posts` WHERE post_status = ‘publish’ OR post_status=’static’ ORDER BY post_modified DESC

    WordPress database error: [MySQL server has gone away]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM `wp_posts` p LEFT JOIN `wp_post2cat` pc ON p.ID = pc.post_id LEFT JOIN `wp_categories` c ON pc.category_id = c.cat_ID WHERE post_status = ‘publish’ GROUP BY cat_ID

    WordPress database error: [MySQL server has gone away]
    SELECT DISTINCT YEAR(post_date) AS `year`, MONTH(post_date) AS `month`, MAX(post_date) as last_mod, count(ID) as posts FROM wp_posts WHERE post_date < '2006-10-27 22:21:37' AND post_status = 'publish' GROUP BY YEAR(post_date), MONTH(post_date) ORDER BY post_date DESC

    WordPress database error: [MySQL server has gone away]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES (’40’,’_pingme’,’1′)

    WordPress database error: [MySQL server has gone away]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES (’40’,’_encloseme’,’1′)

    WordPress database error: [MySQL server has gone away]
    SELECT ID FROM wp_posts WHERE TRIM(to_ping) != ” LIMIT 1

    WordPress database error: [MySQL server has gone away]
    SELECT post_id FROM wp_postmeta WHERE meta_key = ‘_pingme’ OR meta_key = ‘_encloseme’ LIMIT 1

    Warning: Cannot modify header information – headers already sent by (output started at /XXX/XXX/www/wp-includes/wp-db.php:102) in /XXX/XXXX/www/wp-admin/post.php on line 122

    Ca vient également de OVH ? Je suis aussi sur le 60gp… si c’est ça, super….

    #577074
    AmO
    Participant
    Maître WordPress
    4452 contributions

    OVH ^^ C’est pas spécifique au plan, mais à la configuration de leur serveur mUtualisé !

    #577075
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Ce que je trouve bizarre c’est que j’ai installé un blog “backup” sur la même base et que celle-ci ne fait jamais d’erreur… Ca ne vient pas d’autre chose alors ??

    Y-a-t’il un moyen de vérifier la base ?

    #577076
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Pas vraiment, et puis ca dépend également de la charge de serveurs… enfin plein de param ^^

    #577077
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Je suis allé faire du nettoyage dans la base et résultat, je n’ai plus aucun souci depuis de matin… Il y avait pas mal de trucs bizarres et des liens vers l’ancien emplacement de mon blog…😋

    #577078
    Fran6
    Participant
    Chevalier WordPress
    107 contributions

    Le problème est réapparu ce soir chez moi après avoir mis WordPress en 2.0.6.. Visiblement pas de changements dans la Base de Données… Quelqu’un aurait une idée de ce que je pourrais faire ?

    Il semblerait y avoir des soucis sur la base avec wp_tags et wp_post2tags … et puis ça finit avec:

    Warning: Cannot modify header information – headers already sent by (output started at /home.3/xxxx/ssssss/wp-includes/wp-db.php:104) in /home.3/xxxx/ssssssssss/wp-includes/pluggable-functions.php on line 270

    Merci d’avance pour votre aide !

    #577079
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Réupload WP2.0.6, et depuis PhpMyAdmin optimise et répare tes tables.

15 sujets de 1 à 15 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.