[Résolu] Problème d’affichage de minuature sur wordpress 3.6 (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 13 réponses, 5 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 10 années et 8 mois.
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #530227
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    Bonjour,
    Version WordPress : 3.6
    Thème utilisé : Udesign
    Adresse du site : http://www.sofia.gov.mg

    J’ai un souci sur la minuature de site que j’ai crée. Elle n’affiche pas l’image, seuelement une couleur blanche à la blanche à la place. je sais pas comment faire. Merci de votre aide

    #921402
    Flobogo
    Modérateur
    Maître WordPress
    20202 contributions

    Bonjour,

    Votre message devrait être dans la rubrique « support » du forum, vous auriez ainsi eu le petit questionnaire entier à compléter.

    Attendez pour qu’il soit déplacé, et recopiez ci-dessous le questionnaire en le complétant en entier :

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :

    Et ce serait bien de détailler votre souci, car on ne comprend pas de quellle miniature de site vous parlez. (un « screenshot » pour votre thème-enfant, peut-être ?)

    #921403
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    Bon voila,
    Premier temp, j’ai crée le site en local, et tout es nikel. Mais quand j’ai transferé le site en distant, tout à coup les minuatures de l’extrait d’article (comme par exemple « Image à la Une »)n’apparaissent pas, seuelement un petit crois et le nom de l’image, voilà l’URL : http://www.sofia.gov.mg/?cat=16

    #921404
    CAMEO172
    Participant
    Maître WordPress
    1395 contributions

    as tu lu l’erreur quand tu veux ouvrir ton image directement :

    A TimThumb error has occured

    The following error(s) occured:
    Could not create the index.html file – to fix this create an empty file named index.html file in the cache directory.
    Could not create cache clean timestamp file.

    Query String : src=http://www.sofia.gov.mg/wp-content/uploads/2013/09/bazary2.jpg&w=570&h=172&zc=1&q=90
    TimThumb version : 2.8.11

    l’image http://www.sofia.gov.mg/wp-content/uploads/2013/09/bazary2.jpg est bien présente.
    je ne connais pas assez TimThumb pour comprendre le soucis (si ce n’est que je ne vois pas l’intérêt d’avoir un process PHP pour une image à la une… il suffit de mettre la bonne taille à la bonne compression, wordpres gère ça très bien.

    #921405
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    CAMEO172, si tu as cliqué sur le lien, tu trouve bien qu’il n’ y a pas d’aperçue d’image sur la minuature. Or le thème que j’utilise (Udesign) a besoin de cette fonction là (minuature) pour ma présentation de page d’accueil.

    #921406
    Flobogo
    Modérateur
    Maître WordPress
    20202 contributions

    Est-ce que ce n’est pas simplement parce que suite au transfert du site local vers le site distant, les URL des images ne sont plus bonnes ?

    Je vous conseille le tuto de Luciole135, en inversant les notions site local /site en ligne (puisque son tuto sert à faire une copie locale d’un site existant, alors que pour vous, c’est l’inverse)

    Même si vous avez déjà fait le transfert, il vous suffit d’installer le fichier du script saerchreplacedb2.php (point 5 du tuto) sur votre site en ligne pour effectuer le remplacement des URL.

    #921407
    CAMEO172
    Participant
    Maître WordPress
    1395 contributions
    yassergerardain wrote:
    CAMEO172, si tu as cliqué sur le lien, tu trouve bien qu’il n’ y a pas d’aperçue d’image sur la minuature. Or le thème que j’utilise (Udesign) a besoin de cette fonction là (minuature) pour ma présentation de page d’accueil.

    l’erreur t’indique une solution :

    « to fix this create an empty file named index.html file in the cache directory »

    essaye donc de crer un fichier index.html vide dans ton dossier de cache

    #921408
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    Je viens de tester vite fais un autre thème, ça a fonctionné. mais ça marche pas encore sur Udesign. je pense que le probleme vient du thème Udesign.

    #921409
    Li-An
    Participant
    Maître WordPress
    28549 contributions

    L’utilisation de TimThumb dans les thèmes et les plugins est une aberration sans nom qui n’a aucune justification. Si vous savez comment le faire, vous feriez mieux d’adapter le thème avec la gestion de miniatures embarquée de WP.

    #921410
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    Li-An, de viens de me donnée une idée, je vais essayer

    #921411
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #921412
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    Noaneo, merci pour le lien. je vais voir

    #921413
    yassergerardain
    Membre
    Initié WordPress
    11 contributions

    Grand merci Noaneo, le probleme est resolu.
    Le probleme d’affichage de minuature par « script timthumb » est resolu grace à « chmod 777 sur le dossier cache« 

    Bonne contiunation!!!

    #921414
    Anonyme
    Invité
    Maître WordPress
    34070 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.