[Résolu] Pourquoi mes liens n’ont-ils pas tous la même “gueule” ? (Créer un compte)

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #455662
    Archilatrik
    Participant
    Chevalier WordPress
    131 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.5
    – Thème utilisé : Redoable 1.2
    – Plugins en place :
    – Nom de l’hebergeur :
    – Adresse du site : http://www.romaincorraze.com

    Problème(s) rencontré(s) :

    Bonjour à tous,

    J’avais modifié ma feuille de style à une époque pour que tout mes liens soient en rouge et en gras.En vous rendant sur mon site http://www.romaincorraze.com , vous constaterez que dans mes articles, certains liens sont en rouge comme prévu , mais la moitié d’entre eux sont de couleur grise.

    Comment se faisse ? Ou dois-je aller dans ma feuille de style pour rectifier le tir ? Je n’ai même pas réussi a retrouver ou j’avais modifié cela…

    Merci d’avance. Je peux vous envoyer ma feuille de style.css si vous le souhaitez.

    #615767
    Pierre S.
    Membre
    Chevalier WordPress
    107 contributions

    Bonjour Archilatrik,
    tu as deux définitions dans ta feuille de style qui provoques ce comportement…

    ligne 1177
    .entry-content a {
    font-weight: bold;
    text-decoration: none;
    color: #e94545;
    }
    et ligne 1181
    .entry-content a:visited {
    color: #cccccc;
    }

    donc il te suffit de supprimer la ligne 1181 et d’écrire ceci :

    .entry-content a, .entry-content a:visited {
    font-weight: bold;
    text-decoration: none;
    color: #e94545;
    }

    😉

    #615768
    Archilatrik
    Participant
    Chevalier WordPress
    131 contributions

    Merci de ta réponse Pierre.

    Malheureusement, cela doit venir d’ailleurs puisque la modification n’a rien changé…

    #615769
    Archilatrik
    Participant
    Chevalier WordPress
    131 contributions

    Je précise que je souhaite uniquement faire apparaitre les liens en rouge pour ceux inclus dans les articles et uniquement les articles.

    #615770
    Pierre S.
    Membre
    Chevalier WordPress
    107 contributions

    c’est ce que fait le code que je t’ai fournit 😉 mais tu as une autre feuille de style (style-dynamic.css.php) où il y a :

    h2, #primary .entry-content h2, #primaryFirst .entry-content h2, h2, h2 a, h2 a:visited, h2, h2 a, h2 a:hover, h2 a:visited,
    .first .entry-meta, .entry-meta, .page-meta, .sidenote h2, a, .secondary h2, .tertiary h2, .first .entry-meta h2,
    .entry-content a:visited, blockquote, #comment-block h2, #wp-calendar caption, .first .relatedPosts, .first .relatedPosts h2 { color: #cccccc; }

    donc il faudrait enlever l’occurence .entry-content a:visited …
    PS Je serais à ta place j’allègerai beaucoup mes feuilles de style parce que j’en ai déjà vu beaucoup mais pas encore comme les tiennes 😉

    #615771
    Archilatrik
    Participant
    Chevalier WordPress
    131 contributions

    C’est super !

    Un énorme merci, j’étais à la recherche de la faille depuis longtemps !

    Je prend note de tes conseils, mais je suis encore novice en matière de programmation, je vais me renseigner commet allèger ces feuilles de style…😉

    Merci encore.

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.