[Résolu] Poedit et chaine “%s” (Créer un compte)

  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #503443
    Akhlan
    Participant
    Initié WordPress
    28 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.2.1
    – Version de PHP/MySQL : 5
    – Thème utilisé : Twenty Ten
    – Extensions en place :
    – Nom de l’hebergeur : 1&1
    – Adresse du site : http://s150525350.onlinehome.fr/akhlan_psm/

    Problème(s) rencontré(s) :

    Voilà, j’ai un soucis sous Poedit et la chaine de caractère “%s”

    voici le texte issu du php:

    This text file can be used to restore your settings here on “%s”, or to easily setup another website with the same settings”. <-- le guillemet est bien présent...

    voici mon fichier fr-FR.po

    msgid “This text file can be used to restore your settings here on "%s", or to easily setup another website with the same settings".”
    msgstr “Ce fichier json pourra être utilisé pour restaurer vos paramètres sur "%s" ou alors il pourra être utilisé pour configurer facilement un autre site avec les mêmes paramètres.”

    En laissant les guillemets, poedit m’indique une erreur à ces emplacements, en changeant les guillemets par ", Poedit accepte de sauvegarder sans erreur mais du coup, quand je retourne sur mon site, la chaine “This text file can be used to restore your settings here on "%s", or……” n’existant pas, le texte reste en Anglais…

    J’ai le même soucis avec la chaine d par exemple…

    Il y a une astuce que je n’ai pas trouvé ?

    Merci
    Akhlan

    #807020
    tabris
    Membre
    Chevalier WordPress
    181 contributions

    tu as essayé d’échapper les guillemets avec un ?

    #807021
    Akhlan
    Participant
    Initié WordPress
    28 contributions

    pffffffffffff, j’ai pas pensé au plus simple, merci tabris, ça fonctionne nickel 😉

    Donc pour ceux que ça intéresse, pour poedit, il faut mettre au lieu de

    et secondo, un texte originale “setting type you’d like to backup” passe sans erreur si on vire l’antislash “setting type you’d like to backup” sous poedit et aucun soucis pour ma part sur la page en ligne

    Encore merci
    Akhlan

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.