[Résolu] podpress : bouton “add media” inactifs (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #449622
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.5
    – Thème utilisé :
    – Plugins en place :
    – Nom de l’hebergeur : dédié

    Problème(s) rencontré(s) :

    Est ce que quelqu’un sait pourquoi Podpress ne tourne que sur une install fraiche de WP ?
    Dès que j’essaye de l’installer sur un WP qui a “déjà” utilisé un podpress (après effacement sauvage des fichiers par FTP, sans utiliser l’upgrade) alors le Javascript du bouton “Add Media” dans la zone écrire ne veut pas jouer.

    Les infos sont bien générées sous une DIV “display:none” mais le bouton ne transforme pas ce “display none”.

    Si par contre je fais une install neuve de WP et une install neuve de Podpress ça roule.

    Par contre j’ai installé un WP “B” en copiant les fichiers à paritr d’un WP “A” et quand j’ai installé podpress sur le WP “B” je me suis aperçu qu’il récupérait des données propres au WP “A” (url par défaut de stockages des fichiers).

    Savez vous si Podpress génère un fichier config quelquepart ? Si c le cas ce serait sans doute la cause du pb et il me faudrait effacer ce fichier de config. Mais ce fichier ne peu pas être dans le dossier “podpress” des plugins puisque je l’écrase.

    Bref… si quelqu’un a une remontée d’expérience à me faire c ‘est cool

    ++
    m

    #586068
    quentin
    Membre
    Chevalier WordPress
    315 contributions

    surement pas un fichier de config, mais surement des options dans la tables d’options (voir discussion sur le codage de wp 😉 ).
    Regarde la table d’options et purge tout ce qui a l’air lié a podpress.

    #586069
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    tables purgées mais problème constant malheureusement.
    Je penche pour une cuase Javascript.
    En cliquant sur le bouton mon module Java me donne “PodpressAddMediafile not defined”.
    Je pense que le Javascirpt n’est pas ajouté/appelé pour cette fonction pour une raison quelqconque…
    Je vais tester

    #586070
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    Aïe, non, j’ai comparé les sources de 2 pages une avec podpress ok et une avec podpress bug et les deux appellent correctment les “.js”.
    Obscur…
    Any thought ?

    #586071
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    Bon, ok, c’est bien le javascript qui colle.
    Sur toutes les actions java aucune des fonctions n’est définie.
    Je suis sur la bonne piste mais c étrange parce que les fichiersd .js sont bien appelés avec le chemin correct et les ficheirs .js sont “out of the box”..
    une idée quelqu’un ? je suis pas le meilleur en javascript ? une action non définie, qu’est ce que ça veut dire ?

    #586072
    quentin
    Membre
    Chevalier WordPress
    315 contributions

    tu as forcé le rafraichissement de la page n’est ce pas ?
    si tu ouvres dans firefox tu vois quoi comme trace dans l’error log ?

    #586073
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    AH AH
    Quand je vais chercher le fichier “.js” directement avec son url le serveur refuse de me le donner et me renvoit une “internal server error”

    Je brûle !

    (j’adore les petits débuggage où je me parle seul sur le forum)

    #586074
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    ah, non, quentin est toujours là, merci

    #586075
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    oui mais alors pourquoi refuse t’il de me serveir ce ficheir .js ??

    Confirmation :! sur le blog ou podpress marche je peux accèder au fichier javascript directement avec l’url.

    Reste à savoir pourquoi j’ai un internakl server error quand j’appelle ce fichier (parce que je suis sur OVH ?)

    Quelqu’un a bien Podpress qui tourne sur un compte mutualisé OVH quand même ?
    Et de toute façon si j’appelle mes .css je peux appeller mais .js ? non ? Y’a restriction sur les fichier squi peuvent ou non être appelés ?

    #586076
    quentin
    Membre
    Chevalier WordPress
    315 contributions

    tu as acces a l’error_log ? les 500 y sont tracées.

    #586077
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    l’error log du serveur ? non je suis sur un mutualisé
    mais je suis sur que lepb vient du fait que je ne peux appeller le fichier avec “src”
    firebug confirme le pb de non défintion des fonctions Javascript

    firefox garde un log d’erreurs ? tu peux me dire où ?

    #586078
    quentin
    Membre
    Chevalier WordPress
    315 contributions

    en anglais Tools > Error console. Suis pas sur en francais mais tu devrais pouvoir trouver 😉.
    Sinon je pense pas que le src fasse un problème sur le serveur.
    En général les 500, c’est des erreurs de droits (chmod), htaccess (rewrite foireux), ou des trucs vraiment plus compliqués. Je vois assez mal ce que ca pourrait etre sur un js…

    #586079
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    Résolu : Problème de CHMOD sur les dossiers/fichiers

    Chez OVH, si pb d’error 500 :

    Les dossiers CHMOD à 705 max
    Les fichiers CHMOD à 755 max

    #586080
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    Merci quentin d’^tre resté présent à mes côtés dans ce moment difficile.
    Et, effectivement c t le CHMOD le coupable. Il sera châtié

    #586081
    matthieu
    Membre
    Chevalier WordPress
    296 contributions

    en anglais Tools > Error console. Suis pas sur en francais mais tu devrais pouvoir trouver wink.

    Aaaah, oui , celle là je connais je croyais que ct la console Java
    Mais j’ai découvert firebug qui marche du tonnerre du coup, plus di’nfos dispo

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.