[Résolu] permaliens dans une utilisation CMS de wordpress (Créer un compte)

  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #452089
    voodoo
    Membre
    Initié WordPress
    24 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1.2
    – Thème utilisé : perso d’après andréas
    – Plugins en place : Add Meta Tags, Akismet, Contact Form ][
    – Nom de l’hebergeur : ovh
    – Adresse du site : http://www.josiebernicot.fr

    Problème(s) rencontré(s) :

    Voilà un site tout simple universitaire que je suis en train de développer (pas encore de contenu), ma structure est valide, l’accessibilité aussi et tout à l’air de fonctionner correctement(pas le temps de tester sous mac), et maintenant, je suis face aux problèmes DES PERMALIENS :search: pour une utlisation dans DES PAGES et améliorer ainsi le référencement.
    Malheureusement mes talents de codeurs à 2 doigts :boulet: et à demi-cerveau me font défaut pour afficher l’adresse de mon choix dans le navigateur.

    Quand j’utilise Options> Permaliens, un fichier ht.access se crée bien mais rien ne se passe dans le navigateur et quand j’essaye le champ personnalisés, là j’ai même pas de fichier ht.access qui se crée (totu en sachant que j’ai bien fait les manips comme il est dit dans les discussions précédentes de Ben Kenobi ), et rien…:cool:
    mais chiant et énervant au bout d’un moment!

    Etant novice + ou -, est-ce que quelqu’un aurait un lien vers une discussion, ou une doc. (même en anglais) pour mettre des permaliens sur des pages (et pas des articles), merci.

    #600349
    voodoo
    Membre
    Initié WordPress
    24 contributions

    ✅:boulet: resolu ! :boulet:✅

    simplement une faute d’inatention quand j’avais preparé mon thème:

    j’avais coupé la boucle du titre du content pour les pages, n’en voyant pas l’utilité, qui à l’origine est du style:

    <h2><a href="” rel=”bookmark” title=”Lien permanent vers “></a></h2>

    pour à la place:

    <h2></h2>

    qui permet d’appeler seulement le titre sans avoir de liens dessus mais evidemment , les permaliens ne marchent plus, une belle erreur de débutant, donc novices et apprentis-destructeurs de boucles php comme, moi, ne touchez pas à cette boucle dans votre modèle de page et vérifiez qu’elle ressemble à ça:

    <h2><a href="” rel=”bookmark” title=”Lien permanent vers “></a></h2>

    ensuite dans les pages, aller dans le panneau latéral à côté du champ de saisie de texte dans la petite interface nommé”page slug” ou “identifiant de la page” selon les versions, taper le nom que vous voulez donnez à votre permalien (nom qui apparaitra à la suite de votre adresse type: http://www.monsite/mapage/), faîtes le pour toutes les pages.
    ensuite dans Options>Permaliens, saisir champ personnalisé et entrer:

    /%postname%/

    le fichier ht.access se crée à la racine de votre site et normalement vos permaliens marchent (sauf chez free voir le tuto de Ben Kenobi pour comment faire)

    et bien merci quand même et en espérant que cette explication aidera les débutants comme moi.:boulet:✅

2 sujets de 1 à 2 (sur un total de 2)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.