[Résolu] Pas de mail de confirmation à l’inscription (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 41 réponses, 5 participants et a été mis à jour pour la dernière fois par Li-An, le il y a 2 semaines.
12 sujets de 31 à 42 (sur un total de 42)
  • Auteur
    Messages
  • #1022393
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Voici quelques nouvelles et la réponse de l’hébergeur :
    « En fait, j’ai la réponse à votre soucis. Je viens de m’inscrire et de regarder les logs de mail sur le serveur et il s’avère que lors de l’inscription, seul un email vers votre boite est envoyé. Aucun email vers l’utilisateur ne tente d’être envoyé.
    Ca semble donc venir du fonctionnement de wordpress directement et non d’un soucis antispam comme je le pensais à la base.. En gros, il n’y à aucun appel à un envoi de mail lors de la validation d’inscription sur votre site, d’ou le fait que l’utilisateur ne reçoit rien. « 

    Je ne mets pas sa parole en doute (loin de là) mais là, c’est tout de même bizarre car même avec une installation sans aucune modification, cela ne veut pas fonctionner…

    #1022394
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Et donc, les gars de EvxOnline, ils découvrent un énorme bug dans WP – genre qui va planter la plupart des sites de commerce ou de membres et qui va générer 3 millions de messages sur le Web – et ils trouvent ça normal.
    Je viens de tester et ça marche sur mon WP de test avec mon hébergeur. Demandez leur d’installer un WP eux-mêmes et de tester. Et quittez les parce qu’on commence à entrer dans l’incompétence, là.

    #1022395
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Mon propre site (celui dont je parle dans ce sujet est un que je gère pour un ami) ne connaît pas ce souci d’inscription. J’en ai fait le test aussi justement. Et je suis également chez Evx.
    J’ai aussi regardé le htaccess, le wp-config mais rien qui me semble anormal. J’ai encore changé tous les fichiers sauf ceux de wp-content et wp-plugins mais toujours rien.

    #1022396
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Je crois qu’on est arrivé au bout du truc. J’ignore ce qui bloque.

    #1022397
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Bonjour

    Evx a trouvé l’erreur. En fait cela venait du plugin simple:press. En le désactivant et en déplaçant le dossier contenant les fichiers, on reçoit le mail de confirmation.
    Pour citer Nathan de Evx : « ce plugin re-écrit la fonction wp_new_user_notification() de WordPress permettant la notification d’un utilisateur et l’envoi d’un email d’inscription. »
    A ce niveau, le problème est résolu sauf que j’ai besoin de ce forum. Y a t-il une solution ? Ou bien je vais devoir désinstaller simple:press ?

    #1022398
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Ce qui est étonnant c’est que le problème ait lieu alors que le plugin est désactivé.

    La seule solution c’est de demander à Simple:Press de corriger la fonction – mais le support est payant. Il ne faut pas rêver, nous n’allons pas corriger un plugin de cette complexité ici.

    #1022399
    domifo
    Participant
    Padawan WordPress
    87 contributions

    je viens d’essayer de m’inscrire sur votre site et n’ai pas (encore) reçu de confirmation

    je me permets de squatter votre discussion car je suis aussi à la recherche d’un plugin de personnalisation du login WP – je vois que vous utiliser « user login logo » – en êtes-vous satisfait ? il est signalé comme n’étant pas compatible avec la toute dernière version actuelle de WP (mais bien avec la 4.3.0) donc j’hésite un peu – j’ai choisi USER LOGIN mais je ne suis pas satisfait à 100% – merci pour votre avis éclairé sur la question

    #1022400
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions
    Li-An wrote:
    Ce qui est étonnant c’est que le problème ait lieu alors que le plugin est désactivé.

    La seule solution c’est de demander à Simple:Press de corriger la fonction – mais le support est payant. Il ne faut pas rêver, nous n’allons pas corriger un plugin de cette complexité ici.

    Pas réveillé ce matin Li-An ? 😉
    C’est le contraire. Le mail est envoyé lorsque le plugin est désactivé (bizarre que ça fonctionne sur ce point alors que j’avais essayé avec tous les plugins désactivés et ça ne voulait pas quand-même; est-ce du au cache serveur ?).
    A mon grand regret, je vais désinstaller simple:press, nettoyer la BDD et installer bbpress. J’ai vu sur votre site qu’en plus, vous disiez qu’il était plus simple à gérer.
    Merci beaucoup de la patience et de l’aide apportée.

    domifo wrote:
    je viens d’essayer de m’inscrire sur votre site et n’ai pas (encore) reçu de confirmation

    je me permets de squatter votre discussion car je suis aussi à la recherche d’un plugin de personnalisation du login WP – je vois que vous utiliser « user login logo » – en êtes-vous satisfait ? il est signalé comme n’étant pas compatible avec la toute dernière version actuelle de WP (mais bien avec la 4.3.0) donc j’hésite un peu – j’ai choisi USER LOGIN mais je ne suis pas satisfait à 100% – merci pour votre avis éclairé sur la question

    Oui car j’ai laissé le plugin activé. Pour user login logo, très simple d’utilisation et pas de problème.

    #1022401
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    J’avais bien compris pour le plugin désactivé mais comme vous avez rajouté qu’il avait fallut déplacer les fichiers pour que ça fonctionne. Bon, je mets comme résolu si vous êtes d’accord.

    #1022402
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Le problème étant que les mails de confirmation n’arrivaient pas et que la solution venait de la désactivation de simple:press, oui, on peut mettre résolu.
    Je vais aller voir du côté de bbpress maintenant.

    #2475700
    Marie61
    Participant
    Initié WordPress
    18 contributions

     

    Moi aussi j’ai le même problème.  Hébergeur Infomaniak et site https/marie-liehn-auteur.fr

    Mes newsletters fonctionnent.

    Merci

    #2475704
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    @Marie61 : merci de ne pas déterrer un vieux sujet résolu. Ouvrez votre propre sujet et remplissez le formulaire de demande d’aide. Merci d’avance pour votre compréhension.

    • Cette réponse a été modifiée le il y a 1 semaine et 3 jours par Flobogo. Raison: ajout du lien
12 sujets de 31 à 42 (sur un total de 42)
  • Le sujet ‘[Résolu] Pas de mail de confirmation à l’inscription’ est fermé à de nouvelles réponses.