[Résolu] Pas de mail de confirmation à l’inscription (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 41 réponses, 5 participants et a été mis à jour pour la dernière fois par Li-An, le il y a 2 semaines.
15 sujets de 1 à 15 (sur un total de 42)
  • Auteur
    Messages
  • #554537
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    – Version de WordPress : 4.3
    – Thème utilisé : BresponZive Pro
    – Plugins en place : Akismet, Contact Form 7, Cookie Notice, Simple:Press, User Login Logo, WPeCommerce, Yoast SEO
    – Adresse du site : http://revivalgames.org/

    Bonjour

    Comme le titre le signale, les personnes qui veulent s’inscrire ne reçoivent pas de mail de confirmation. Pour voir si un plugin en était la cause, je les ai tous désactivés et j’ai tenté de me créer un compte (avec une seconde adresse mail valide que je possède). L’inscription se fait, elle est prise en compte aussi bien dans la partie utilisateurs du dashboard que dans la base de données mais pas de réception de mail (même dans la partie spam). J’ai tenté aussi de voir si cela pouvait venir d’un réglage du forum, des paramètres généraux de WordPress mais tout me semble normal.
    Si vous avez une solution, je vous en serez reconnaissant ^^ Merci

    #1022364
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Il faut aussi mettre un thème par défaut en même temps que désactiver les plugins – ça peut venir du thème.

    #1022365
    damienb
    Participant
    Chevalier WordPress
    223 contributions

    Bonjour,

    est-ce que l’envoi de formulaire fonctionne ? Juste pour vérifier que ce n’est pas un pb de smtp (installation locale ?)

    #1022366
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Bonjour damienb
    Entre temps, j’ai installé un plugin de newsletter (MailPoet Newsletters). J’ai voulu faire un envoi test et je n’ai rien reçu.
    Par contre j’ai tenté de m’envoyer un mail via contactform 7. Avant cela, j’ai modifié l’adresse de contact (qui est en free) et j’ai mis la mienne (qui est en hotmail). Et ça marche.

    Bonjour Li-An
    J’ai tenté en mettant le thème par défaut et en désactivant tous les plugins mais sans résultat.

    #1022367
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    On va faire du basique:
    allez sur le phpMyAdmin de votre hébergeur et réparez optimisez la base de données.
    Renvoyez par FTP tous les fichiers de WP en écrasant ceux présents – vous ne perdrez pas vos données.

    Le problème c’est que si ça marche avec Contact Form 7, il n’y a aucune raison que ça ne marche pas avec les trucs basiques.
    Créez un utilisateur et regardez si vous recevez un mail de confirmation.

    #1022368
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Bah, vous avez testé, je suis idiot.

    Installez ça http://www.echodesplugins.li-an.fr/plugins/wp-mail-logging/ et regardez si les mails partent bien.

    #1022369
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Avant poster cette demande, j’avais fait une réparation suivie d’une optimisation de la BDD ^^
    Je suis d’accord que si contactform fonctionne, les autres devraient aussi. D’ailleurs, les mails générés suites à des inscriptions (ceux que le webmaster reçoit quand une personne s’enregistre) arrivent bien. Et c’est là la bizarrerie.
    Sinon, j’ai installé le plugin et envoyé dans la foulée un mail. Il est bien parti.

    #1022370
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    C’est la journée des trucs bizarres.
    Renvoyez les fichiers par FTP c’est tout ce que je peux conseiller.

    #1022371
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    J’ai remplacé tous les fichiers de wp-admin, wp-includes et ceux à la racine. Après cela, j’ai mis un thème par défaut (twentyfifteen) et désactivé tous les plugins. Malheureusement, le problème persiste… 😕

    #1022372
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Je sèche. Vous nous avez pas précisé l’hébergeur.

    #1022373
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    EvxOnline. J’ai vérifié si la fonction mail était activé et c’est le cas. Donc, a priori, je peux oublier la piste de l’hébergeur.
    Petite question. Dans Réglages > Général à la ligne Adresse de messagerie, c’est une adresse en Free. Normalement, ça ne devrait pas poser de souci étant donné que le formulaire de contact envoie à cette même adresse.

    #1022374
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Mettez une adresse comportant le nom de domaine utilisé. Ça plaira mieux aux systèmes antispam.

    #1022375
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Quelque fois les filtres antispams de l’hébergeur filtrent les mails sortants.

    #1022376
    Sand_27
    Participant
    Chevalier WordPress
    446 contributions

    Des petites nouvelles.
    Que ce soit la newsletter ou le formulaire, ça fonctionne. Par contre, toujours rien pour les inscriptions. Les nouveaux membres inscrits ne reçoivent pas le mail de confirmation mais par contre, je reçois bien l’avis comme quoi une personne s’est inscrite. A priori, le(s) filtre(s) de l’hébergeur ne semble(nt) pas en cause…

    #1022377
    Li-An
    Participant
    Maître WordPress
    28551 contributions

    Il reste à tester l’installation propre en parallèle et un plugin de SMTP. Je ne sais pas quoi vous dire. Vous avez testé avec des adresses mails différentes pour l’expéditeur ?

15 sujets de 1 à 15 (sur un total de 42)
  • Le sujet ‘[Résolu] Pas de mail de confirmation à l’inscription’ est fermé à de nouvelles réponses.