[Résolu] Modifier les permaliens

  • Statut : non résolu
15 sujets de 31 à 45 (sur un total de 46)
  • Auteur
    Messages
  • #565751
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Tu supprimes le htaccessn tu remets les paramètres par défaut et tu valides.

    #565752
    sofia
    Membre
    Initié WordPress
    6 contributions
    BenKenobi wrote:
    Comme j’avais du commencer cette conversation dans un autre thread, j’ai du oublier d’en raconter la fin ici.
    Donc finalement je suis parvenue à modifier mes permaliens. En fait j’ai simplement effacé mon fichier .htaccess puis j’ai enregistré mes modifications en incluant /index.php/ devant. Cela a eu pour effet de me créer automatiquement un nouveau .htaccess qui fonctionne.

    En fait ce fichier .htaccess, apparait tout seul des que tu modifies les permaliens…

    Sinon oui je suis bien chez Free, et après un message sur leurs newsgroups on m’a certifié que je possédais bien tous les droits nécessaires (avec exemples et preuves à l’appui)… donc depuis quand ce CHMOD serait-il désactivé ?

    Bonjour,

    Meme probleme mais j’ai pas compris comment tu as résolu. Je suis chez free aussi.
    Donc j’ai supprimé le htacces, et j ai la page d’accueil. Seulement, les liens sont foireux. Il faudrait que je remette la config d’origine.Comment?

    puis j’ai enregistré mes modifications en incluant /index.php/ devant

    Que veux tu dire exactement??

    merci

    #565753
    AmO
    Participant
    Maître WordPress
    4452 contributions
    Buck wrote:
    Donc, si vous connaissez un client FTP gratuit sous Mac qui me permet de le voir, je suis preneur, car jusque-là, j’ai essayé Cyberduck & Transmit, mais ils me montrent aucun htaccess.

    Personnellement à part CyberDuck, j’en connais pas…
    Ceci dit si c’est juste pour modifier ton fichier .htaccess, une version d’évaluation devrait faire l’affaire
    => http://www.01net.com/mac/Internet/ftp/index.html

    #565754
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    sofia > Dans ton interface admin dans la partie « permaliens », à l’endroit où tu saisies tes modifications de permaliens, il faut que tu mettes comme expliqué, « index.php » en premier de telle sorte que tes permaliens modifiés ressemblent à : index.php/date/catégorie… (avec la syntaxe adéquate bien sur 😉 )

    pour remettre par défaut les permaliens, suffit, le cas échéant, de supprimer le htaccess, puis de laisser vide le champ de saisie des permaliens et de valider.

    #565755
    sofia
    Membre
    Initié WordPress
    6 contributions

    Je ne comprends pas …ca Marche pas.
    Je supprime bien le fichier .htaccess…mais comme je l’ai dit plus haut, je ne vois que l’index.php..apresquand je click sur un lien camarche plus.

    Sinon des que je vais dans la config (apres avoir supprimé .htaccess), >option>permaliens> je remet l’option par défaut : la premiere :

    Valeur par défaut

    Direct quand je valide j’ai cette page..

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Apache/ProXad [Jan 16 2006 02:44:52] Server at mdecerle.free.fr Port 80

    Je rappel, je suis chez free..apparamment ca joue non?

    merci de ta reponse ben

    #565756
    sofia
    Membre
    Initié WordPress
    6 contributions

    Alors?

    Je comprends âs je en peux rien faire. Je suis bloqué!
    Quel que soit l option que je choisis dans les options des permaliens..des que je valide, j’obtiens internal server erreur 500.

    Pourtant j’ai supprimé .htaccess

    SVP help!

    #565757
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Je suis chez Free aussi, donc je suis sûr que ma démarche fonctionne puisque j’ai moi aussi eu de tels problèmes que je suis parvenu à résoudre.

    Donc j’essaie de reprendre :
    1. Supression du htaccess dans ton FTP
    2. Remettre la valeur par défaut des permaliens (le champ de saisie doit être vide)
    3. Valider
    4. Normalment tout doit refonctionner.

    Je te conseille de toujours conserver ta page d’admin de permalien ouverte… ainsi pour vérifier le fonctionnement ouvre la page du site dans une autre fenetre ou onglet. De cette maniere tu pourras revenir modifier facilement dans ta page de permaliens.

    Si cela ne fonctionne pas c’est étrange car moi ca a fini par marcher…

    #565758
    sofia
    Membre
    Initié WordPress
    6 contributions

    En fait ca marchait pas mais j ai trouvé une autre solution…pour ceux que ca peux interesser.

    Sur le site officiel de wordpress..dans les docs..http://codex.wordpress.org/Using_Permalinks
    Si le serveur de votre hebergeur est apache, ET PAS IIS…c le cas de free

    Il faut changer dans le fichier vars.php (/includes)

    Server Blockage: Your host might have blocked the SERVER_SOFTWARE variable and this will cause WordPress’ .htaccess generation to fail. If you are sure that your server is running Apache, you can force WordPress to believe that your server is running Apache by changing your wp-includes/vars.php file. Follow the steps below to implement these changes.

    1. Open the wp-includes/vars.php file using the built in file editor in your WordPress Admin panel. To navigate to this panel, login to WordPress, click on « Manage », then on « Files », scroll to the bottom and type in wp-includes/vars.php into the text box under the « Other Files » title.
    2. Look for $is_apache = strstr($_SERVER, ‘Apache’) ? 1 : 0;, once you find it replace it with // $is_apache = strstr($_SERVER, ‘Apache’) ? 1 : 0;
    3. Add a new line under // $is_apache = strstr($_SERVER, ‘Apache’) ? 1 : 0; and type in $is_apache = 1

    voila et plus de problemes de mon coté.
    :D

    #565759
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Ma fois même en étant un Freenautes, je suis parvenus à changer mes permaliens sans cette complexe modifications de code…

    #565760
    jb
    Membre
    Initié WordPress
    21 contributions

    Mon serveur ne permet pas l’écriture directe sur mon fichier .htaccess.
    Alors je procède de la sorte:
    Je mets un fichier htaccess dans le répertoire racine de mon blog.
    Je ne lui donne pas les droits d’écriture.
    Dans l’interface d’admin, je modifie les permalinks et valide la modification.
    La page d’interface s’actualise en m’affichant le code censé normallement s’écrire sur le fichier htaccess.
    Je copie-colle ce code sur un autre fichier htaccess que j’ai sur mon PC, que j’uploade sur le serveur à la place de l’autre.

    Là au moins ca marche à tous les coups.

    #565761
    chupito
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    J’essaie depuis une semaine de modifier mes permaliens, sans aucun succes… J’ai essaye la methode /index.php/ en debut de structure des permaliens, le bidouillage de fichier vars.php, les conseils indiques sur le codex wordpress.com, mais rien n’y fait… Mon site est heberge chez Free.

    Si quelqu’un avait une idee, une suggestion, voire une solution, ca m’aiderait bien!

    Merci d’avance…

    #565762
    chupito
    Participant
    Initié WordPress
    2 contributions

    Bon, j’ai finalement reussi a mettre les permaliens sous la forme /index.php/. Cela dit, aucun fichier .htaccess n’a ete cree, est-ce normal???

    Merci

    #565763
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions
    chupito wrote:
    Bon, j’ai finalement reussi a mettre les permaliens sous la forme /index.php/. Cela dit, aucun fichier .htaccess n’a ete cree, est-ce normal???

    Oui. C’est pour ceux qui ne peuvent créer de .htaccess qu’existe la méthode /index.php/.

    #565764
    codfingers
    Participant
    Maître WordPress
    541 contributions

    http://cyberduck.ch/
    il y a même le widget 😉
    cordialement,

    #2243567
    Anonyme
    Inactif
    Initié WordPress
    5 contributions

    je crois que le problème vient de Free (si tu c’est bien Free qui t’héberge)

    En effet Free a désactivé la fonction chmod qui permet de modifier les droits. Donc … point de salut ?
    D’ailleur si tu es sur Free tu le trouve où ton fichier .htaccess ?

15 sujets de 31 à 45 (sur un total de 46)
  • Le sujet ‘[Résolu] Modifier les permaliens’ est fermé à de nouvelles réponses.