[Résolu] Mod. Permaliens => Erreur 500

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #450673
    Hitchhiker
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1
    – Thème utilisé : Defaut
    – Plugins en place : Aucun
    – Nom de l’hebergeur : Free

    Problème(s) rencontré(s) :

    Bonjour,

    Je poste ce sujet car mes recherches sur le forum sont vaines.

    En effet, après une modification des permaliens (qui étaient réglés par défaut) pour la version par date/nom du post, je n’arrive plus à accéder ni à mon blog, ni à son interface d’administration (message : 500 Internal Server Error).

    Je suis un peu inquiet, j’espère que mon blog ne s’est pas envolé!

    * Y’a-t-il un moyen de remettre par défaut les réglages des permaliens en modifiant un fichier sur le serveur?
    * Ou puis-je garder cette configuration par date/nom du post ?

    Merci d’avance

    #592748
    ModoFX
    Membre
    Chevalier WordPress
    363 contributions

    Bonsoir,

    Je suis chez Free, je ne parviens pas à modifier la structure de mes “permaliens”. Toutes modifications entrainant la perte de l’accès au blog et l’affichage d’une erreur 500. Comment faire ?

    Sachez qu’il est entièrement possible de personnaliser ses permaliens sur un blog WordPress hébergé par Free.

    Voici la démarche à suivre en cas de problème :

    1. Vérifier sur votre serveur FTP Free qu’il n’y ait PAS de fichier nommé .htaccess à la racine de votre blog WordPress. Le cas échéant, le supprimer.
    2. Revenir dans votre interface d’administration du blog, rubrique Options/Permaliens.
    3. Vérifier que la structure des permaliens est celle par défaut. Si ce n’est pas le cas, sélectionner la structure par défaut puis valider.
    4. Enfin, indiqué dans la zone “Personnalisé”, la structure de votre choix précédée de /index.php/ comme dans l’exemple suivant : /index.php/%year%/%monthnum%/%day%/%postname%/
    5. Validez.

    Si tout c’est bien passé, vos permaliens personnalisés doivent être opérationnels.

    Comme on n’est pas à l’abri d’une erreur de manipulation et qu’au bout du compte, le blog reste sur une erreur 500… et vous n’avez même plus accès à votre interface d’administration. Voici une démarche pour les plus téméraires d’entre vous, la modification directement dans la base de données.

    1. Allez dans PhpMyAdmin, ouvrez votre base de données puis afficher la table “wp_options”.
    2. Ensuite cherchez l’option “permalink_structure”. Elle se trouve à la ligne 34. Selon le nombre de lignes affichées par page elle peut se trouver vers la fin de la première page ou en début de la deuxième page.
    3. Ensuite cliquez sur “Modifier” et effacez ce qu’il y a d’inscrit. Quand vous avez l’option “structure des permaliens par défault” cochée dans la console admin de WP, cette case est vide.
    4. Enfin faites “Exécuter”.

    Les paramètres par défaut du blog sont de retour.


    Issue de la FAQ de WP Francophone : http://www.wordpress-fr.net/faq/index.php?action=artikel&cat=4&id=6&artlang=fr&highlight=permaliens

    Cordialement,

    #592749
    Hitchhiker
    Participant
    Initié WordPress
    13 contributions

    Rebonsoir.

    Merci de votre réponse en cette heure tardive.

    Malheureusement je n’ai pas de fichier .htaccess à la racine du répertoire de mon blog, et je n’arrive toujours pas à accéder à l’administration.

    De plus, j’ai bel et bien supprimé la configuration dans l’option permalink structure de ma base de données, mais je rencontre toujours l’erreur 500 à chaque connexion à l’interface d’admin ou du site.

    Faut-il rafraichir la base de données ou le navigateur? Ou bien y’a-t-il un bug monumental lol?

    #592750
    Hitchhiker
    Participant
    Initié WordPress
    13 contributions

    ✅ !

    En fait, Transmit (mon client FTP) cachait le fichier .htaccess à la racine. Il m’a suffit de faire apparaître les fichiers cachés dans les options. J’ai également réussi à rendre mes permaliens “pretty” 🍺

    Merci encore. En espérant que cela aidera peut-être quelqu’un dans la même situation.

    Ciao!

    #592751
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Modération :
    Hitchhiker > Je t’invite à lire nos règles… une recherche t’aurait amené à trouver la réponse toi-même.

    🙂

    #592752
    arn0
    Participant
    Initié WordPress
    1 contributions

    Bonsoir à tous..
    Même soucis. J’ai lu la doc http://www.wordpress-fr.net/faq/index.php?action=artikel&cat=4&id=6&artlang=fr
    Mais j’ai trop compris

    Ensuite cliquez sur “Modifier” et effacez ce qu’il y a d’inscrit. Quand vous avez l’option “structure des permaliens par défault” cochée dans la console admin de WP, cette case est vide.

    Du coup, je suis bien bloqué. J’ai modifié la ligne “permalink_structure” (l.34 bien vu)
    “effacez ce qu’il y a d’inscrit” ?? la propriété option_value ?
    Quelqu’un peu me donner la config par défaut de cet enregistrement svp ?

    Pas de .htaccess en vue !

    #592753
    sheme
    Membre
    Padawan WordPress
    60 contributions

    Bonjour à tous

    Je suis chez free et voila mon blog : http://asso.nouvelledonne.free.fr

    Enfin maintenant on voit plus rien parce que bien sur j’ai voulu changer les permaliens (j’avais pas lu la faq).

    J’ai acces à l’admin après avoir supprimé la valeur de l’option dans phpmyadmin.

    J’ai donc l’option par défault pour les permaliens mais j’arrive plus à afficher le blog en lui même. J’ai supprimé le htaccess.

    Si quelqu’un aurait une idée… Merci d’avance à tous.

    #592754
    sheme
    Membre
    Padawan WordPress
    60 contributions

    Auto correction comme dirait les instits…

    Il semble que le probleme vienne du header. Cela dit j’ai sauvegardé ma bdd et j’ai tout réinstallé. Et ça marche.

    #592755
    nledez
    Membre
    Initié WordPress
    1 contributions
    #592756
    lucasw
    Membre
    Initié WordPress
    5 contributions

    Désolé de remonter ce topic, mais si j’ai bien compris, avec free, on est obligé de mettre dans ses permaliens /index.php/ au départ pour que ca marche ? En tout cas moi ca ne marche que quand je fais ca…pas cool.

    Merci

    #592757
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    As-tu strictement suivi le mode d’emploi de la FAQ indiqué au message #2 ?
    Moi, oui, et ça a marché.

    #592758
    lucasw
    Membre
    Initié WordPress
    5 contributions

    Oui j’ai bien fait ca, mais quoi que je fasse, sans le index.php, l’ai l’erreur 500 et je suis obligé de supprimer le contenu de permalink_structure dans la table des matières.

    Merci

    #1626467
    Petoux
    Participant
    Initié WordPress
    3 contributions

    Désolé de remonter le sujet mais @ModoFX m’a sauvé la vie… ça marche enfin ! merci beaucoup !

13 sujets de 1 à 13 (sur un total de 13)
  • Le sujet ‘[Résolu] Mod. Permaliens => Erreur 500’ est fermé à de nouvelles réponses.