[Résolu] MAJ WordPress 3.0/ Message d’erreur

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 32)
  • Auteur
    Messages
  • #483258
    Julie Tiny
    Membre
    Initié WordPress
    10 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : migration vers 3.0
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.julie-nivert.com/lemondedetiny/

    Problème(s) rencontré(s) :

    Bonsoir,

    Comme d’autres membres, j’ai rencontré des soucis avec la mise à jour automatique 3.0 de wordpress.
    Un premier message d’erreur est apparu:

    
    Fatal error: Call to undefined function is_multisite() in /homez.349/julieniv/www/lemondedetiny/wp-includes/wp-db.php  on line 505

    Dans l’impossibilité de me loguer en tant qu’admin sur WP, j’ai donc tenté de faire la mise à jour manuellement – comme indiquéici.– en remplaçant notamment les répertoires wp-includes et wp-admin.

    Voilà ce qui s’affiche depuis sur mon site:

    
    Fatal error: Call to undefined function wp() in /homez.349/julieniv/www/lemondedetiny/wp-blog-header.php  on line 14

    J’ai tenté de restaurer les anciens wp-includes et wp-admin via mon ftp, mais le problème persiste, et j’avoue que je suis un peu perdue…

    Auriez-vous quelques idées pour résoudre le problème?

    Merci, et bonne soirée,

    Julie

    #730448
    A Demain
    Participant
    Initié WordPress
    9 contributions

    Je suis dans la même situation!!! çà me rassure un peu mais une réponse et surtout une solution, rassurera Julie (et moi par la même occasion :p).

    Dans l’attente d’un sauveur ou d’une sauveuse 🙂

    Merci

    #730449
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Avez-vous tenter de faire la mise à jour manuellement via le FTP ?

    #730450
    A Demain
    Participant
    Initié WordPress
    9 contributions

    Je suis en train…on verra le résultat…

    #730451
    A Demain
    Participant
    Initié WordPress
    9 contributions

    Rien ne change de mon côté…

    Est-il possible de réinitialiser, tout en récupérant les archives des posts et commentaires?

    #730452
    A Demain
    Participant
    Initié WordPress
    9 contributions

    voilà ce que donne mon site pour le moment:

    Warning: main(/homez.341/ademain/www/wp-includes/default-constants.php) [function.main]: failed to open stream: No such file or directory in /homez.341/ademain/www/wp-settings.php on line 20

    Fatal error: main() [function.require]: Failed opening required ‘/homez.341/ademain/www/wp-includes/default-constants.php’ (include_path=’.:/usr/local/lib/php’) in /homez.341/ademain/www/wp-settings.php on line 20

    Un docteur, vite un docteur!!!! svp!!!
    :wp:

    #730453
    Jamal
    Membre
    Initié WordPress
    1 contributions

    Bonjour à tous
    j’ai eu le même message d’erreur lorsque j’ai essayé de faire une mise à jour automatique .vers 3.0.

    Pour y remédier je vous conseille de suivre cette petite procédure :

    Télécharger la version 3 manuellement.
    De-zipper le contenu en local
    Transférer les dossiers et fichiers suivant via ftp:

    Dossiers :
    /wp-admin
    /wp-includes

    Fichiers :
    Tous les fichiers de la racine

    Attention : n’écrasez pas le dossier /wp-content car si c’est le cas vous allez perdre tous vos posts.

    Bonne chance 🙂 et ne me remerciez pas JOKE

    #730454
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Pour info les posts sont dans la bases de données (tant qu’on n’y touche pas il n’y a pas de risque). Le dossier wp-content contient les fichiers téléchargés (images, vidéos…), plugins, thèmes. C’est pourquoi il ne faut pas y toucher comme le dit Jamal.

    À la racine, il faut faut conserver le fichier .htaccess (notamment s’il sert à forcer l’usage de PHP5) et sauvegarder avant le fichier wp-config.php histoire d’éviter d’avoir à rechercher tous les paramètres. (Il y a des lignes supplémentaires dans le nouveau wp-config (phrases de sécurité)).

    #730455
    A Demain
    Participant
    Initié WordPress
    9 contributions

    Erreur 404…çà change de tout le charabia d’avant…
    J’ai suivi à la lettre ce que Jamal et fge ont conseillé…je ne sais toujours pas quoi faire…:(

    #730456
    Julie Tiny
    Membre
    Initié WordPress
    10 contributions

    Merci pour vos réponses…J’avais effectivement fait la jour manuellement en écrasant les anciens fichiers (sauvegardés ailleurs en cas de besoin)…mais ça ne change absolument rien!

    #730457
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    Si tu donnais l’adresse du site, cela permettrait d’avoir une idée plus précise du problème. Erreur 404 c’est que la page n’est pas trouvée. C’est lorsque tu cherches à afficher l’index ?

    #730458
    Red-rabbit
    Membre
    Maître WordPress
    688 contributions

    Fge :elle a donné l url de son site; c est elle l initiatrice du post :p
    http://www.julie-nivert.com/lemondedetiny/

    #730459
    Red-rabbit
    Membre
    Maître WordPress
    688 contributions

    Julie n’ecrase pas les fichiers, efface les auparavant; et après tu envoi les fichiers de remplacement.

    #730460
    Franck (fge)
    Modérateur
    Maître WordPress
    9583 contributions

    @Red-rabbit : Mon message s’adressait en fait à A Demain 😉 Julie à posté le message en le moment où j’ai affiché le post et validé la réponse. J’aurais du faire un refresh 😳 Pardon…

    @Julie : As-tu désactivé les plugins avant la MAJ ? (si ce n’est pas le cas renomme temporairement le répertoire plugins cela les désactivera)

    #730461
    Julie Tiny
    Membre
    Initié WordPress
    10 contributions

    @ Red-rabbit :J’ai écrasé les fichiers, sans grand résultat, puis je les ai effacé et remplacé, sans résultat non plus! :]
    @fge: Je vais essayer de renommer le répertoire plugins! 🙂
    Et ce fichier le fichier .htaccess, il se situe où exactement?

15 sujets de 1 à 15 (sur un total de 32)
  • Vous devez être connecté pour répondre à ce sujet.