[Résolu] Ma sidebar est en bas de ma page au lieu d’être sur la droite :(

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #447506
    sebseb
    Membre
    Initié WordPress
    5 contributions

    Bizarre bizarre : http://radiodijoncampus.free.fr/wordpress/index.php

    Ca s’est produit depuis que j’ai créé des articles pour mettre des photos… même mes titres (voir en page 2 du blog ou dans la rubrique vidéo) sont devenus centrés au lieu d’être à gauche comme les autres…

    Je n’arrive pas à trouver l’erreur… qui se retrouve mêm si je change de thème…

    #573154
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Cela veut dire que le code d’un de tes billets n’es pas propre et provoque une erreur ^^

    #573155
    sebseb
    Membre
    Initié WordPress
    5 contributions

    billet = article?

    #573156
    damino
    Participant
    Maître WordPress
    1243 contributions

    Salut. J’ai déjà aidé à résoudre ce genre de problème et comme le disait AmO cela provient souvent d’une erreur de code (des balises en trop ou en moins). Un des moyens de trouver est de soumettre son site à la validation W3C (il y a un lien sur ce forum pour valider son site).

    Sinon j’ai rien vu “d’anormal” sur ton blog …

    Billet ??? … t’es resté trop longtemps sur DotClear non ? (dans ce cas oui billet =article).

    #573157
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Euuuuuh

    Je dis billet, car dans le monde Journaliste, on appelle ca un Billet (sauf erreur de ma part)

    Pi je trouve que c’est original :p
    et oui c’est une idée de dotclear :p

    #573158
    sebseb
    Membre
    Initié WordPress
    5 contributions

    Merci pour les infos, je vais poursuivre sur W3C alors…. sait-on jamais 🙂

    #573159
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Le probleme est résolu ?

    #573160
    sebseb
    Membre
    Initié WordPress
    5 contributions

    plus ou moins…
    disons que j’ai essayé de mettre un plugin pour faire un album photo, et j’ai un nouveau souci !
    je ne peux plus accéder à mon blog maintenant ! le plugin a du foutre la m***e… Disons que je peux ya ccéder via FTP, mais plus par le web :(
    Comment puis-je réparer ça ?

    #573161
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Il marche bien ce blog. J’y ai accès… tu as résolu le problème ?

    #573162
    sebseb
    Membre
    Initié WordPress
    5 contributions

    oui ca y est, j’ai trouvé la réponse sur ce forum : virer le fichier .htaccess du FTP 🙂 (merci Amo d’ailleurs)

    #573163
    Claire
    Participant
    Initié WordPress
    16 contributions

    Help ! Je rencontre le même problème que SebSeb… une sidebar qui se met en bas de ma page ! J’avais déjà rencontré ce problème, lié alors à un div non fermé dans mon header.php.

    Mais là c’est différent :
    – ma sidebar est bien placée quand on consulte une chronique de manière indépendante (exemple : http://web2claire.free.fr/wordpress/index.php/2006/05/11/regarder-la-tele-par-la-fenetre-de-linternet-2/) (remarque: cela ne marche pas pour la 3ème chronique…)
    – mais ma sidebar est décallée sous mes chroniques en page principale :
    http://web2claire.free.fr/wordpress/index.php

    Pour info, ce problème de sidebar arrive un jour après un problème avec les permaliens, dont j’avais modifié le style… grâce au forum, le problème avait été résolu après avoir ajouté /index.php/ avant %year%/%monthnum%/%day%/%postname%/ (enfin, pour info, free a mis une bonne heure pour comprendre le changement… j’ai essayé toutes les combines expliquées et rien ne marchait ! je suis partie manger et au retour, tout était OK !).

    Retour à mon problème de sidebar. Je ne pense pas que cela vient de ma dernière chronique publiée car j’ai un blog local qui tourne avec EasyPHP et la chronique n’entraîne pas un décallage de ma sidebar.
    Et pour info, je n’ai pas de fichier .htaccess à la racine de mon blog hébergé par free (paraitrait que c’est normal, cf une autre discussion dans le forum).

    Si vous avez des idées sur l’origine de ce problème, je suis preneuse !

    Claire
    PS: et oui, moi, je ne parle ni de billets, ni d’articles… mais de chroniques !!!! smile
    Ok, ça a un côté un peu plus “fille” ! Qui vient peut-être du fait que c’est un nom féminin (UNE chronique), au contraire des deux autres (UN billet, UN article) ! smile

    #573164
    damino
    Participant
    Maître WordPress
    1243 contributions

    Claire claire, … regarde un peu le code du post du 3 mai … Il y une balise div en tout début de paragraphe devant “Emarketing Blog …”.
    C’est cette balise non refermée ET inutile qui fait tout foiré.

    Alors j’en profite pour le redire : valider vos sites W3C permet souvent de trouver les erreurs. Sinon utilisez les outils de diagnostic de site. Par exemple j’ai utilisé un plugin Safari (SafariStand) ou une extension FireFox (Webdeveloper) qui permet d’éditer le code de la page (il est édité en “cache” donc tu peux faire les conneries et essais que tu veux sans toucher à ton site en ligne) et donc d’appliquer de modifs et traquer ainsi les erreurs …

    #573165
    Claire
    Participant
    Initié WordPress
    16 contributions

    Merci Damino pour ces conseils. L’erreur ne semblait pas venir du

    de mon post du 3 mai, qui était bien fermé, mais de :

    qui était à la fin de mon post du 15 mai… et merci à W3C d’avoir mis cette erreur en avant !

    Et j’en profite pour vous conseiller d’installer l’extension Firefox de Jennifer Madden : “View Source Chart” qui permet de créer a Colorful Chart of a Webpage’s Rendered Source Code :
    http://jennifermadden.com/scripts/ViewRenderedSource.html

    #573166
    ramenian
    Membre
    Chevalier WordPress
    167 contributions

    Ayant déjà eu le même souci, c’est souvent une balise mal fermée qui fiche la pagaille 🙂

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.